Jump to content
Sign in to follow this  
tHaHooL

Routing / ICS mit mehreren Adaptern (auf WAN & LAN Seite)

Recommended Posts

Hallo zusammen!

 

Ich bin gerade dabei ein kleines Problem zu lösen, brauche aber noch etwas Hilfestellung dazu. Ich habe ein System welches auf WAN-Seite

 

1x WLAN

1x UMTS

 

hat. Über diese beiden Adapter wird also die Verbindung ins Internet hergestellt. Ich möchte diese Internetverbindung(en) nun an 2 weitere Adapter "weiterreichen". Diese sind

 

1x LAN (hier hängt direkt ein onlinefähiges Endgerät dran)

1x VWLAN (Microsoft Virtual WiFi Adapter / Hotspot)

 

Die Verbindungen an sich habe ich schon, nur gibt es nun das grundlegende Problem, dass ich via ICS nur eine Verbinung sharen kann. Ich kann also z. B. die WLAN Verbindung via ICS an meinen VWLAN-Adapter (Hotspot) weiterreichen, aber nicht gleichzeitig noch an den LAN-Adapter.

 

Oder aber ich kann via ICS nicht gleichzeitig die WLAN Verbindung UND die UMTS Verbindung zu einem "internen" Adapter (VWLAN / LAN) weiterreichen, so dass -je nach dem- ob per WLAN oder UMTS was reinkommt, immer eine Verbindung möglich ist.

 

Wie würdet Ihr das lösen?

Kann man da mittels routing was anständiges auf die Beine stellen?

 

Vielen Dank!

Share this post


Link to post
Share on other sites

Das ganze läuft auf einem kommerziellen Projekt und ich wollte vorher mal die Möglichkeiten abklopfen die Windows von sich aus bietet.

 

An einen Proxyserver (auch kostenpflichtig) hatte ich auch schon gedacht, aber das führt halt oft zu Problemem wenn z. B. ein Gerät an den internen Hotspot angemeldet ist und bestimmte Ports (ausserhalb von den Standards 21,80,443, usw.) benötigt.

 

Oder gibt es hier mittlerweile "transparente" Proxyserver?

Sorry, habe fast 10 Jahre lang nichts mehr mit Proxys gemacht.

 

Sollte es ohne Proxy gehen wäre mir dennoch eine systemeigene Lösung lieber.

Share this post


Link to post
Share on other sites

Jetzt habe ich was gefunden was exakt mein Szenario abdeckt:

IP Forwarding - How to make Windows XP as a Router

 

Leider funktioniert es bei mir noch nicht so wie es soll - die Konfiguration habe ich exakt wie im Beispiel vorgenommen, der Schalter IPEnableRouter ist auf "1" gesetzt, aber an den Clients kann ich bisher noch nicht ins Internet Pingen / darauf zugreifen.

 

Der Unterschied zu dem gespostetem Beispiel liegt noch im Betriebssystem (ich habe Win7) sowie dass der Zugang am "Server" über WLAN erfolgt.

Die Firewall habe ich zum testen auch mal deaktiviert.

 

Hat jemand eine Idee was ich noch testen könnte?

Share this post


Link to post
Share on other sites

Kommerzielles Projekt und Windows 7 mit ICS/Routing ? Da passt irgendwas nicht ...

Wenn Du mit dem 7er routest, dann ist das kein NAT mehr. Kennt der Internetrouter die Rückroute in die ihm abgewandten Netzwerke hinter dem 7er-Router ?

Edited by IThome

Share this post


Link to post
Share on other sites

Eigentlich ist eis WES7 (ist aber weitgehend mit dem "normalen" Win7 identisch).

Einen externen Router kann ich leider nicht verwenden, soll ja alles in einem Gerät abgebildet werden.

 

Ich habe soweit alles am laufen, die Schnittstellen sind alle Bereit, DHCP läuft, was noch fehlt ist ein NAT auf Windows Ebene - dann wäre alles soweit fertig. Nur leider gibt es scheinbar das NAT nur in abgespeckter Variante als ICS, was wiederum aber nur 1 Adapter ansprechen kann und nicht mehrere gleichzeitig / parallel.

 

Unter NAT32 Windows Software Router Home Page (31. December, 2011) gäbe es da scheinbar eine Lösung dazu, besser wäre es natürlich mit Windows Bordmitteln, da bin ich eben noch auf der Suche.

Share this post


Link to post
Share on other sites

Ok - danke für die Rückmeldung.

Also in WES7 habe ich zumindest den Dienst "Routing and Remote Access Service" - scheinbar hat Windows Embedded das also mit an Board :confused:

Eine Konfigurationsoberfläche wie bei den Server Versionen finde ich aber bei Embedded leider trotzdem nicht...

 

EDIT

Habe gerade gesehen - der Dienst ist im normalen Win7 auch integriert - scheint also wohl in diesem Falle nicht von Bedeutung zu sein.

Edited by tHaHooL

Share this post


Link to post
Share on other sites

Hallo,

 

auch wenn das nicht ganz hier hin passt... Ich bin durch mein Problem auf diesen Thread gestoßen, vielleicht geht es ja anderen genauso.

Ich wollte in Windows 7 eine einzige Internetverbindung über zwei andere Adapter freigeben. Da man aber nur eine Verbindung zur Freigabe auswählen kann, ist dies nicht ohne weiteres möglich.

Die Lösung ist eine Netzwerkbrücke. Diese muss für die Adapter, für die die Internetverbindung freigegeben werden soll, erstellt werden. Anschließen gibt man die Internetverbindung für die Netzwerkbrücke frei. Das hat bei mir problemlos funktioniert.

Vielleicht hilft das ja jemandem :)

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...