Jump to content
Sign in to follow this  
VoHa

Probleme mit neuem Win2003 Server

Recommended Posts

Hallo,

 

vor einigen Wochen wurde bei uns das "gute alte Novell Netware" durch Win2003 (55 Lizenzen) ersetzt. An Verkabelung (CAT5) und Switches (Netgear 3x 24 Port 100 MBit, 4x 1000 MBit) wurde nichts verändert.

 

Ich muss nun etwas weiter ausholen, um die Probleme zu erklären.

 

Auf dem neuen Win2003-Server laufen lediglich zwei Datenbankanwendungen (1x MSAccess, 1x branchenspezifische Software mit unbekanntem Format). Der Server beinhaltet nur die eigentlichen Datenbänke, die ausführbaren Dateien sind auf den Clients installiert (WinXP Pro und Win2k SP4).

Domäne wurde nicht eingerichtet, sondern lediglich die Arbeitsgruppe, die in den Clients bereits eingerichtet war und somit eine notwendige Umkonfigurierung der Clients überflüssig machten.

Auch DHCP, DNS, active directory und dergleichen wurden auf dem Server nicht eingerichtet, sondern lediglich eine feste IP-Adresse vergeben (Die 55 Clients haben ebenfalls alle eine feste IP-Adresse).

 

Um sich offenbar das Anlegen von Usern/Gruppen zu ersparen, wurde von der beauftragten Firma auf dem Server lediglich 1 Benutzer angelegt, dem die entsprechenden Rechte auf dem Datenbankordner zugewiesen wurden.

 

Die Clients wurden dann dergestalt modifiziert, dass eine Batch-Datei in die Autostart der "All User" eingebunden wurde, die sinngemäss in etwa lautet:

net use \\192.168.0.100\DatenbankOrdner benutzername passwort /persistant=yes

 

Mit dieser Batch klappt jedenfalls nicht immer die Anmeldung am Server, sondern es ist oft die Neuanmeldung des Clients mit START - ABMELDEN und erneutem Anmelden nötig. Dann funzt's in der Regel.

 

Nach der Anmeldung läufts dann in der Regel störungsfrei, bis auf die Eigenart, dass der Server nach einiger Zeit (ca. 15 bis 30 Minuten), wenn die Workstation "untätig" ist, die Netzverbindung trennt (rotes X im Windows-Explorer am Netzwerklaufwerk). Beim Zugriffsversuch auf das Netzlaufwerk, z.B. zum Speichern eines Word-Dokumentes wird dieses zwar wiederhergestellt, aber es erfolgt zunächst eine Fehlermeldung von Word, dass das Netzverzeichnis nicht verfügbar ist, ein Speichern in den entsprechenden Ordner ist danach aber möglich. Die Fehlermeldung ist dennoch lästig.

 

Weiter auffällig ist auch, dass das Antwortverhalten des Servers relativ "träge" ist (jedenfalls erheblich langsamer als beim alten Novell Netware Server). Beispielsweise benötigt das Öffnen einer Word, Excel oder Access-Datei ca. 3-4 Sekunden - könnte allerdings auch mit dem auf dem Server installierten McAfee Virenscanner zusammenhängen, der ständig "aktiv" ist.

 

 

So, das war ja einiges. Vielleicht hat einer von euch ein paar gute Tips für einen Win2003 Laien.

 

Volker

Share this post


Link to post
Share on other sites

Die Clients wurden dann dergestalt modifiziert, dass eine Batch-Datei in die Autostart der "All User" eingebunden wurde, die sinngemäss in etwa lautet:

net use \\192.168.0.100\DatenbankOrdner benutzername passwort /persistant=yes

 

Mit dieser Batch klappt jedenfalls nicht immer die Anmeldung am Server, sondern es ist oft die Neuanmeldung des Clients mit START - ABMELDEN und erneutem Anmelden nötig. Dann funzt's in der Regel.

 

Dann setz die in der No. 36 genannten Einstellungen auf jedem XP-Client: FAQ-GPO

 

Nach der Anmeldung läufts dann in der Regel störungsfrei, bis auf die Eigenart, dass der Server nach einiger Zeit (ca. 15 bis 30 Minuten), wenn die Workstation "untätig" ist, die Netzverbindung trennt (rotes X im Windows-Explorer am Netzwerklaufwerk).

 

Die Lösung für die roten Kreuze ist hier genannt: Windows 2000 - FAQ

 

Weiter auffällig ist auch, dass das Antwortverhalten des Servers relativ "träge" ist (jedenfalls erheblich langsamer als beim alten Novell Netware Server). Beispielsweise benötigt das Öffnen einer Word, Excel oder Access-Datei ca. 3-4 Sekunden - könnte allerdings auch mit dem auf dem Server installierten McAfee Virenscanner zusammenhängen, der ständig "aktiv" ist.

 

Du könntest testweise den AV-Scanner komplett deinstallieren, deaktivieren reicht meistens nicht. Ich tippe aber eher auf das SMB-Signing: SMB Signing - Einstellungen für: Kommunikation digital signieren

Auch hier gilt wieder, stell das auf dem Server und auf den Clients gleich ein. Spätestens jetzt solltest Du über eine Domain nachdenken. Denn die o.g. Änderungen machst Du auf jedem Client einzeln, bei einer Domain wird das zentral am Server verwaltet, die Clients können sich gar nicht wehren.

Share this post


Link to post
Share on other sites

Tja, ich denke mit der Arbeitsgruppe werdet Ihr da dauerhaft keine Freude haben.

 

Auch unter Novell 2, 3 oder 4 (wenn man mal von "alten" Novellservern sprechen will) gab es eine zentrale Netzwerk Anmeldedatenbank (Bindery) die später unter 4 zur NDS (und heute zum eDirectory) geworden ist. Mit der Arbeitsgruppe habt Ihr sowas nun nicht mehr und müsst Euch nach Deiner Schilderung mit Anmeldekrücken a la "ich melde mal per Batch nen lokalen User an" herum schlagen, die eben mal und mal nicht funktionieren, was auch kein Wunder ist.

 

Entweder Ihr legt alle Client-User auch auf dem Server an oder Ihr kehrt zu einer Netzwerk Anmeldedatenbank und zentralen Usern zurück, da muss es ja kein Novell sein, da reicht durchaus ein Linux Server mit Samba oder aber falls vorhanden ein anderer Windows Server und darauf ein Active Directory.

 

So jedenfalls werden Dich/Euch solche Probleme dauerhaft verfolgen. Ach und bei der Gelegenheit würde ich mich nach einem neuen externen Partner Ausschau halten, der mehr Kompetenz hat, denn das was die beauftragte Firma da abgeliefert hat, halte ich für Bastelei und wenig Kompetent.

 

Grüsse

 

Gulp

Share this post


Link to post
Share on other sites

Ach und bei der Gelegenheit würde ich mich nach einem neuen externen Partner Ausschau halten, der mehr Kompetenz hat, denn das was die beauftragte Firma da abgeliefert hat, halte ich für Bastelei und wenig Kompetent.

 

richtig, das war Pfusch.

Als erstes würde ich DNS, WINS & DHCP am Server einrichten und vernünftig konfigurieren. Dann muss halt ein Praktikant / Azubi einmal an alles Rechner laufen und auf dynamische IP umstellen, das ist in 2h erledigt. Wenn die Namensauflösung ordentlich funktioniert läuft das mit Netzlaufwerken doch deutlich besser.

Auf Dauer werdet ihr aber nur mit AD und Domänenbenutzern glücklich werden...

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...