Jump to content
Sign in to follow this  
Alexander

Ping geht nicht mehr

Recommended Posts

Hallo,

 

ich habe oder besser hatte eine Netzwerkverbindung von einem XP-home-edition und einem 98-first-edition PC. Die beiden Rechner sind über ein Cross-Connect-Kabel verbunden, die IP-Adressen sind fest vorgegeben. Nach ein paar Problemen (DNS-Konfiguration aktivieren am 98er notwendig) funktionierte dieses einige Monate sehr gut.

 

Nach ein paar Möbelschiebaktionen am 98er Rechner - glaub(t)e ich - wurde die Verbindung unterbrochen bzw. instabil.

 

1. Nach Aus- und Einbau der Netzwerkkarte am 98er kam das Netzwerk immer mal wieder zurück. Auch als ich einen anderen PCI-Steckplatz für die Netzwerkkarte verwendet habe.

 

Nach ein paar Wochen verabschiedete sich das Netzwerk mitten in einem Spiel übers Netz, wobei der XP-Rechner neu gebooted werden musste. Seit dem geht kein ping mehr zum anderen Rechner.

 

2. Da ich einen Wackelkontakt vermutet habe, habe ich mir zunächst ein Kabel von einem Freund ausgeliehen, was keine Verbesserung erzielte.

 

3. Die Netzwerkkarte vom 98er wurde als nächstes von mir getauscht - dennoch kein 'ping' möglich.

 

Fehlerbild:

- ping auf die lokale Adresse und 127.0.0.1 funktioniert auf beiden Rechnern

- ping auf den anderen Rechner endet mit 100% Verlust

- wird der 98er heruntergefahren, quittiert dies der XP mit "Netzwerkkabel" nicht verbunden

- stellt man den XP von 100MHz auf 10MHz Vollmodus Übertragungsrate, schaltet die Karte am 98er sichtbar durch LCD auch auf diesen Modus um

- booted man den XP, wenn der 98er schon oben ist, dann gibt es kurz darauf eine kurze Plattenaktivität am 98er, aber der Verbindungsaufbau scheint irgendwie abgebrochen zu werden

 

Hat irgendjemand eine Idee wie man den Fehler weiter einkreisen könnte oder gar woran es liegen könnte?

 

Danke im voraus

Share this post


Link to post

Hallo,

 

Vorschläge:

1.) bei beiden Karten in den Eigenschaften/erweiterte Eigenschaften die Übertragungsgeschwindigkeit fest auf 100BaseTX stellen. Kann möglicherweise etwas anders heißen, je nach Treiber.

2.) Gib in einer DOS-Box den Befehl ifconfig /all ein und poste beide Ergebnisse mal hier.

 

Ein Konnekt haben beide Karten (siehe deine Anmerkung "wird der 98er heruntergefahren, quittiert dies der XP mit "Netzwerkkabel" nicht verbunden"). Typisch für TP-Kabel, wenn Hub (bei X-Over der andere PC) weg ist.

 

Daher würde ich eher auf eine IP-Problematik tippen.

 

Grüße

Olaf

Share this post


Link to post
Original geschrieben von edv-olaf

Hallo,

 

Vorschläge:

1.) bei beiden Karten in den Eigenschaften/erweiterte Eigenschaften die Übertragungsgeschwindigkeit fest auf 100BaseTX stellen. Kann möglicherweise etwas anders heißen, je nach Treiber.

2.) Gib in einer DOS-Box den Befehl ifconfig /all ein und poste beide Ergebnisse mal hier.

 

Ein Konnekt haben beide Karten (siehe deine Anmerkung "wird der 98er heruntergefahren, quittiert dies der XP mit "Netzwerkkabel" nicht verbunden"). Typisch für TP-Kabel, wenn Hub (bei X-Over der andere PC) weg ist.

 

Daher würde ich eher auf eine IP-Problematik tippen.

 

Grüße

Olaf

 

-----------------------------------------------------

Hallo Olaf,

 

1) die Übertragungsrate habe ich von 100 full duplex bis 10 half verändert ohne Erfolg

 

2) hier der Output von ipconfig

ipconfig /all @XP-Rechner:

 

C:\Dokumente und Einstellungen\Owner>ipconfig /all

 

Windows-IP-Konfiguration

 

Hostname. . . . . . . . . . . . . : Calvin

Primäres DNS-Suffix . . . . . . . :

Knotentyp . . . . . . . . . . . . : Peer-Peer

IP-Routing aktiviert. . . . . . . : Ja

WINS-Proxy aktiviert. . . . . . . : Nein

 

Ethernetadapter Netzwerkbrücke:

 

Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : MAC-Brückenminiport

Physikalische Adresse . . . . . . : E2-8C-43-41-F2-C8

DHCP aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.0.1

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

Standardgateway . . . . . . . . . :

 

-----------------------------------------

 

ipconfig /all @98er-Rechner:

 

Windows 98 IP-Konfiguration

 

Hostname . . . . . . . . . : Calvin

DNS-Server . . . . . . . . : 192.168.0.1

Knotentyp . . . . . . . . . : Broadcast

NetBIOS-Bereichs-ID . . . . :

IP-Routing aktiviert. . . . : Nein

WINS-Proxy aktiviert. . . . : Nein

NetBIOS-Aufl”sung mit DNS . : Ja

 

0 Ethernet Adapter :

 

Beschreibung. . . . . . . . : Realtek 8139-series PCI NIC

Physische Adresse . . . . . : 00-50-FC-A9-CF-41

DHCP aktiviert. . . . . . . : Nein

IP-Adresse. . . . . . . . . : 192.168.0.2

Subnet Mask . . . . . . . . : 255.255.255.0

Standard-Gateway . . . . . . : 192.168.0.1

Erster WINS-Server . . . . :

Zweiter WINS-Server . . . :

Gltig seit. . . . . . . :

Gltig bis . . . . . . . :

 

Gruß Alexander

Share this post


Link to post

hi,

 

wenn ich das richtig gelesen habe, haben beide rechner den selben namen oder war das nur ein schreibfehler?? versuch doch mal von jedem rechner aus die eigene ip anzupingen, also die 192.168.0.1 vom xp aus und .2 vom 98er aus

 

gruß sparcy

Share this post


Link to post

Hallo,

 

der Name des 98er-Rechners lautet anders ('hobbes') und ist so auch eingetragen. Da aber 'calvin' als Gateway und DNS Host beim 98er eingetragen ist, aber er mit diesem keine Verbindung zustande kommt, bildet sich der 98er nun irgendwie ein, er sei wohl 'calvin'.

 

Er reagiert daher beim ping nicht richtig auf die Rechnernamen, aber das Kritische ist wohl, dass die Rechner mit der IP-Nummer keinen Kontakt bekommen.

 

Gruß

Share this post


Link to post

Also ich würde noch mal beim 98er in der Netzwerkkonfiguration nachschauen, ob der Hostname wirklich stimmt, denn der wird ja wohl eigentlich kaum über DNS bezogen, oder täusch ich mich da.

 

Und wie pingst du den jeweils anderen Rechner an? Mit 'ping Rechnername' oder mit 'ping IP-Adresse'? Denn wenn du nur den Rechnernamen anpingst, könnte es auch am Nameserver liegen.

Share this post


Link to post

Hallo,

 

zum Überprüfen benutze ich immer die IP-Adresse, da der 98er mit den Namen nicht klar kommt, solange es keine Verbindung mit dem XP-Rechner gibt.

 

Vielleicht bedingt durch die alte 98er-Betriebssystemversion gab es früher auch immer Probleme mit der Namensauflösung, aber mit 'DNS Konfiguration aktivieren' und dem Eintrag vom XP-Rechner als Gateway - war ein Typ von 'zuschauer' auf dieser Page - hat es dann funktioniert.

Share this post


Link to post
Original geschrieben von Alexander

Vielleicht bedingt durch die alte 98er-Betriebssystemversion gab es früher auch immer Probleme mit der Namensauflösung, aber mit 'DNS Konfiguration aktivieren' und dem Eintrag vom XP-Rechner als Gateway - war ein Typ von 'zuschauer' auf dieser Page - hat es dann funktioniert.

Hi Alex, ich war jetzt erstmal geschockt, weil ich mich an Dein Problem nicht erinnern konnte. :cry:

Den XP solltest Du als default gateway eintragen, da auf dem XP ICS läuft.

Ich war bisher der Meinung, den Befehl IPCONFIG gibt es nicht unter Win98 (ich kenn nur winipcfg.exe).

Hast Du auf dem Win98 wirklich ipconfig /all abgesetzt ?

Daß du kein Ping name zum XP abesetzen kannst, wen der aus bzw. nicht erreichbar ist, ist ja normal.

Du hast geschrieben, nach einem Crash mitten im Spiel mußtest Du den XP neu starten.

Ich vermute eher ein Problem am XP. Da der direkt am Internet hängt - ist dort eine Firewall drauf ?

Share this post


Link to post

Hallo Zuschauer,

 

ja ipconfig /all läuft auf meinem 98er. Wenn ich 'DNS aktivieren' abschalte, dann meldet er sich auch ohne erfolgreichen Verbindungsaufbau mit seinem 'richtigen' 98er-Namen.

 

Der XP geht über DFÜ/Provider ans Internet. Hier kann ich den Internetfirewall einschalten (mein Default) oder abschalten (habe ich zwischendurch mal ohne Erfolg probiert) - meinst du diesen Schalter?. Bei meiner Netzwerkbrücke - die der XP für den LAN-Access eingerichtet hat - kann ich nach meinem Wissen keinen Firewall aktivieren ???

 

Gruß Alexander

Share this post


Link to post

Hallo,

 

die Hostnamen dürfen nicht identisch sein! Sonst antwortet der XP ja dem 98-er "Calvin", was der XP aber selber ist. Andersrum würde der XP an "Calvin" (den vermeintlichen 98-er) senden, was er aber selber ist. Somit ist klar, dass keine Kommunikation zustande kommen kann.

 

Also, nochmal prüfen, warum der 98-er "Calvin" als Namen hat / bekommen hat und den Fehler beheben. Dann solltest du der Lösung einen Schritt näher gekommen sein. Mit diesem redundanten Host-Namen brauchst du IMHO nicht weiter probieren, eine Verbindung herzustellen, es würde nicht funktionieren.

 

Grüße

Olaf

 

PS: @zuschauer: Warum sollte ipconfig auf W98 nicht funzen? winipcfg geht nicht auf NT und folge-BS, das ist OK. :)

Share this post


Link to post

@alex

Poste mal bitte die Ausgabe des Befehls "route print" auf dem XP. Ich habe den leisen Verdacht, das dort irgendetwas nicht ok ist. Kann mich aber auch täuschen.

Grüße

Olaf

Share this post


Link to post
Original geschrieben von edv-olaf

PS: @zuschauer: Warum sollte ipconfig auf W98 nicht funzen? winipcfg geht nicht auf NT und folge-BS, das ist OK. :)

Sag ich doch, ich wußte nicht, daß es ipconfig auch bei Win98 gab/gibt.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...