Jump to content
Sign in to follow this  
StefanWe

OMA - Keine Berechtigung

Recommended Posts

Hi,

ich wollte mal versuchen mit meinem PDA ( Windows Mobile 2003 ) auf meinen Exchange zuzugreifen. Das ganze erstmal ohne SSL, ja ich weiß, Kennwörter werden unverschlüsselt übertragen usw.usw, aber ich wollte es erstmal so zum laufen bekommen.

Nur leider scheitert es hier schon.

 

Nachdem ich die GPRS Verbindung aufgebaut habe und im ActiveSync auf Synchronisieren drücke, wird eine Verbindung zu meinem Exchange aufgebaut, dies scheint auch einwandfrei zu funktionieren. Nur sobald Änderrungen gesucht werden, bricht das ganze ab und es erscheint folgende Fehlermeldung:

 

Sie sind nicht berechtigt, mit Ihren aktuellen Einstellungen eine Synchronisierung durchzuführen. Wenden Sie sich an Ihren Microsoft Exchange Administrator.

 

Fehlercode http_403

 

wenn ich den pda allerdings per Kabel an meine nDesktop anschließe kann ich über activesync wunderbar alle termine, emails usw synchroniseren.

 

Im Benutzerprofil ist Outlook mobile access aktiviert.

Share this post


Link to post
Share on other sites

ja sbs2003. Sp1 und beim Exchange auch sp2 installiert.

 

Wie gesagt, ich wollte es erstmal ohne SSL versuchen.

 

Ja so wie auf MSexchangefaq Seite bin ich vorgegangen.

überall ist mobile access aktiviert.. soweitich das gesehen habe.

 

SSL ist nicht aktiviert im IIS.

Share this post


Link to post
Share on other sites

also ich kann bei meinem windows mobile 2003 einen activesync server einrichten. die Verbindung zum Server wird ja auch einwandfrei aufgebaut, nur kommt dann halt die Fehlermeldung mit der Berechtigung.

Share this post


Link to post
Share on other sites
Geht das nicht erst ab Windows Mobile 5?

Korrekt, für Direct Push muss es mind. Windows Mobile 5, und dabei auch ein MIndestversionstand sein. Den müsste ich aber raussuchen.

 

grizzly999

Share this post


Link to post
Share on other sites

mh ja. nur möchte ich direct push ja nicht nutzen, sondern ich möchte, wenn der Benutzer an seinem PDA auf Synchronisieren klickt, der DA per GPRS eine Verbindung zu meine mExchange aufbaut(was ja auch einwandfrei funktioniert) und dann die Daten abgleicht(was nicht funktioniert, denn da kommt ja der Berechtigungsfehler).

Und ich finde immernoch nicht den haken wo ich dazu noch eine Berechtigung setzen muss.

 

Das ganze zur Zeit auch ohne SSL um einen Fehler in Zertifikaten auszuschließen.

Share this post


Link to post
Share on other sites

####

Nachdem ich die GPRS Verbindung aufgebaut habe und im ActiveSync auf Synchronisieren drücke, wird eine Verbindung zu meinem Exchange aufgebaut, dies scheint auch einwandfrei zu funktionieren. Nur sobald Änderrungen gesucht werden, bricht das ganze ab und es erscheint folgende Fehlermeldung:

###

Kann es sein das der Zugriff mit einer "EXTERNEN" IP nicht gestattet ist ?

Nur mit einer localen ? Firewall ?

Share this post


Link to post
Share on other sites

also im IIS ist keine Einschränkung eingetragen, das nur bestimmte IPs Zugriff haben.

Es ist eine fast frische SBS 2003 Installation. Also nichts irgendwie verwuselt. Habe nur OMA aktiviert. OWA funktioniert ebenfalls wunderbar.

 

Die Firewall leitet Port 80 zu dem SBS2003 Server weiter. Weitere Ports sind nicht weitergeleitet. von Innen allerdings ist Port 80 nach außen geöffnet. Firewall ist von Securepoint die nx2007

Share this post


Link to post
Share on other sites

ich habe mich nocht nicht mit dem Thema AS auseinander gestetzt plane es aber... mittelfristig.

Habe folgendes gefunden:

 

pocket-expert.de » FAQ: ActiveSync

###

Verwendete Ports

ActiveSync verwendet die folgenden Ports:

 

* 990 - RAPI Request

* 999 - Time Server

* 5678 - Synchronization Information

* 5679 - Heartbeat

* 7428 - ovladmgr Common service

Falls die Personal Firewall Schwierigkeiten macht, sollte man diese Ports freischalten.

 

###

Share this post


Link to post
Share on other sites

Hast mal testweise noch den 443 in der FW freigemacht? Der SBS leitet ja zB http-Anfragen für OWA automatisch auf https um, evtl macht der das auch mit OMA-Anfragen. Weiß ich grad net 100%ig, wäre aber gut möglich.

Share this post


Link to post
Share on other sites

Hi.

 

Ohne gültiges zertifikat wirst du meiner Meinung nach da überhaupt keine Chance haben

 

Versuche einmal folgende Vorgangsweise:

 

am SBS Server:

- starte den Assistenten für den Internetzugang.

- gib der Seite für die Webdienstekonfiguration den Zugriff au Outlook Mobil Access frei

- erstelle wenn notwendig ein neues Zertifikat, dass genau auf den Namen lautet, über dass dein Server aus dem Internet erreichbar ist (wenn z.B. der Server über webmail.sbspraxis.de erreichbar ist, dann muss auch dass Zertifikat auf webmail.sbspraxis.de lauten)

- das erstellte Zertifikat solltest du dann zu weiteren Verwendung am SBS im Ordner ClientApps\SBSCert finden

 

- wenn nein:

- starte auf einem Arbeitsplatz den IE und geife auf OWA zu

- wenn die Zertifikatsfehlermeldung kommt, dann klicke beim IE7 auf die Statusmeldung "Zertifikatsfehler" und wähle Zertfikat installieren

- starte den Assistenten Zertifikat installieren, und wähle als Zertfikatsspeicher "Vertrauenwürdige Stammzertfizierungstellen"

- starte OWA erneut, es darf jetzt keine Zertfikatsfehlermeldung mehr kommen

- klicke im IE7 anschließend auf das Schloßsymbol -> Zertfikat anzeigen -> Register Details -> in Datei kopieren -> wähle DER-codiert-binär X.509

- kopiere das Zertfikat auf deinen PDA

 

am PDA:

- importiere das Zertifikat, es sollte sich nach dem Importvorgang im Speicher "Stammzertifikate" befinden, anschließend

- ActiveSync -> Extras -> Optionen -> Register Server

- im Feld "mit Server synchronisieren" den FQDN deines Servers eingeben und zwar im Format -> webmail.sbspraxis.de - also genau so wie er auf deinem Zertfikat lautet

- anschließend unter Optionen Benutzername, Passwort und Anmeldedomain angeben

- für die automatische Synchronisation muss die Checkbox "Kennwort speichern" aktiviert sein

 

Mit dieser Vorgangsweise habe ich bis jetzt noch jeden PDA mit Windows Mobil 2003 (sogar mein eigener ;)) zum Laufen gebracht.

 

LG Günther

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...