Jump to content
Sign in to follow this  
techabteilung

Windows 2000 Server mit 2 NICs - DNS-Problem

Recommended Posts

Hallo. Mein 1. Posting und gleich ne Frage. Keine Angst: ich geb auch Antworten.

 

Ich hab ein Problem mit einem Windows 2000 Server, der 2 Netzwerkkarten hat.

Der Server ist DomänenController, DNS-Server und DHCP-Server. Außerdem existiert noch ein zweiter Server, der als BackupDomänenController dient.

 

In beiden Servern (nennen wir sie mal Server1 und Server2) sind jeweils 2 Netzwerkkarten eingebaut. Jeweils 1 Karte ist im LAN und die jeweils 2. Karte ist mit einem BackupServer verbunden (einfach n Fileserver mit richtig Platz).

 

Die Karten für's LAN sind 100Mbit und die für's Backup sind Gbit-Karten. (sorum gewählt, weil täglich etwa 100Gb Daten für's Backup anfallen, die über Nacht gesichert werden müssen)

 

Die LAN-Karten haben den IP-Bereich 192.168.1.x und die Backup-Karten den Bereich 192.168.3.x. In den TCP/IP-Optionen der Backup-Karten hab ich im Registerreiter DNS die Option "Adressen dieser Verbindung in DNS registrieren" deaktiviert. Das gleiche auf den beiden Karten, die im BackupServer stecken. Stattdessen hab ich auf Server1 und Server2 in der HOSTS-Datei die IP-Adressen des Backup-Servers eingetragen. Und zwar nur die Adresse, an die die Netzwerkkarte im Server(1,2) angeschlossen ist.

 

Verstanden? Der Backup-Server hängt nicht im LAN sondern ist nur mit Server1 und Server2 verbunden - jeweils mit einer eigenen Gigabit-Karte.

 

Mein Problem: In der DNS-Tabelle auf Server1 und Server2 stand am Anfang die IP-Adresse der jeweils 2. Karte mit drin. Wenn man den Server1 oder Server2 dann gepingt hat bekam man manchmal die Adresse im 192.168.1.x-er Bereich und hatte somit normalen Zugriff. Aber manchmal bekam man auch die 192.168.3.x-er Adressen angezeigt und die sind ja vom LAN aus nicht erreichbar. Ist ziemlich schlecht so.

Nachdem ich die oben genannten Änderungen in den DNS-Optionen und den HOSTS-Dateien gemacht hatte und dann noch die falschen Adressen (192.168.3.x) aus der DNS-Tabelle gelöscht hatte lief alles reibungslos. 3 Monate lang. Bis jetzt.

 

Jetzt hab ich die 192.168.3.x-er Adressen schon wieder in den DNS-Tabellen. Und wenn ich die bei beiden Servern raus lösche, dann dauert's n paar Minuten und die sind wieder drin.

 

Wie bekomm' ich das hin, dass die IPs der Gigabit-Karten nicht in der DNS-Tabelle landen? Da soll nur die jeweilige 192.168.3.x-er IP des Backup-Servers drin sein (wie in der HOSTS eingetragen).

 

Wer irgend ne Idee dazu hat... bitte dringend posten! Ist ne schlimme Sache, wenn man außendienst-Mitarbeiter hat die sich per VPN verbinden und die nicht arbeiten können, weil der VPN-Client die falschen Server-IPs geliefert bekommt.

 

Danke schonmal im Voraus.

Share this post


Link to post

Hi,

kannst Du nicht eine statische route auf Server1+2 setzen so das Daten die in das

Backup-Netz gehen sollen über ein bestimmtes Interface gehen? Z.B.:

route ADD 192.168.3.0 MASK 255.255.255.0 192.168.3.'Server1' IF 2

Ziel^ ^Subnet ^Gateway ^Interface (2te NIC)

Gib mal auf der Kommandozeile "route print" ein, da siehst Du deine Interfaces.

Hast Du schonmal den DNS-Cache geleert? (ipconfig /flushdns)

 

Gruß,

Andreas

Share this post


Link to post

Entferne die Einträge der Karten und konfiguriere die DNS-Server so, dass sie nur auf der Adresse des LANs horchen. Setze die Karte des LANs in der Bindungsreihenfolge an die erste Stelle und starte nach diesen Aktionen die Server neu. Eigentlich sollten die Hosteinträge des anderen Netzes nicht zurückgeliefert werden, wenn Netmaskordering in den DNS-Serveroptionen angeschaltet ist (wenn sich beide Karten registrieren). Die Registrierung erfolgt, weil die Server auf beiden Adressen horchen und registrieren diese auch ...

VPN-Clients ? Läuft auf einem der Server auch ein RRAS ? Wenn ja, dann konfiguriere auch noch folgendes ...

Name resolution and connectivity issues on a Routing and Remote Access Server that also runs DNS or WINS

Share this post


Link to post

Ergänzend zu ITHome:

auf der GigaBitkarte, Eigenschaften, TCP, Reiter dns

Diese Verbindung in DNS registrieren --> Haken raus

Reiter Wins - kein NBT over TCP

Share this post


Link to post

Die Haken bei "Diese Verbindung in DNS registrieren" hab ich schon im Januer raus genommen und hatte danach keine Probleme mehr. Hab auch den DNS-Cache schon geleert (auf beiden Servern), beide Server neu gestartet, Reihenfolge der NICs auch schon kontrolliert. Im LAN läuft alles ganz normal. Gehe mal davon aus, dass die Clients immer die richtige IP des Servers haben, weil der bei denen als DNS eingetragen ist.

Mein Problem hab ich nur, wenn ich mich über VPN mit dem Server verbinden will. Wenn ich den dann mit dem Namen pinge, bekomme ich die falsche IP zurück. Wenn ich die richtige IP anpinge komm ich ohne Probleme auf den Server. Aber Outlook macht halt Probleme, weil das ja nicht mit den IPs auf den Exchange zugreift, sondern den NetBios-Namen benutzt.

 

@IThome:

Läuft kein RAS-Dienst drauf. VPN geht über einen D-Link VPN-Router der im LAN hängt und auf den Aussendienst-Notebooks halt der D-Link-VPN-Client.

Kein NetBios über TCP: kann ich das machen? Ich MUSS über den Namen auf den Backup-Server zugreifen können. Geht nicht anders. BackupExec arbeitet nicht zuverlässig, wenn ich's über die IP-Adresse oder über ein Netzlaufwerk versuche.

 

Das mit dem Konfigurieren, dass der DNS-Server nicht mehr auf der 2. Karte lauscht werd ich gleich mal überprüfen. Trägt der DNS-Server das denn nicht ein, wenn ich die IP und den Namen vom Backup-Server in die HOSTS-Datei schreibe?

 

Mal ne Frage: wenn ich den IP-Bereich 192.168.3.x verwenden will... muss ich dann nicht auch die Subnet-Mask auf die 3.Stelle ändern? Also 255.255.0.0 ?

 

Hab das alles irgendwann mal gelernt - während der Ausbildung - ist aber schon ne ganze Weile her. Und wenn man das n paar Jahre eher selten macht, dann kann man da schonmal auf dem Schlauch stehen.

Share this post


Link to post
BackupExec arbeitet nicht zuverlässig, wenn ich's über die IP-Adresse oder über ein Netzlaufwerk versuche

 

Wenn das auch nicht geht hast du ganz klar ne Macke im DNS - ich sichere hier auch wunderbar BE Clients mit deaktiviertem NBT.

Share this post


Link to post

Der DNS-Server trägt keine statischen Zuordnungen, die in der HOSTS stehen, in die DNS-Datenbank ein.

Wenn Du zwei verschiedene Netzwerke benutzen willst , 192.168.1.0 und 192.168.3.0, dann benutze eine 24er Maske und keine 16er (war das die ganze Zeit ein 16er Maske ? Dann wundert es mich allerdings, dass das überhaupt korrekt funktionierte )

Share this post


Link to post
Ergänzend zu ITHome:

auf der GigaBitkarte, Eigenschaften, TCP, Reiter dns

Diese Verbindung in DNS registrieren --> Haken raus

Das können wir in dem Falle haken. ein DNS-Server trägt sich immer mit allen seinen Karten im DNS ein, egal, ob du das Häkchen setzt, oder nicht, egal ob man die 3 KB-Artikel mit Registry Key setzen durchführst oder nicht. Ist ein Feature eines multihomed DNS ;)

 

grizzly999

Share this post


Link to post
Entferne die Einträge der Karten und konfiguriere die DNS-Server so, dass sie nur auf der Adresse des LANs horchen.

 

damit sollte das Problem eigentlich beseitigt sein, hat der ThreadErsteller das denn jetzt mal so eingestellt?

Share this post


Link to post

Hi. Habs eingestellt. Scheint zu klappen. Bisher. Werd das noch n paar Tage beobachten.

Ist ne ziemlich seltene Konfiguration:

 

VPN über UMTS-Router mit WLAN-AP, auf der anderen Seite n Win2000Server und n DLink VPN-Router.

 

Danke für die vielen Antworten. Wahnsinns-schnell!

 

So. Nächstes Projekt: IP-Bereich unseres Firmen-LAN umstellen, damit wir per VPN auf die Server von den Kunden können. Schonmal einer von euch n DomänenController umgestellt?

Share this post


Link to post

Jo, das klappte problemlos, DNS-Zonen durchforsten, WINS-Einträge usw., IPCONFIG /REGISTERDNS, NETDIAG /FIX , NBTSTAT -RR, dann klappte das ...

Share this post


Link to post

@ Velius

 

Mache das Backup über Gigabit. Hab's zuerst mit Netzlaufwerken versucht. Hat der aber nach n paar stunden immer getrennt. Auch als ich die Zeit für's Trennen auf max eingestellt hab und auch als ich persistent benutzt hab.

Dann den kompletten Netzwerk-Pfad in BE angegeben mit IP-Adresse drin. Gleiche Symptome.

 

Funktioniert erst seit ich den Tipp bekommen habe die IP-Adresse aus dem Pfad raus zu nehmen und stattdessen den NetBios-Namen zu benutzen. Seitdem einwandfrei und zuverlässig.

Share this post


Link to post

Hm, bin mir jetzt gar nicht sicher, ob 2000 schon NBTSTAT -RR kennt. Wenn nicht, die richtigen DNS-Server und WINS-Server einstellen und einmal durchtauchen ...

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...