Jump to content
Sign in to follow this  
eXOs

Probleme mit Drucker über RDP-Verbindung

Recommended Posts

Hallo Zusammen,

 

ich hab hier einen Server der als Druckserver(W2k) arbeitet. Wir haben neue Drucker (HP 1320tn und HP 3000dtn) bekommen und diese habe ich ebenfalls auf diesem Druckserver installiert und freigegeben. Dann haben die User diese freigegebenen auch auf dem TS genutzt.

 

Speziell von einem User wurde mir dann letzens berichtet, dass das öffnen des Druckdialoges sehr lange (bis zu 2min) dauert. Wenn er dann einen anderen Drucker als den Standarddrucker (HP1320tn) wählen will, und die Liste aufgeklappt hat, ging dies ebenfalls bis zu 2min. Ganz schlimm wurde es dann wenn er auf Abbrechen geklickt hat, da hing der Druckdialog bis zu 5min auf seinem Bildschirm rum. Also habe ich mal den Standarddrucker geändert, das war dann der PDFCreater und siehe da, die Sache ging gleich wesentlich schneller (nahezu ohne jegliche Verzögerung).

 

Da das aber keine Lösung ist, habe ich mir überlegt, die Drucker "lokal" über TCP/IP am TS zu installieren. Das habe ich heute gemacht und wenn ich den HP 1320tn wieder als Standard definiere, habe ich immer noch zeitliche Verzögerungen, allerdings bewegen diese sich nun in einem annahmbaren Rahmen.

 

Testhalber habe ich aber die Drucker auf meinem Client ebenfalls "lokal" über TCP/IP installiert und bei mir habe ich keinerlei zeitlichen Verzögerungen wenn ich den Druckdialog öffne.

 

Ist das "normal" auf einem TS?

Share this post


Link to post

Nicht wirklich...

Allerdings wüsste ich auf die Schnelle auch nicht, wo man da ansetzen soll. Hast Du mal mit den Druckern ein wenig rumgespielt, andere Treiber benutzt, Dummy Drucker (die nicht wirklich existieren) installiert ?

Share this post


Link to post

Sind die Netzwerkschnittstellen an den Druckern ordnungsgemäß eingerichtet ? Mit Gateway, DNS usw. ?

DNS sauber konfiguriert am TS ?

Wenn ich mich recht entsinne, gibt es auch unterschiedliche Treiber für HP Drucker beim Betrieb im Netzwerk bzw. lokal.

 

Nur mal so ein paar Ansatzpunkte.....

 

Greetings Ralf

Share this post


Link to post

Danke für die Antworten...

 

@Wolke2k4

Treiber habe ich von HP für W2k3 Server runtergeladen. Was meinst du mit Dummy Drucker? Einfach einen installieren der nicht da ist, diesen dann als Standard und schauen ob es immer noch so lahm ist??

 

@Userle

Netzwerkschnittstelle eben nochmal geprüft, sieht gut aus, alles da. Treiber wie gesagt, die aktuellen für W2k3 Server geladen. Eine Auswahl Netzwerk/Lokal gab es nicht.

Share this post


Link to post

Ein derartiger Verhalten lässt darauf schließen, dass es Kommunikationsprobleme mit dem Drucker oder Druckserver gibt und die Druckerverwaltung ind Timeouts läuft.

 

Schon mal am TS und am Server die Druckerwarteschlange neugestartet?

 

Status des Druckers überprüft (evtl. nicht bearbeitete Druckaufträge, Drucker angehalten oder Offline, Berechtigungen des Users für den Drucker etc.)?

 

Wie ist der Drucker konfiguriert? Druckt er in eine Warteschlange, oder direkt auf den Printserver im Drucker? Testweise von einem ins andere umstellen.

 

Wie sieht es aus, wenn der Drucker lokal am TS installiert wird?

 

Gibt es Meldungen in der Ereignisanzeige? Sowas wie Treiberdatei xy kann nicht hinzugefügt werden etc.

 

Gruß morio

Share this post


Link to post

Hi morio,

 

den Drucker habe ich ja schon lokal am TS installiert, was das ganze ja auch schon beschleunigt hat, vom Client aus gehts trotzdem schneller.

Share this post


Link to post
Danke für die Antworten...

 

@Wolke2k4

Treiber habe ich von HP für W2k3 Server runtergeladen. Was meinst du mit Dummy Drucker? Einfach einen installieren der nicht da ist, diesen dann als Standard und schauen ob es immer noch so lahm ist??

 

Korrekt...

Share this post


Link to post

Ich kann jetzt nicht viel zur Performace deines TS im Vergleich zu den Rechnern sagen, aber prinzipiell ist es so, dass am TS die Aplikationen bevorzugt behandelt werden und Dienste wie z. B. Drucker immer etwas langsamer sind als am lokaen Rechner.

 

Wobei natürlich zu berücksichtigen ist, dass es sich hierbei um wenige Sekunden handelt. Alles was länger als 20 Sekunden dauert deutet eher auf ein Problem hin (kann auch ein Ressourcenproblem sein).

 

Zum Test kannst du mal versuchen die Priorität des Druckdienstes zu erhöhen. Hierfür sind jedoch erweiteret Admin-Rechte (Als Teil des Betriebssystems handen) erforderlich.

 

Des weiteren lohnt es sich verschiedene Treiber zu testen. PostScript mit PCL etc. Ggf. gibt es hier auch Unterschiede in der Druckjobbearbeitung.

 

Auch prinzipielle Eigenschaften des Systems wie wenig freier Festplattenpeicher, stark fragmentiertes Dateisystem etc. können zu Verzögerungen führen.

 

Gruß morio

Share this post


Link to post
Ich kann jetzt nicht viel zur Performace deines TS im Vergleich zu den Rechnern sagen, aber prinzipiell ist es so, dass am TS die Aplikationen bevorzugt behandelt werden und Dienste wie z. B. Drucker immer etwas langsamer sind als am lokaen Rechner.

 

Das würde ich eher nicht so sehen. Das Einzige was höchstens dauert ist der Vorgang bis das Blatt aus dem Drucker kommt. Insbesondere bei größeren Druckjobs und schmalen WAN verbindungen entsteht schnell ein Flaschenhals.

Auch das Druckermapping kurz nach der Anmeldung dauert ein paar Sekunden, fällt in der Regel jedoch nicht auf.

Das generelle Verhalten der Drucker (öffnen des Eigenschaftsdialogs usw.) unterscheidet sich von der Geschwindigkeit in der Regel aber nicht. Wenn ja dann liegt das Problem woanders.

Share this post


Link to post

Also seit die Drucker am TS installiert sind dauert es ja auch nur ein paar Sekunden. Ich denke wir könne, sollte es sich weiterhin in diesem Rahmen bewegen, damit leben da es ja vorher bis zu 5min ging.

 

@Wolke2k4

hab hier noch einen kollegen der nicht will das ich einen Drucker der nicht vorhanden ist installieren um das zu testen. Er ist der Meinung dass uns das nicht weiterbringt, da es sich mit dem PDF Drucker ja so verhält, dass dort keine verzögerung auftritt.

Share this post


Link to post

hat der client irgendwelche drucker installiert, die bei der TS-sitzung gemappt werden, die aber nicht mehr existieren, oder vom TS aus nicht erreicht werden können?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...