Jump to content
Sign in to follow this  
PID

WSUS / Framework Problem mit ASPNET

Recommended Posts

Hallo Experten,

 

eine aussenliegende Filiale unserer Firma benötigt einen WSUS Server innerhalb unserer Firmen Domäne

 

Diese Domäne hat eine Passwortregel (mind. 1 Buchstabe gross, mindestens 1 Sonderzeichen, mind. 8 Buchstaben,

und keine wiederholung des alten Passwortes für mindestens 8 Passwörter).

 

Ich habe also den WSUS Server ( auf w2k Server mit SP 3) aufgesetzt. inkl. der notwendigen zusätzliche komponenten ( SQL Express, dot net Framework, Bits 2.0)

 

Die Installation von WSUS wird sauber abgeschlossen, danach soll dann im Internetexplorer die Verwaltungskonsole aufgerufen werden (http://servername:8350\wsusadmin )

 

 

 

Hier kommt dann aber im Internetexplorer die Fehlermeldung : "server application unavailable" auf der WSUS Startseite.

 

Der Webserver jedoch ist OK (andere Websiten laufen weiterhin normal)

 

Nach einigem Suchen habe ich dann unter Dienste festgestellt das der Dienst "ASP.NET State Service" des Framework nicht automatisch gestartet wurde.

 

Beim Versuch diesen händisch zu starten kommt die Fehlermeldung: "Fehler 1069: Der Dienst konnte wegen einer fehlerhaften Anmeldung nicht gestartet werden"

 

Ich vermute nun das beim anlegen des Users ASPNET durch das System (Installation des dot net Framework) ein Passwort generiert wird, das nicht den oben genannten Anforderungen der Domäne entspricht. Somit kann der Dienst mit diesem Konto auch nicht gestartet werden.

 

Verwende ich jedoch das Systemkonto so startet der Dienst, aber das dotnet Framwork kann dann wohl nicht mit dem ASPNET Kontodaten darauf zugreifen.

 

Auch eine Neuvergabe des Passwortes von ASPNET hilft hier nicht weiter.

 

Denn das Framwork bekommt wohl nichts von der Passortänderung mit und versucht weiterhin mit dem alten Kennwort zuzugreifen.

 

Hilfe wie komm ich hier wieder raus, ich will doch nur auf die WSUS Webseiten zugreifen können !

 

Für jede zielführende Hilfe Dankbar

 

PID

Share this post


Link to post

Hi,

 

aktualisier erstmal den Server auf SP4 und zieh alle Patches nach. Dann im IIS noch prüfen ob ASP.net freigschaltet ist (Webdiensterweiterungen). Welches Framework hast Du installiert? 1.1 oder 2.0?

 

BTW auf meinem 2003er mit aktiven WSUS startet ASP.net Zustandsdienst nicht automatisch (steht auf Manuell) mit dem User "Netzwerkdienst" - hast Du die Deutsche oder Englische Frameworkversion drauf?

Share this post


Link to post

Installiere zuerst SP4 und alle Hotfixes von Windows Update. Dabei kann gleich .NET 2.0 installiert werden. Der aktuelle BITS sollte auch mitkommen.

 

SP3 ist sicher nicht supported. PS: Vom WSUS gibt es auch ein SP1.

 

-Zahni

Share this post


Link to post

Hallo,

 

erst mal danke für die standart Tipps (hätte ich auch gegeben)!

bzw. ich hätte es in meiner ersten Frage reinschreiben können - sorry!

 

Aber das ist es nicht, denn (im Detail):

 

Der Server ist auf dem alktuellen Stand:

 

mit SP 4

 

Alle Updates von Microsoft Update sind eingespielt.

 

Beide (Framework 1.0 und 2.0 sind installiert).

 

Das Aktuelle Bits ist drauf.

 

Selbstverständlich wurde WSUS SP 1 installiert.

 

Das ganze hab ich überigens mehrfachst neu installiert

Es kommen keine Fehlermeldungen alle Installationen laufen einwandfrei durch.

 

Doch sobald nach der WSUS Installation die Startseite aufgerufen wird kommt die oben genannte Fehlermeldung.

 

 

Hiiilllllfffffffeeeeeeeee!!!!!!!!!!!!

 

mfg

PID

Share this post


Link to post

Hi,

 

NTFS Zugriffsberechtigungen für Netzwerkdienst im Verzeichnis \windows\microsoft.net auf ändern setzen - so der Netzwerkdienst noch keinen Zugriff hat.

 

btw - Du hattest SP3 geschieben ;)

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...