Jump to content

DHCP & VLAN


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

wir haben DHCP (W2k-Server) seit längerem in Einsatz. Jetzt ist es notwendig geworden einige Clients (W2K und XP) in einem VLAN mit völlig anderen IP`s zu versorgen. Ich habe einen neuen Bereich mit der zusätzlichen IP-Range definiert und aktiviert.

Jetzt mein Problem: Kein Client bekommt IP`s der zusätzlichen Range, weder die im VLAN noch die im standart LAN. Habe die Leasezeiten zum Test schon minimal gesetzt.

Woran kann das liegen?

 

Danke im voraus. :)

Link to comment

wenn du mehrer vlans definierst und die clients dort reinhängst musst du "ip-helper" (heisst bei hp so) adressen in den vlans konfigurieren. die ip helper adresse ist die adresse des dhcp servers... nennst du die vlans zb vlan1 vlan2 etc legst du auf dem dhcp server für jedes vlan ein scope an... und schon holen sich die clients die adressen aus dem richten bereich... mit superscope klappt das nicht, hab ich schon probiert... hab das ganze an zwei standorten mit jeweil 13 vlans laufen... auf stockwerke bezogen. jedes hat sein eigenes. funktionert einwandfrei. fragen?

 

gruss

jobe

Link to comment
  • 3 weeks later...

Hi.

 

Bei uns in der Firma haben wir einen DHCP-Server-Dienst, auf dem 4 Bereiche laufen. Der DHCP hängt aber nur in einem der Bereiche.

 

Der Router wurde so konfiguriert, daß DHCP-Anfragen zum Server weitergeleitet werden. (IP-HELPER-ADDRES)

Automatisch sendet der Server eine IP aus dem passenden Bereich zurück.

 

Das hat bei uns sofort funktioniert. Kannste bei dem Router vielleicht eine Helper Adresse angeben oder BootP freischalten?

 

Ansonsten könnteste ja noch in jedem Subnetz (VLan) einen DHCP-RELAY-AGENTEN installieren, der dann die Anfragen entgegennimmt....

Link to comment

Tagging ist auf dem switch aktiv.

Die Workstation bekommen ein IP vom DHCP wenn Sie das erste mal ans Netz angeschlossen werden, egal in welchem Vlan sie aufgestellt werden.

Somit sollte Relay und tagging ja funktionieren, oder?

Wenn ich die WS jedoch physikalisch an ein anderes vlan anschliesse, bekommt sie keine neue IP aus diesem Vlan, bis ich auf dem DHCP Server die WS aus dem alten VLAN entferne.

 

Wir habe die gleiche konfiguration an einem anderen Standort. Dort funktioniert alles. Allerdings ist dort ein W2K DHCP und dieser ist kein DC.

An dem Problemstandort ist der DHCP Server DC und Windows 2003.

Link to comment
  • 2 weeks later...
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...