Jump to content

NAT über W2K Server - ich bin am verzweifeln


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Moin moin,

 

ich bekomm hier gleich SOOOO einen Hals wegen dieses ******* NAT. Habe gestern geschlagene 8 stunden am stück damit verbracht es wieder und wieder auszuprobieren!

 

Vielleicht habt ihr ja noch einen heissen Tip:

 

Ich möchte 2 netzwerke über NAT auf dem 2000Server ans internet anbinden (DSL). Das ganze sieht nun so aus:

 

Ich habe am Server 4 aktive NEtzwerkverbindungen:

100Mbit - 192.168.0.1

10Mbit - 192.168.1.1

DSL (für die ethernetverbindung mit dem DSL modem) - 0.0.0.0

t-online - die dial up verbindung die dann ja offenbar auf DSL(der verbindung) aufsetzt

 

Die Verbindung ins internet am server funzt und auch die verbindung mit den beiden netzwerken.

 

für die clients verwende ich dhcp mit folgenden einstellungen:

range: 192.168.0.1 - 192.168.0.100 // gesperrt: 192.168.0.1

range: 192.168.1.1 - 192.168.1.100 // gesperrt: 192.168.1.1

Gateway: 192.168.0.1 bzw. 192.168.1.1

DNS: 192.168.0.1 bzw. 192.168.1.1

 

Die Adresszuweisung klappt auch problemlos auf beiden netzwerken.

 

Jetzt habe ich also den krassen installationswizard für Routing und RAS verwendet um den SErver als NAT Server einzurichten.

daraufhind wurde also unter IP-Routing der Eintrag NAT erstellt in dem auch alle schnittstellen korrekt eingetragen sind. (Soll heissen die 100Mbit und 10Mbit schnittstelle wurden korrekt als intern eingetragen und die DSL (also die lan verbindung) als extern eingerichtet -

Dies macht mich schon etwas stutzig weil ich eigentlich erwartet hätte dass ich die dial up verbindung als externe schnittstelle hätte angeben können - dies ist aber nicht möglich weil die schnittstelle nirgends ausgewählt werden kann - ist das erste mal dass ich dsl mit win2k einsetze insofern will ich auch gar nicht bezweifeln dass das richtig ist - ist es??

 

BEi DNS habe ich nun wirklich gar keine ahnung wo ich was einstellen muss und ob ich ne forward zone brauche oder was auch immer, nichtsdestoweniger habe ich mal versucht da einzustellen dass anfragen die dieser server nicht beantworten kann an einen höheren dns server weitergeleitet werden.

(2 von t-online habe ich dort eingestellt)

 

Wie auch immer ich will also nun auf meinem client http://www.google.de öffnen und die address auflösung klappt nur dann passiert nichts mehr. Ich gebe netstat ein und sehe

233.5.3.5:http (google.de) - SYN-Gesendet

 

und das wars das bedeutet vermutlich dass die verbindung von innen nach aussen nach innen funtzt aber die antworten von google vom nat server nicht korrekt zum client weitergeleitet werden.

 

Komisch ist nur dass die ip addresse von google.de korrekt aufgelöst wure.

 

Ich habe nirgends bei den internetverbindungen eingestellt verbindungsfreigabe für .... aktivieren - das ist ja nicht nötig für nat oder? - geht zumindest nicht, er will mmir dann sagen dass ich gefälligst nat abschalten soll und ICS anmachen soll wenn ich die internetverbindungsfreigabe aktivieren möchte.

 

Ach ja, bei den eigenschaften von NAT unter IP-routing habe ich schon alles ausprobiert, sowohl ip adressen von dhcp beziehen lassen oder auch nicht - so habe ich das auch mit dns schon ausprobiert.

 

BITTE HELFT MIR

 

danke schonmal fürs durchlesen

 

 

mfg

 

Stefan

Link to comment

danke auf jeden fall für die antwort aber adsl-support bringt mich da leider keinen deut weiter weil die mir da nicht sagen wir man nat einrichtet sondern nur ics. Und DSL mäßig funzt ja auch alles.

 

ach ja, mit ics funktioniert das übrigens (aber da kann man ja nur ein netzwerk mit anschliessen)

Link to comment

wow ich habe es endlich geschafft (nach nur 5 weiteren stunden - eigentlich war ich in gedanken schon auf dem weg zur nächsten brücke)

 

Wie auch immer hier die lösung des problems fall das nochmal jemand haben sollte:

die eigentlich dfü verbindung muss direct unter RRAS - Server - allgemein - schnittstelle hinzugefügt werden. ES ERSCHEINT KEIN SYMBOL unter Dfü-Lan verbindungen. (weiss dafür vielleicht noch einer wie man das machen könnte) Soll heissen dass die verbindung auch genau an dieser Stelle VERBUNDEN werden muss. Damit das widerum passieren kann muss man einen statischen routing eintrag für die eben erstellte dfü verbindung erstellt werden bei dem beide adressen auf 0.0.0.0 gestellt werden. Versucht man nun diese verbindung zu verbinden sollte das klappen. Jetzt kann man die auch unter NAT als verbindung zum internet erstellen.

 

Ist jetzt etwas konfus falls jemand dabei tatsächlich ein problem hat einfach nochmal hier posten ich werdes dann nochmal

genauer schreiben.

 

Danke an alle die sich gedanken gemacht haben. (wäre aber echt nett wenn mir einer noch schreiben könnte wie ich ne verknüpfung auf den desktop zu dieser verbindung bekommen könnte)

 

mfg

 

Ace

Link to comment
  • 2 months later...

Ooohhh jaaa.... ihr sprecht mir aus der Seele. Dieses Problem hatte ich auch zig mal und es hat mich unendlich Nerven gekostet. Ich bin dann immer wieder mal zum guten alten WinRoute rübergesprungen, aber nach einer frischen Neuinstallation und unter Verwendung von RASPPPOE hatte es dann endlich funktioniert.

Natürlich darf der Eintrag unter Statische Routen nicht fehlen (0.0.0.0 0.0.0.0 keine DSL Router 1) und unter der standard mässig eingerichteten RAS-Richtlinie die RAS-Berechtigung auf erteilen setzen nicht vergessen.

 

Eine Verknüpfung wird, glaube ich, aus Systemgründen wohl nicht funktionieren, weil dieser RAS Eintrag ja auch nicht unter "Netzwerk- und FDÜ-Verbindungen" zu finden ist.

 

Ich habe anstatt dessen eine zusätzliche DFÜ DSL Verbindung erstellt. Dies hat er bei mir auch angenommen obwohl ich die Verbindung nicht aus dem Routing und RAS gestartet habe. Routen tut er wohl trotzdem.

 

Irgendwie ist das manchmal alles etwas undurchsichtig, und der Weg den man gehen sollte nirgends genau beschrieben, bzw. es gibt keine Beispiel HowTos bzw. Roadmap. Naja... in diesem Sinne und guten Rutsch ins Neue Jahr!

Link to comment

"Irgendwie ist das manchmal alles etwas undurchsichtig, und der Weg den man gehen sollte nirgends genau beschrieben, bzw. es gibt keine Beispiel HowTos bzw. Roadmap."

 

Genau das ist auch mein Problem, ich habe mich durch MS-Hilfe Dateien, Knowledge Base Artikel, und Forum-Beiträge gelesen bis ich endlich den Router am laufen hatte.

Ich hatte nämlich die Statische Route nicht eingetragen.

 

Das surfen geht jetzt, ich habe nur noch das Problem dass ich keine emails senden kann (abrufen geht komischerweise).

Und bei manchen Internetseiten habe ich auch Probleme z.b. http://www.gmx.de.

Hätte da vielleicht noch jemand einen Tip für mich ?

 

 

 

mfg neon001

Link to comment

Hi,

ich hätte da doch noch eine kleine Frage:

Ich habe auf einer Seite die Anleitung gefunden, wie man den MTU Wert ermitteln kann:

 

Mit folgendem Befehl (Windows) können Sie testen ob, das TCP/IP-Paket fragmentiert wird oder nicht.

 

Geben Sie dazu zuerst den Wert 1500 ein. Sollte Sie die Meldung erhalten, dass das Paket fragmentiert sei, muessen Sie den Wert um jeweils ca 10 reduzieren.

Wenn Sie einen funktionierenden Wert gefunden haben, d.h. Sie erhalten bestätigte Ping-Abfragen, ändern Sie den MTU-Wert mit einem Tool ab (siehe Links unten).

 

Befehl im der Eingabeaufforderung eingeben (Start -> Programme -> ...)

ping -l MTU IP -f -w 10000

 

Wobei MTU = <1500 und IP = eine externer am Internet angeschlossender Rechner sein muss

 

 

Das habe ich mal auch am Server getestet mit MTU 1500, da kommt aber die Meldung: "Pakete müssen fragmentiert werden, DF-Flag ist jedoch gesetzt".

 

Muß ich jetzt am Server den MTU-Wert auch runtersetzten? :confused::confused:

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...