Jump to content

Exchange 2016 -> 2019


Go to solution Solved by Squire,

Recommended Posts

  • Solution

Hallo,

 

ich hatte gestern ein Phänomen, das ich mir nicht so ganz erklären kann ...

 

Umgebung:

AD, mehrere Domänen, eine Exchange Organisation (mehrere 2016er Server). Bei uns eine DAG (2 Server) hinter einem Kemp Päarchen. Hybrid Szenario für O365 (Mailboxen alle on Prem)

 

Ziel:

Dazu sollen jetzt zwei 2019er Exchange als DAG kommen. Die Mailboxen aus der 2016er DAG sollen auf die 2019er verschoben und die 16er dann zurückgebaut werden.

 

Stand jetzt

Ein 2019er wurde installiert, die virtuellen Verzeichnisse identisch zu den 2016ern gesetzt. SplitDNS ist im Einsatz. Das öffentliche Zertifikat, welches wir auf den 2016ern verwenden hab ich auch im 2019er drin. Der 2019er ist bisher noch in keinem Connector hinterlegt, ebenso wurde der 2019er nicht am Kemp bekannt gemacht. Die SCPs zeigen alle auf die virtuelle Adresse/Namen des Kemp

 

Jetzt das, was ich nicht verstehe ...

Outlook bringt eine Zertifikatswarnung, dass auf dem korrekten öffentlichen Zertifikat der interne Name nicht drauf ist. Sprich der Server meldet sich bei Outlook mit seinem internen Namen und mit dem korrekten externen Zertifikat. Wie kann das eigentlich sein? Outlook quatscht doch normal über den virtuellen Service auf den Kemp Loadbalancern zu den Exchangeservern. Wieso die Meldung des 2019ern?

 

Mein Plan war die beiden 2019er fertig zu installieren, virtuelle Verzeichnisse zu setzen, Zertifikat einspielen, DAG erstellen, dann am Kemp bekannt machen (sollte hierzu ein neuer Service angelegt werden oder kann ich die bei den 2016ern mit hinzufügen?), Connectoren anpassen (Sendeconnectoren) ...

 

Im Moment hab ich den 2019er wieder heruntergefahren, um die User durch die Zertifikatsfehler nicht zu irritieren.

 

Frage: Passt mein Upgrade Weg? Warum kommt der Zertifikatsfehler?

Link to comment

Moin,

 

der Upgrade-Weg ist genau richtig, Vermutlich hat sich da zeitlich etwas überschnitten - oder Du hast einen der virtuellen Verzeichnisse auf dem neuen Server vergessen.

 

Ein heruntergefahrener Exchange-Server sollte kein dauerhafter Zustand sein, das macht mehr Probleme als Zertifikatswarnungen bei Usern.

Link to comment

@cj_berlin Guten Morgen Evgenij,

 

ich hab die Verzeichnisse mit Frankys Script ausgelesen und gesetzt (Dieses hier) man muss ja das Rad nicht zweimal erfinden.

Auf Dauer lass ich den Exchange eh nicht aus. Ich denk fast, dass ich die Geschichte erst am Wochenende weiter verfolge. Dann rufen nicht gleich irgendwelche User an und motzen ...

 

Aber schön, dass Du meinen Weg bestätigst, :D hatte schon an mir zu zweifeln begonnen ;-) 

 

Noch eine Frage zu dem Hybrid Gedöns, das ist in der Tat für mich relativ neu ... muss ich da den Hybrid Wizard nochmal laufen lassen, oder genügt es die beiden neuen Exchange in den Connectoren hinzuzufügen?

Link to comment
vor 16 Minuten schrieb cj_berlin:

oder Du hast einen der virtuellen Verzeichnisse auf dem neuen Server vergessen.

Die sind egal, wenn der scp auf die bisherigen Server zeigt. Aber meist ist es ein caching des iis, wenn man das nicht schnell genug ändert, und dann noch caching am Client. Muss man halt mal durch. ;)

Link to comment

die SCPs zeigen alle auf die virtuellen Services am Kemp.

 

Ja ist schon lustig ... mal ist man nicht schnell genug, mal muss man "ewig" warten, bis die Replikation durch ist ... :aetsch2:

 

was mich aber trotzdem interessiert ist, wie der Client den 2019er findet, wenn doch die SCPs auf den Kemp zeigen und der den auch noch nicht kennt...

Edited by Squire
Link to comment

Naja kommt halt drauf an, wie lang die Replikation dauert bei euch, wenn ihr mehrere exchangeserver habt, werden es wohl mehrere Standorte sein und damit eben genügend zeitliche Verzögerungen inklusive caching. ;)

Gerade eben schrieb cj_berlin:

Darum haben Firmen, die ständig neue Exchange Server installieren, dafür eine separate Installations-Site im AD.

Ich wollt’s grad schreiben. ;) alternativ setzt man den scp eben bereits während des setups sobald er auftaucht. Klappt auch „meist“.

  • Like 1
Link to comment

HCW sollte neu ausgeführt werden, wie nach jedem anderen Update auch. 

vor 12 Minuten schrieb Squire:

Noch eine Frage zu dem Hybrid Gedöns, das ist in der Tat für mich relativ neu ... muss ich da den Hybrid Wizard nochmal laufen lassen, oder genügt es die beiden neuen Exchange in den Connectoren hinzuzufügen

 

Link to comment
  • 2 weeks later...

Seit dem Wochenende sind beide 2019er aufgesetzt, DAG eingerichtet und keine Zertifikatsmeckereien am Montag ... Mein oben beschriebener Weg war genau richtig. Hat ja der Kollege @cj_berlin auch bestätigt.

 

Jetzt müssen noch ein paar Anpassungen für die "Um-Systeme" [Mailarchivierung, MDM, Disclaimerlösung] vorgenommen werden ... dann geht das Mailboxschubsen an.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...