Jump to content

Probleme beim Zugriff aus VLAN über VPN


Recommended Posts

Hallo zusammen.

Ich beschreibe das Problem mal wie folgt - wahrscheinlich stehe ich einfach auf dem Schlauch...

An Standort A habe ich ein (Haupt-)Netzwerk mit dem Bereich 192.168.10.0/24. 
An Standort B habe ich ein Netzwerk mit dem Bereich 192.168.20.0/24.
An beiden Standorten befindet sich jeweils ein RV325. Es läuft eine Site-to-site-VPN zur Verbindung der beiden Standorte. Netzwerkzugriffe sind von beiden Seiten möglich. Soweit keine Probleme.

Nun wurden die IP-Adressen an Standort A knapp und somit habe ich auf dem RV325 am Standort A ein VLAN erstellt. (192.168.30.0/24). Dieses ist in erster Linie speziell für mobile Geräte gedacht, um diesen Internetzugriff zu verschaffen. Im VLAN ist ein DHCP-Server über den gesamten Bereich aktiv.

Problem ist, dass ich mit einem Laptop, das sich am Standort A befindet und das keine statische IP hat, nicht in das Netzwerk am Standort B komme. Also kein Zugriff vom VLAN (30er-Netz) auf das 20er-Netz am 2.Standort über VPN. Wenn ich dem Laptop eine statische Adresse aus dem Hauptnetz (also 10er-Netz) gebe, funktioniert der Zugriff dann wieder. Allerdings sollten die Laptops ihre IP über DHCP beziehen, da sie an beiden Standorten eingesetzt werden. Ansonsten gibt es dann wieder Probleme, wenn ich mit dem Laptop am Standort B sitze (20er-Netz) und eine statische 10er-Adresse habe.

Ich hoffe, Ihr könnt mir folgen und mir einen Tipp geben, wie ich das Problem lösen kann.

Viele Grüße
Grobi
 

Link to comment

Hallo Grobi09,

 

aus der Ferne ist es von uns schwierig den Unterschied von einer DHCP zu einer statischen Konfiguration zu bewerten, ohne Informationen. Wenn ich das richtig verstanden habe, existiert dein Problem also nur, wenn du die DHCP-Konfiguration verwendest. Sobald du die Konfiguration statisch erledigst funktioniert auch das Routing? Falls ja, liegt das Problem auf der Hand. Schaue Dir die DHCP-Konfiguration auf deinem DHCP-Server an und vergleiche mit deiner statischen Konfiguration.

 

Welche Optionen werden denn verteilt? Gibt es vielleicht mehrere Gateways in deinem Netz?

Link to comment

Hallo Grobi,

 

wenn ich das richtig verstanden habe funktionieren die Zugriffe aus dem VLAN 30 / Standort zu Standort B nur wenn dem NB Im VLAN 30 eine IP aus dem Netz 192.168.10.0 vergibst. Wenn dem so ist vermute ich das im Router am Standort B die Rückroute fehlt, d.h. erkennt kein Gateway für das Netz. Vielleicht kannst Du die Konfig der Router hier posten.

Link to comment
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...