Jump to content

WDS UEFI Client bekommt keine boot.wim


Recommended Posts

Hallo,

 

beschäftige mich nun seit 3 Wochen a 5 Tage mit diesem Problem.

 

Wir haben zwei DCs W2019 die beide DHCP 50-50 Lastenausgleich haben. Der Haupt DC (01) hat einen WDS Server der Probleme macht. Keine Subnetze. D.h DC02 ist die Redundanz zum DC01.


WDS ist als AD DS integriert konfiguriert. 

 

Legacy boot funktioniert nur UEFI nicht. 

 

Der DHCP hat die Option 60 PXEClient aktiviert, ohne klappt noch weniger. Die Richtlinien mit Option 66 & 67 habe ich auch schon probiert, vergebens. Daher habe ich die wieder entfernt. 

Rogue Server detection ist beim WDS an. Testweise habe ich den DHCP auf DC02 auch mal deaktiviert ansonsten sieht man in Wireshark auch nicht das der DC02 aktiv funkt.
Folgende Ports sind zugelassen. Habs auch mal mit komplett deaktivierter Firewall probiert. 

UDP - 67, 68, 69, 4011

TCP - 135, 137, 138, 139, 5040
 

Nachdem der Client das NBP File ( boot\x64\wdsmgfw.efi) bekommt passiert nichts mehr. In Wireshark sieht man danach noch ARPs wo gefragt wird wer der Client ist
Im WDS Log wird fleißig versucht erneut zum Client zu senden. (Siehe Anhang) 

Client Arch stimmt überein. 

 

Am Client selber sieht man nichts außer das ein UEFI Netzwerkboot versucht wird, danach Abbruch wie in Wireshark zu sehen.

Der WDS Server hat auch ein normales Win10 Pro boot und install wim eingegangen. 

 

Ich weiß nicht ob Links geteilt werden dürfen, ansonsten gibt es genau einen Beitrag wo das Szenareo beschrieben wird. Der Fix war den DCHP neu zui nstallieren. Ist hier nicht möglich da es eine produktiv Umgebung ist. 

 

NETBIOS ist in der Netzwerkkarte aktivert. 

 

Hoffe ihr habt noch Ideen warum der Client die Boot.wim nicht bekommt obwohl er den Ausweis dafür hat. 

 

Viele Grüße!!

 

 

 

WDSFAIL.png

FAILWireshark.png

Link to post
vor 13 Minuten schrieb zahni:

Ich glaube, die Anleitung war ganz brauchbar:

 

https://gal.vin/posts/pxe-booting-for-uefi-bios/

 

Wichtig ist, dass Du die Bootfiles von dem Windows nimmt, dass Du booten willst und nicht irgendwas, das der WDS im Bauch hat.

Die wird normalerweise aus der Boot.wim extrahiert. Kontrolle ist aber besser.

Das habe ich bereits ausprobiert, das war mit den Optionen 66 & 67 gemeint. Trotzdem danke. 

Link to post

DHCP UND WDS nicht auf der gleichen Maschine ausführen. Die DHCP-Funktion im WDS sollte man generell abschalten. Die funktioniert i.d.R. nur wenn man nur ein LAN-Segment hat.

Link to post
Am 12.7.2021 um 14:51 schrieb mkwjason:

Keine Subnetze.

Alles Andere wäre verwunderlich.

 

Wichtig sind hier die Einstellungen auf dem Client im BIOS bezogen auf das Boot-Menü. Für weiteren Sinnhaftigkeiten Support, muss m.M.n. das Konzept angepasst werden.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...