Jump to content

Recommended Posts

Hallo,

ich habe leider, trotz vieler "Verbesserungen" noch immer ein perfomance Problem mit Firebird 3.0. Ich habe schon vieles geändert, die Situation ändert sich leider jedoch nicht.
Wir betreiben eine kleine Firma, in der vier Rechner, mit einer Netzwerkfähigen Software (Amicron Faktura) zeitgleich arbeiten sollen. Sie greifen alle auf eine Firebird 3.0 Datenbank zu. Weiterhin gibt es dieverse Geräte im privaten Haushalt, die am gleichen Netzwerk hängen.

Die Umgebung sieht so aus:

Als Router haben wir die Fritzbox 7590. An dieser sind private WLAN Geräte und private LAN Geräte angeschlossen.  Am WAN Anschluss der Fritzbox habe ich eine CAT 7 Verbindung zum NETGEAR XS708T-8-Port 10 G (extra neu angeschafft) hergestellt. Alle Firmencomputer und der Server und ein NAS Server und Drucker hängen an diesem Switch.

Als Server nutzen wir einen PC

Intel Core i7-8700 3.70GHZ
RAM 32 GB

Auf diesem Server läuft windows server 2019 essentials (extra neu angeschafft).

Es gibt leider trotz der Neuanschaffungen keine Verbesserung. Der Softwarehersteller Amicron Factura hat das Problem live gesehen, kann es sich jedoch nur so erklären, dass das Netzwerk das Problem ist.
Es gibt auch starke Schwankungen. Mal rennt das Programm, manchmal ist es sehr langsam.

Ich habe mir schon einige Videos über die Konfiguration zur Software windows server 2019 essentials angesehen. Es wird dort immer erklärt, wie man was installiert, jedoch nicht, was man wofür benötigt.
Da es ein produktives System ist, möchte ich auch nicht aufs blaue etwas probieren.

Ich würde mich über eine Hilfestellung sehr freuen.

Link to post

Wozu braucht man in einer solch kleinen Umgebung 10 GbE?

Läuft das Programm den Lokal auf dem Server performant? Kann man das testen?

 

Wenn es am Netzwerk liegt muss man dieses analysieren. Fehler im Switch auslesen. Ist ja ein Managed Switch.

Link to post

Falls Du einen kleinen 1Gb Switch zur Hand hast nimm den Netgear einmal raus und probiere es mit dem anderen Switch. Hatte auch gerade Probleme mit einem Netgear XS, allerdings aus der 5er Reihe. Nachdem alle Maschinen auf einen anderen Switch umgesteckt wurden waren alle Netzwerkprobleme schlicht weg.

Link to post

Hallo,

 

ich habe jtzt noch ein wenig probiert und bin auf die Idee gekommen, die Firewall beim Server und einem Arbeitsrechner für das private Netzwerk zu deaktivieren. Siehe da, es lief super. Dann habe ich die Firewall am Arbeitsrechner wieder eingeschaltet und es lief immernoch super.

Also liegt das Problem wohl an der Firewall des Servers. Ich habe dort bereits vorher Reglen für Firebird und Amicron angelegt. Diese scheinen jedoch nicht richtig zu sein.

Meine Frage nun:

Kann mann vielleicht die Firewall zwischen Server und den Arbeitsstationen über die IP Adresse ausschalten?

Link to post

Ich würde das beim Hersteller anfragen. Er kann sicher die Konfiguration der Windows Firewall nennen.

Was mich wunder ist, dass es Performance Probleme und Schwankungen gibt. Wenn ein Port blockiert wird, dürfte keine Verbindung gehen.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...