Jump to content
iJannis

Windows Store Fehler 0x8024500C

Recommended Posts

Hallo Leute,

 

ich bin am Verzweifeln. Seit der 1903 können die meisten Clients in unserer Domäne keine Apps mehr aus dem Store herunterladen. Die Fehlermeldung sagt, man solle die Windows Updates in der GPO aktivieren. Das Ding ist, dass wir schon die GPO rauf und runter nach den Regeln durchsucht haben und nichts gefunden haben. Zusätzlich haben wir Tipps und Tricks bis Seite 5 bei Google durchforstet, ohne Erfolg. Clients, die nicht in der Domäne sind, haben Null Probleme mit dem Store. Jedoch die meisten anderen Clients, die sich in der Domäne befinden schon. Selten laden manche auch nicht die Windows Updates herunter wegen diesem Fehler. Bei uns läuft ein WSUS und einen Domänencontroller auf dem wir einheitlich die Richtlinien für jeden Client gesetzt haben. Da ich neu bin, weiß ich nicht welche Infos ihr noch braucht. Ich bin für jeden Tipp dankbar!

Edited by iJannis

Share this post


Link to post
Share on other sites

Nimm einen Testclient in eine neue leere OU auf. Die Vererbung von Gruppenrichtlinien deaktivierst Du auf der OU. Client zweimal neu starten und den Storen testen. Wenn es funktioniert, erstellst Du ein GPO für den WSUS. Du trägst nur den Namen des WSUS ein, verlinkst das GPO auf die TestOU. Auf dem Client anmelden, gpupdate ausführen, ohne irgendein forcieren oder ähnliches, zweimal neu starten und Store testen. Funktioniert es jetzt?

Share this post


Link to post
Share on other sites

Hi,

erstmal Danke für deine Hilfe.

 

Zitat

Nimm einen Testclient in eine neue leere OU auf. Die Vererbung von Gruppenrichtlinien deaktivierst Du auf der OU. Client zweimal neu starten und den Storen testen. Wenn es funktioniert, erstellst Du ein GPO für den WSUS. Du trägst nur den Namen des WSUS ein, verlinkst das GPO auf die TestOU.

Bis hier hin funktioniert alles.

Jedoch kommt folgende CMD Ausgabe:

 

cmdfehler.PNG

Share this post


Link to post
Share on other sites

Wie weit bist Du gekommen? Das GPO mit dem WSUS erstellt? Bekommt der Client eine IP vom DHCP? Bisschen wenig Infos hast Du bisher geliefert.

Share this post


Link to post
Share on other sites

Naja, wenn der Client keinen DC findet, wird alles schwierig :-) Das wäre jetzt die Zeit für Grundlagendiagnose: ipconfig /all, ping etc.

Share this post


Link to post
Share on other sites

ipconfig puckt IP vom DHCP aus, richtiges Netz, die Subnetzmaske stimmt und der Gateway auch. Pings auf eigene Server sowie Externe sind möglich. GPUPDATE ließ sich dann auch wieder normal machen..

Share this post


Link to post
Share on other sites

OK, und was ist mit dem WSUS? Funktioniert das jetzt wie gewünscht? Wenn Du weiterhin so wenig pries gibst, wird es schwierig bis unmöglich dir zu helfen.

Share this post


Link to post
Share on other sites

Solange der Client in der leeren Test OU ist, ja. Aber sobald ich ihn wieder in die normale OU aufnehme und der wieder die alten WSUS Richtlinien zieht, kommt wieder besagter Fehler. Haben sich irgendwelche GPOs in Richtung WSUS seit der V1903 geändert? Muss ich irgendeine Richtlinie raus nehmen?

Share this post


Link to post
Share on other sites

Naja, dann musst Du jetzt Einstellung für Einstellung in die leere TestOU übernehmen und jedesmal testen. Irgendeine Einstellung muss es ja sein.

Share this post


Link to post
Share on other sites

Hallo

Habe so ein ähnliches Problem, mit Windows 10  1903. Da man z.b keine Langauge Packs mehr bekommt, muss man sie aus dem Store herunterladen oder Updaten.

 

So da wie auch eine Domäne und einen Wsus Server betreiben, können alle Clients die in der Domäne sind und über dem Wsus gefüttert werden, keine Langauge Packs herunterladen oder Updaten.

 

Was ich jetzt herausgefunden habe ist, das wenn man z.b eine Sprache installieren oder updaten möchte am Client, das der Client natürlich auf denn Wsus Server schaut, und dort nicht findet.

Logisch da es keine Langauge Packs für 1903 und Wsus gibt ( zumindest haben das meine Recherchen ergeben )

Die Sprachen gibt es jetzt nur noch über den Store

 

Um Sprachen aus dem Store zu Installieren muss man am Wsus Server vorbei.

Das habe ich mit einem Script realisiert

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU" /v UseWUServer /t REG_DWORD /d 0 /f

net stop wuauserv

net stop bits

net stop appidsvc

net stop cryptsvc

ren C:\Windows\SoftwareDistribution\ SoftwareDistribution.old

ren C:\Windows\System32\catroot2 catroot2.old

net start bits

net start wuauserv

net start appidsvc

net start cryptsvc

In diesem Script wird im reg. Das UseWUServer von 1 auf 0 gesetzt.

Das genau heisst das wenn 0 eingetragen ist, kein Wsus Server genutzt wird.

So ist es dann auch möglich Sprachen aus dem Store zu Installieren.

Kann sein das man denn PC 1-mal neu starten muss wenn es beim ersten mal nicht klapp.

Nach dem alles erfolgreich Installiert ist kann man über die Gruppenrichtlinienverwaltung

Auf der entsprechenden OH eine Gruppenrichtlinienupdate anstossen, so bekommen dann alle Clients über die Gruppenrichtlinie ihren Wsus Server wieder.

 

 So hat es bei mir geklappt, könnte vielleicht auch Dir helfen, nur mal so als Tipp

 

Sascha

Hallo

Habe so ein ähnliches Problem, mit Windows 10  1903. Da man z.b keine Langauge Packs mehr bekommt, muss man sie aus dem Store herunterladen oder Updaten.

 

So da wie auch eine Domäne und einen Wsus Server betreiben, können alle Clients die in der Domäne sind und über dem Wsus gefüttert werden, keine Langauge Packs herunterladen oder Updaten.

 

Was ich jetzt herausgefunden habe ist, das wenn man z.b eine Sprache installieren oder updaten möchte am Client, das der Client natürlich auf denn Wsus Server schaut, und dort nicht findet.

Logisch da es keine Langauge Packs für 1903 und Wsus gibt ( zumindest haben das meine Recherchen ergeben )

Die Sprachen gibt es jetzt nur noch über den Store

 

Um Sprachen aus dem Store zu Installieren muss man am Wsus Server vorbei.

Das habe ich mit einem Script realisiert

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU" /v UseWUServer /t REG_DWORD /d 0 /f

net stop wuauserv

net stop bits

net stop appidsvc

net stop cryptsvc

ren C:\Windows\SoftwareDistribution\ SoftwareDistribution.old

ren C:\Windows\System32\catroot2 catroot2.old

net start bits

net start wuauserv

net start appidsvc

net start cryptsvc

In diesem Script wird im reg. Das UseWUServer von 1 auf 0 gesetzt.

Das genau heisst das wenn 0 eingetragen ist, kein Wsus Server genutzt wird.

So ist es dann auch möglich Sprachen aus dem Store zu Installieren.

Kann sein das man denn PC 1-mal neu starten muss wenn es beim ersten mal nicht klapp.

Nach dem alles erfolgreich Installiert ist kann man über die Gruppenrichtlinienverwaltung

Auf der entsprechenden OU eine Gruppenrichtlinienupdate anstossen, so bekommen dann alle Clients über die Gruppenrichtlinie ihren Wsus Server wieder.

 

 So hat es bei mir geklappt, könnte vielleicht auch Dir helfen, nur mal so als Tipp

 

Sascha

 

Edited by Saschat

Share this post


Link to post
Share on other sites

Die Sprache über "Einstellungen" hinzufügen da hatte ich kein Problem zumindest unter 1809.

Oder man extrahiert sich über Fiddler die entsprechende Sprache als appx und kann das dann über install-appxpackage installieren.

 

Bin noch nicht dahinter gekommen wie man mit WPP ein appx installiert, denn die werden ja als User und nicht als System installiert. Auch die Abfrage ob die App installiert ist, ist nicht ganz einfach.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...