Jump to content
Sign in to follow this  
ineedhelp

Skript wird nach Anmeldung nicht gestartet

Recommended Posts

@All

 

Wenn ich mich auf meine Systeme per RDP anmelde, soll das Programm DesktopInfo mit meinen Einstellungen ausgeführt werden. Zu diesem Zweck habe ich eine Gruppenrichtlinie definiert. In der Konfigurationsdatei von DesktopInfo habe ich definiert, dass PowerShell-Skripte Daten zur Anzeige in DesktopInfo aufbereiten sollen -> CMD=active:1,hidden:1,interval:300,file:powershell.exe,directory:%temp%,parameters:-ExecutionPolicy ByPass -Command Scripts\Get-IPConfig.ps1. Es gibt auch eine Gruppenrichtlinie auf Computerebene, die die Ausführung aller Skripte erlaubt.

 

Wenn ich mich per RDP an meinem System anmelde, werden die PowerShell-Skripte nicht ausgeführt. Starte ich das PowerShell-Skript manuell wird mir folgender Fehler angezeigt:

image.thumb.png.2d96315c8809d7a26a3d128038d7cd7d.png

 

image.png.c5efceb78de867735cd278772017733e.png

 

Sobald ich das Programm aber manuell starte, laufen meine PowerShell-Skripte wie gewünscht.

 

Was musst ich machen, dass meine PowerShell-Skripte mit DesktopInfo nach der Anmeldung die gewünschten Daten liefert. 

 

Vielen Dank im Voraus.

 

 

Edited by ineedhelp

Share this post


Link to post
Share on other sites

Leider wissen viele nicht, das der Befehl Rechsklick "Mit Powershell ausführen" nicht einfach nur der Aufruf ist. 

"C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" "-Command" "if((Get-ExecutionPolicy ) -ne 'AllSigned') { Set-ExecutionPolicy -Scope Process Bypass }; & 'P:\test.ps1'"

Hier siehst du den originalen Aufruf. Da die Einstellung auf "bypass" gestellt wird, erscheint die Meldung. Deine Einstellungen sind ja "Unrestricted". Damit eine Änderung. 

Starte die Powershell einfach normal und führe dort das Skript aus.

  • Like 1

Share this post


Link to post
Share on other sites

Danke @MurdocX. Wieder etwas dazu gelernt. Ich stehe doch noch ganz unter auf der PowerShell-Leiter. Nun funktioniert es wie gewünscht.

 

Ein kurzer Blick in die Windows-Registierungsdatenbank hätte mir es auch verraten ...

image.png.4ca19971f2d70736c62ae482d702fa9a.png

 

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...