Jump to content
possum72

Hyper-V Replica Zugriff verweigert Fehler

Recommended Posts

Hallo zusammen

Ich habe hier folgendes Problem und hoffe, Ihr könnt mir helfen.
Als Host ist ein Windows Server 2016 installiert. Darauf laufen 7 virtuelle Maschinen mit unterschiedlichen Betriebssystemen.
(Server 2012R2 und Server 2016).
6 Maschinen lassen sich ohne weiteres mit Hyper-V Replica auf einen anderen Server replizieren. Nur eine Maschine nicht.
Hier erscheint immer folgender Fehler:

Fehler beim Generieren des ersten Replikats für "TerminalServer": Allgemeiner "Zugriff verweigert"-Fehler (0x80070005). (ID des virtuellen Computers: ......
Ich kann erkennen, dass er noch das Verzeichnis der ID am Replica-Server erstellt.

Was mir auch aufgefallen ist: Wenn ich diese virtuelle Maschine einfach "nur" exportieren möchte, erscheint der gleiche Fehler.

Hat hier jeman einen Tipp für mich ?

Viele Grüße

Andreas

 

Share this post


Link to post
Share on other sites

Moin,

 

und willkommen an Board!

Normalerweise treten solche Zugriffsfehler auf Host-Ebene auf, d.h. es scheitert dann bei allen VMs. Dass es hier nur um eine VM geht, ist seltsam.

 

Meine erste Vermutung wäre daher, dass auf dem Quellsystem für die betreffende VM die Berechtigungen anders sind als bei den anderen VMs. Vergleiche mal die NTFS-Berechtigungen der fehlschlagenden VM mit denen einer "erfolgreichen". Gibt es da Unterschiede?

 

Gibt es nähere Hinweise in den Eventlogs? Hier kämen mehrere der Hyper-V-Logs in Frage, also nicht nur unter "System" nachsehen.

 

Gruß, Nils

 

Share this post


Link to post
Share on other sites

Was läuft denn in der VM?

 

Und - Replika sind OK, bei manchen Systemen (z.B. Exchange und DC´s ..) nicht zulässig oder man muss spezielles beachten (z.B. MS SQL...) :-)

Share this post


Link to post
Share on other sites

Hallo Nils

Auf diese Idee bin ich auch schon gekommen. Unterschiedlich sind ja nur immer diese Benutzer mit der VM-ID. Den habe ich sogar Vollzugriff gewährt. Ohne Erfolg.
In der Ereignisanzeige finde ich ja die Fehler unter Hyper-V-VMMS. Und hier habe ich grundsätzlich immer diesen "Zugriff verweigert" Fehler.

 

Hallo Nobby

Es handelt sich um einen TerminalServer. Also kein AD, Exchange. Da ist nicht einmal ein SQL-Server installiert :(

Die anderen Replikas habe ich auch schon mal zum Test laufen lassen. Funktionieren ohne Probleme.

 

Was ich noch nicht getestet habe: Vielleicht sollte ich einfach mal die VM löschen und eine neue anlegen (vhd wieder einbinden). Vielleicht hilft es ja.


Viele Grüße

Andreas

 

Share this post


Link to post
Share on other sites

Moin,

 

also hast du die Dateisystemberechtigungen schon manipuliert? Da besteht dann ein sehr hohes Fehlerpotenzial. 

 

Falls es möglich ist, die VM neu zu erzeugen, würde ich das versuchen.

 

Gruß, Nils

 

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb possum72:

Was ich noch nicht getestet habe: Vielleicht sollte ich einfach mal die VM löschen und eine neue anlegen (vhd wieder einbinden). Vielleicht hilft es ja.

Dann mal los! :-)

Baue doch erst mal eine neue zum Testen, klappt es dann, kannst du die immer noch wegwerfen...

Edited by Nobbyaushb

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...