Jump to content
Sign in to follow this  
kosta88

Software Deployment via GPO

Recommended Posts

Gerade eben schrieb TheCracked:

Na und ob das "unsupported" ist, will ich schon schwarz auf weiß von MS lesen :)

Hat das irgendjemand geschrieben? Außer Kosta88?

Share this post


Link to post
Share on other sites
vor 28 Minuten schrieb kosta88:

Ich bleibe derzeit auf WID, habe zwar die Anleitung für Umstieg auf SQL gesehen (und mache auch keine unsupportete Lösung mit Triggers, danke TheCracked), aber habe dafür keine Zeit jetzt, solang ich via WPP ausrollen kann, und das eine will ich machen: Citrix.

Niemand hat etwas von unsupported geschrieben, es ist einfach nur Mist mit Triggern zu arbeiten. Besser eine SP anlegen und die mnauell ausführen. Noch besser einen SQL Express installieren und umstellen. Die Umstellung ist nach der Installation des SQL Express in 2 Minuten gemacht.

 

Aber so wie ich das sehe, solltest Du dir einen Dienstleister holen, der sich mit der Softwareverteilung auskennt.

Share this post


Link to post
Share on other sites

OK, es hat sich bei mir danach angehört. Alles gut.

 

Belassen wir bitte das Thema DL, sicher nicht wegen sowas, niemand ist auf dieser Welt mit einem Wissen geboren worden und jeder muss alles mal lernen. Und nicht alles kann man sofort lernen.

Share this post


Link to post
Share on other sites

Natürlich kann man nicht alles wissen und nicht jeder weiß alles. Aber Du musst dich etwas mehr mit solchen Themen beschäftigen, man kann doch nicht alles nur in Foren erfragen. Und beschäftigen damit heißt für mich eban auch in Testumgebungen spielen und ein Gefühl für die Thematik bekommen. Selbst lernen nicht alles nur erfragen.

Share this post


Link to post
Share on other sites

Wie kannst du denn abschätzen wieviel ich selber probiere, was für Umgebung oder Umgebungen ich habe und wieviel Zeit ich in alles investiere?

Share this post


Link to post
Share on other sites

Nun, ich habe jetzt auch die (behaupte ich jetzt mal) die richtigen Einträge in:

Indicate here the rule or rules that allow clients computer to determine if the update is already installed. -> Package Level Rule, RegKey vorhanden (SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\CitrixOnlinePluginPackWeb) + DisplayName + EqualTo + Data.

Indicate here the rule or rules that allow clients computer to determine if the update is installable. -> RegKey SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\CitrixOnlinePluginPackWeb existiert, und WindowsVersion ProductType=1.

 

Und weiterhin Info "Not Applicable".

 

Kann ich irgendwie rausfinden warum der Status Not Applicable ist?

 

Anbei paar Screenshots:

c1.JPG.ca3ec54fb064a33fee8964a220a4d5fe.JPGc2.JPG.631399d773d850ff0c1bd1fd6e5ec93d.JPGc3.JPG.88f762d602bb8c5256b02d7aa2282270.JPG

 

Edited by kosta88

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb kosta88:

Wie kannst du denn abschätzen wieviel ich selber probiere, was für Umgebung oder Umgebungen ich habe und wieviel Zeit ich in alles investiere?

Anhand der Fragen und der Menge an Fragen glaube ich, das abschätzen zu können, dass Du dich zu wenig damit beschäftigst.

Share this post


Link to post
Share on other sites
vor 32 Minuten schrieb NorbertFe:

Was genau willst du verteilen? Hast du das Citrix whitepaper zum deployment mal gelesen?

Wenn ich wüsste was du genau meinst, dann tät ich mir leichter die Frage zu beantworten. Ich habe ja die funktionierendes GPO Deployment, aber wie schon im Eröffnungspost gesagt, funktioniert nicht verlässlich.

 

Ich will den Citrix Receiver 4.12 überall wo 4.9 installiert ist (automatisch) installieren. 

vor 23 Minuten schrieb Sunny61:

Anhand der Fragen und der Menge an Fragen glaube ich, das abschätzen zu können, dass Du dich zu wenig damit beschäftigst.

Vielleicht damit. Ist aber nicht das einzige womit ich mich beschäftige.

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb kosta88:

Wenn ich wüsste was du genau meinst, dann tät ich mir leichter die Frage zu beantworten.

Ich meine 1.:

was genau verteilst du? Ist das eine .exe oder ein msi? Mit welchen Parametern versuchst du das? Wenn Parameter, wo hast du die her?

 

2. Du hast oben einen link auf mein deployment whitepaper für den alten Citrix Receiver bekommen. Das ist schon etwas älter und das wurde mit neueren Versionen von Citrix nicht unbedingt besser. Also hast du ein aktuelles Citrix whitepaper zum deployment des receivers gelesen?

 

bye

norbert

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb NorbertFe:

Ich meine 1.:

was genau verteilst du? Ist das eine .exe oder ein msi? Mit welchen Parametern versuchst du das? Wenn Parameter, wo hast du die her?

Citrix Receiver hat ja nur die .exe. .msi gibt's für den CR nicht. Die von Citrix möglich Deployment-Methode: https://docs.citrix.com/en-us/receiver/windows/4-6/install/ica-client-deploy-active-dir-tasks.html

Von hier die Downloads, und Parameter denn ich nutze ist lediglich /silent (denn ohne irgendeinem Switch direkt von der Datei installiert funktioniert es auch, ergo sind keine sonstigen Parameter notwendig).

 

vor 2 Stunden schrieb NorbertFe:

2. Du hast oben einen link auf mein deployment whitepaper für den alten Citrix Receiver bekommen. Das ist schon etwas älter und das wurde mit neueren Versionen von Citrix nicht unbedingt besser. Also hast du ein aktuelles Citrix whitepaper zum deployment des receivers gelesen?

 

Also wenn du das hier meinst:

https://www.wsus.de/citrix_receiver_ueber_wsus_bereitstellen

Dann ja, danach habe ich es auch konfiguriert, auch wenn veraltet.

Und nein, habe ich nicht, denn was aktuelleres in dieser Richtung habe ich nicht gefunden.

Share this post


Link to post
Share on other sites

Yaaay!

cit.JPG.084f43b7f359b1a9f90b9fb5124ae26b.JPG

 

Yaaay!!

cit2.JPG.41d3ead917c9d7bb62ecaa4914fbfafe.JPG

 

Nach allen Schwierigkeiten, besten Dank für die Hilfe!

 

Falls interessiert, das war falsch:

"Indicate here the rule or rules that allow clients computer to determine if the update is already installed." -> "4.9" - da habe ich mich vertan. Logischerweise muss ich ja 4.12 eintragen.

Danach plop und installiert.

Edited by kosta88

Share this post


Link to post
Share on other sites
Gerade eben schrieb NorbertFe:

Glückwunsch. Naja dann wärs ja nett für evtl. später hier Nachlesende, wenn du die Lösung hier auch posten würdest. :)

Siehe oben.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...