Jump to content

Keine Statusreports nach WSUS Package Publisher Einrichtung


Go to solution Solved by wsusnoob,
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

mittlerweile habe ich mit dem WSUS Package Publisher erfolgreich Updates auf meinem Testsystem installieren können. 

 

Das blöde ist jetzt nur, dass ich eine OU habe, in welcher die rund 150 Computer keine Statusreports mehr senden. Die letzten sind von vor der Installation und Benutzung des WSUS PP.

 

WindowsUpdate Log eines Clients (mit dem wahrscheinlichen interessanten Teil):

2016-08-16	07:00:49:371	 572	1344	PT	WARNING: Cached cookie has expired or new PID is available
2016-08-16	07:00:49:371	 572	1344	PT	Initializing simple targeting cookie, clientId = 5874a2e0-8020-43d3-ba92-b7b22b3df2de, target group = NL Clients Windows 7, DNS name = 013218wi7.ads.europart.net
2016-08-16	07:00:49:371	 572	1344	PT	  Server URL = http://wsus01:8530/SimpleAuthWebService/SimpleAuth.asmx
2016-08-16	07:00:49:496	 572	1344	PT	WARNING: GetCookie failure, error = 0x8024400D, soap client error = 7, soap error code = 300, HTTP status code = 200
2016-08-16	07:00:49:496	 572	1344	PT	WARNING: SOAP Fault: 0x00012c
2016-08-16	07:00:49:496	 572	1344	PT	WARNING:     faultstring:Fault occurred
2016-08-16	07:00:49:496	 572	1344	PT	WARNING:     ErrorCode:ConfigChanged(2)
2016-08-16	07:00:49:496	 572	1344	PT	WARNING:     Message:(null)
2016-08-16	07:00:49:496	 572	1344	PT	WARNING:     Method:"http://www.microsoft.com/SoftwareDistribution/Server/ClientWebService/GetCookie"
2016-08-16	07:00:49:496	 572	1344	PT	WARNING:     ID:1988f633-1433-498a-b674-04fb31398c87
2016-08-16	07:00:49:543	 572	1344	PT	WARNING: Cached cookie has expired or new PID is available
2016-08-16	07:00:49:543	 572	1344	PT	Initializing simple targeting cookie, clientId = 5874a2e0-8020-43d3-ba92-b7b22b3df2de, target group = NL Clients Windows 7, DNS name = 013218wi7.ads.europart.net
2016-08-16	07:00:49:543	 572	1344	PT	  Server URL = http://wsus01:8530/SimpleAuthWebService/SimpleAuth.asmx
2016-08-16	07:01:08:100	 572	1344	Agent	WARNING: Failed to evaluate Superseded rule, updateId = {8FB961A9-DB99-4FC6-B7A8-6487B0670B33}.3, hr = 8024E003
2016-08-16	07:01:29:995	 572	1344	PT	+++++++++++  PT: Synchronizing extended update info  +++++++++++
2016-08-16	07:01:29:995	 572	1344	PT	  + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://wsus01:8530/ClientWebService/client.asmx
2016-08-16	07:01:30:057	 572	1344	PT	WARNING: GetExtendedUpdateInfo failure, error = 0x8024400E, soap client error = 7, soap error code = 400, HTTP status code = 200
2016-08-16	07:01:30:057	 572	1344	PT	WARNING: SOAP Fault: 0x000190
2016-08-16	07:01:30:057	 572	1344	PT	WARNING:     faultstring:Fault occurred
2016-08-16	07:01:30:057	 572	1344	PT	WARNING:     ErrorCode:InternalServerError(5)
2016-08-16	07:01:30:057	 572	1344	PT	WARNING:     Message:(null)
2016-08-16	07:01:30:057	 572	1344	PT	WARNING:     Method:"http://www.microsoft.com/SoftwareDistribution/Server/ClientWebService/GetExtendedUpdateInfo"
2016-08-16	07:01:30:057	 572	1344	PT	WARNING:     ID:2d17ebcc-d388-4eb5-baa6-9c88920fb8eb
2016-08-16	07:01:30:057	 572	1344	PT	WARNING: PTError: 0x8024400e
2016-08-16	07:01:30:057	 572	1344	PT	WARNING: GetExtendedUpdateInfo_WithRecovery: 0x8024400e
2016-08-16	07:01:30:057	 572	1344	PT	WARNING: Sync of Extended Info: 0x8024400e
2016-08-16	07:01:30:057	 572	1344	PT	WARNING: SyncServerUpdatesInternal failed : 0x8024400e
2016-08-16	07:01:30:073	 572	1344	Agent	  * WARNING: Exit code = 0x8024400E
2016-08-16	07:01:30:073	 572	1344	Agent	*********
2016-08-16	07:01:30:073	 572	1344	Agent	**  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2016-08-16	07:01:30:073	 572	1344	Agent	*************
2016-08-16	07:01:30:073	 572	1344	Agent	WARNING: WU client failed Searching for update with error 0x8024400e
2016-08-16	07:01:30:073	 572	a40	AU	>>##  RESUMED  ## AU: Search for updates [CallId = {8D739C7B-44F3-4E42-A8A3-659FF19F1F6E}]
2016-08-16	07:01:30:073	 572	a40	AU	  # WARNING: Search callback failed, result = 0x8024400E
2016-08-16	07:01:30:073	 572	a40	AU	  # WARNING: Failed to find updates with error code 8024400E
2016-08-16	07:01:30:073	 572	a40	AU	#########
2016-08-16	07:01:30:073	 572	a40	AU	##  END  ##  AU: Search for updates [CallId = {8D739C7B-44F3-4E42-A8A3-659FF19F1F6E}]
2016-08-16	07:01:30:073	 572	a40	AU	#############

So ähnlich sieht das auch bei den anderen Clients aus.

 

SoftwareDistribution Log vom WSUS Server:

2016-08-16 06:48:12.877 UTC	Warning	w3wp.38	SoapUtilities.CreateException	ThrowException: actor = http://wsus01:8530/ClientWebService/client.asmx, ID=a8fc058d-2de3-4691-8aee-0904b05974c6, ErrorCode=InternalServerError, Message=, Client=22b5e3d3-b10d-49cc-94a4-97bb241c5570
2016-08-16 06:50:42.221 UTC	Error	w3wp.13	ClientImplementation.GetExtendedUpdateInfo	System.ArgumentException: The database does not contain a URL for the file 7E1786094E4CA9EA156CAECDB91FAF8D3E387146.
Parametername: fileDigests

Ich habe bisher versucht, alle selbst erstellten Updates freizugeben und dann wieder direkt abzulehnen - leider brachte das nichts. Leider sind auch nicht alle ursprünglich erstellten Updates im WSUS PP drin, weil ich auch welche daraus gelöscht habe.

 

Das erscheint mir alles sehr komisch. Für diese spezielle OU habe ich nie die WSUS PP Updates freigegeben - dafür hab ich ja meine Test-OU. Es ist aber trotzdem die einzige, welche keine Statusreports hergibt.

 

EDIT: Es sind doch mehrere OUs, aber diese ist die größte bzw. wichtigste.

 

Hat jemand eine Idee, was ich machen könnte?

 

Vorab vielen Dank für eure Vorschläge!

 

Viele Grüße

wsusnoob

Edited by wsusnoob
Link to comment

Zuerst Entwarnung, die Verwendung vom WPP in Kombination mit dem WSUS kann nicht solche Fehler erzeugen. Warum geht das nicht? Weil der WPP einfach nur Updates dem WSUS in die DB schiebt, nicht mehr und nicht weniger. Wenn alle Clients den gleichen Fehler reporten, liegt ein grundsätzliches Problem vor.

 

Welche Build vom WSUS ist auf welchem OS installiert? Wie kommst Du an die Build? Die WSUS-FAQ wsus.de/faq No. 44 zeigt es dir. Dort findest Du auch ein Bild das dir zeigt wo die Build steht.

 

Weshalb gibst Du ein Update frei um es gleich anschließend wieder abzulehnen? Deine Logik dahinter erschließt sich mir noch nicht ganz. Auch das Löschen verstehe ich noch nicht. Ist das ein Testsystem?

Link to comment

Ach sorry, ganz vergessen - es handelt sich um den Build 6.3.9600.18228 (OS ist also Windows Server 2012 R2 Standard).

 

Das mit dem Update freigeben und ablehnen war ein gescheiterter Versuch, die Sache zu beheben. Wurde jedenfalls auf einer Seite vorgeschlagen mit einem ähnlichen Fehler wie bei mir. 

Die gelöschten Updates (waren vielleicht 1 oder 2, die anderen sind noch da im WPP) waren letztendlich nur Tests um zu sehen, ob sie mir in der Test-OU angezeigt wurden. Habe die dann kurz danach wieder entfernt.

Edited by wsusnoob
Link to comment

Ach sorry, ganz vergessen - es handelt sich um den Build 6.3.9600.18228 (OS ist also Windows Server 2012 R2 Standard).

Gut, damit wäre das geklärt.

 

 

Das mit dem Update freigeben und ablehnen war ein gescheiterter Versuch, die Sache zu beheben. Wurde jedenfalls auf einer Seite vorgeschlagen mit einem ähnlichen Fehler wie bei mir. 

Die gelöschten Updates (waren vielleicht 1 oder 2, die anderen sind noch da im WPP) waren letztendlich nur Tests um zu sehen, ob sie mir in der Test-OU angezeigt wurden. Habe die dann kurz danach wieder entfernt.

Schau auf die Startseite vom WSUS, Downloadstatus. Will der WSUS noch etwas downloaden? Wie genau hast Du was im WPP gelöscht?

Link to comment

OK, es geht vorwärts. ;)

 

Lass doch den Serverbereinigungsassistenten auf dem WSUS laufen, am besten mehrmals hintereinander.

 

Wie oft fragen die Clients den WSUS ab? Der Default sind ~20 Stunden +-20%. Weiter runter als 4 Stunden solltest du nicht gehen.

 

Jetzt zum eigentlichen Fehler. Auf einem Client der den Fehler im Log hat, eine administrativen Commandline öffnen und das hier eingeben:

 

net stop wuauserv
rd /s /q %windir%\SoftwareDistribution
net start wuauserv

wuauclt /detectnow
wuauclt /reportnow
10 Minuten warten, jetzt die WSUS-Konsole aktualisieren. Gibt es einen aktuellen Report für den Client? Auch kannst Du jetzt auf dem Client manuell nach Updates suchen lassen.
Link to comment

Danke für die Vorschläge - dann lasse ich die Serverbereinigung erstmal durchlaufen (welcher wohl ein paar Stunden braucht).

Wenn die Bereinigung wirklich Stunden braucht, dann lief schon länger etwas falsch. So ein WSUS will auch gewartet werden, dazu zählt auch die Serverbereinigung. Am besten täglich per Script im Taskplaner ausführen lassen und das Ergebnis als Mail schicken lassen. Auf deine Bedürfnisse anpassen: http://wsus.de/de/serverbereinigung2

Link to comment

Finde ich übrigens gar nicht nett von dir, dass Du beim Hersteller postest, ohne hier einen Hinweis abzugeben: http://wsuspackagepublisher.codeplex.com/discussions/657203#post1481329

 

Wenn du nicht weiterkommst, wäre es höflicher den Helfern gegenüber es zu erwähnen. Und den Crosspost darfst Du auch lt. Board Regeln melden. Und ja, natürlich darfst Du in zig Foren posten, aber die Bereitschaft dir zu helfen, sinkt bei den Leuten vermutlich die das selbst herausfinden, auch wenn es nur durch Zufall ist.

 

Und nochmal, es ist nur durch Zufall gleichzeitig mit dem WSUS aufgekommen, aber das willst Du ja nicht glauben.

Link to comment

Tut mir leid, wenn ich das nicht hier angegeben habe. Bin noch bei deinen Vorschlägen am probieren. Deshalb habe ich in der Zwischenzeit mal den anderen Post in Englisch verfasst, um eventuell mehr Input zu bekommen. Wie gesagt, ich melde mich nochmal wenns Ergebnisse gibt.


So, bin jetzt alle Sachen durchgegangen: Mehrmals die Serverbereinigung durchgeführt, auf einem Client den Windows Update Dienst gestoppt, den SoftwareDistribution Ordner gelöscht, den Dienst wieder gestartet und detectnow + reportnow gemacht - alles über die Kommandozeile als Admin. Leider kommt nichts bzw. es wird nichts übermittelt.

Wenn ich manuell nach Updates auf dem Client suche, kriege ich auch dort den Fehler mit dem Code 8024400E raus.  :(

Edited by wsusnoob
Link to comment

Schau dir mal diesen Artikel an, hast Du dieses Update installiert? https://blogs.technet.microsoft.com/wsus/2016/05/05/the-long-term-fix-for-kb3148812-issues/ Und evtl. die manuellen Schritte nicht ausgeführt?

 

Hast Du bei den Clients das selbst erstellte Zertifikat installiert? Hast Du für die Clients/Server im GPO für den WSUS diese Einstellung gesetzt? Signierte Updates aus einem Intranetspeicherort für Microsoft Updatedienste zulassen > Aktiviert.

Link to comment

Das fehlerhafte Update (also KB3148812) war vorher nicht installiert, KB3159706 habe ich trotzdem mal installiert und danach noch die Schritte von https://support.microsoft.com/en-us/kb/3159706 befolgt.

Das Zertifikat wurde auf alle Clients verteilt und liegt auch unter "Vertrauenswürdige Herausgeber". Die Einstellung mit den signierten Updates aus dem Intranet ist ebenfalls bei den Clients und Servern gesetzt.

Über Nacht tat sich nichts...

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...