Jump to content

Erstinstallation zuweisen SCCM 2012 --> Wie?


Go to solution Solved by MaikHSW,
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hey zusammen.

Ich bin gerade dabei eine SCCM 2012 Landschaft aufzubauen und bekomme noch graue Haare....

Mein Setting ist nur ein Server,  der alle Rollen hält.

Die erste Zielsetzung ist ein automatisches Deployment neuer Systeme.

Okay....

 

Ich habe eingestellt:

- PXE Boot ermöglichen

- Reagieren auf alle Anfragen, auch unbekannte

- ich habe ein Referenzsystem installiert und mit Capture Image entsprechend digitalisiert

- Ich habe eine Tasksequenz angelegt wo ich das x64 Startabbild und das Image auswähle

- Die Tasksequenz habe ich der Gruppe "Unbekannte Computer" zugewiesen.

 

Soweit, so gut.

Doch was passiert?

 

Ich bekomme nur den Fehler E-53 "No boot filename received".

Daraufhin habe ich die DHCP Eigenschaften 66 und 67 eingestellt, obwohl dies nicht nötig sein sollte (DHCP Server ist ein anderer Server).

Geht trotzdem nicht.

 

Mein nächster Verdacht war ein Problem mit dem PXE Boot, weswegen ich diesen erst einmal auschließen wollte.

Daher habe ich eine manuelle Start CD mit SCCM erzeugt und entsprechend ein System damit gebootet.

Fehlermeldung: "There are no task sequences available for this computer".

Ich habe die Sequenz aber sicher der Sammlung "Unbekannte Computer" zugewiesen.

Wo ist mein Gedankenfehler?

Oder muss ich die Sequenz irgendwie anders bereitstellen?

 

Herr Google wusste nichts weiter und das scheint irgendwo ein Mysterium zu sein.

Dem Vorgehen aus dem Bechtle Blog (http://www.bechtle-blog.com/home/teil-7-bereitstellung-von-project-2013-und-project-pro-f-r-office-365-ber-den-sccm-2012-r2) bvin ich angepasst (da kein R2) gefolgt. Aber ohne Erfolg.....

 

Irgendwelche Ideen?

 

 

 

gruß

 

 

Maik

Edited by MaikHSW
Link to comment

Hey Doso,

das mache ich ja mit der Boot CD bereits, die umgeht das PXE Thema.

Damit habe ich dann eine Variable weniger.

Aber da kommt ja dann "There are no task sequences available for this computer"..

Daher die Frage: Auf was muss ich die Tasksequenz einstellen damit sie greift?

Importiert ihr die Systeme vorher per MAC bereits in eine Sammlung?

Habe ich testweise auch versucht, aber klappt dennoch nicht.

 

Wo ist der Fehler?

 

 

Gruß

 

 

Maik

 

 

P.S.: Also das PXE Feature will ich später dennoch. Ich bin wesentlich kleiner und will die Aufgabe in naher Zukunft an Kollegen / Azubi abgeben :-)

Je weniger die falsch machen können umso besser.

Link to comment

Hey.

Klar, das läuft auch bestens.

Aber ich möchte ja mit dem SCCM nach dem Thema Neuinstallation auch eine Paketversorgung plus das Patchen abfangen.

Sprich darüber möchte ich alle Pakete (Firefox, Java...) aktuell halten.

Geht zwar theoretisch alles auch per GPO, aber ich muss auch Reportings bereitstellen können.

Und das bietet SCCM u. a. auch :-)

 

 

Gruß

 

 

Maik

Link to comment

- DHCP-Optionen 66 und 67 werden nicht benötigt und sind offiziell gesehen sogar unsupportet. Besser: IPhelper einsetzen, wenn Clients und WDS in unterschiedlichen Subnetzen. Spätestens bei UEFI-Systemen wird's unmöglich, DHCP-Optionen zu verwenden (wenn x86 und x64 verteilt werden soll - wobei "unmöglich" auch durch "extrem komplex" ersetzt werden kann)

- "boot\x86" muss nicht als Windows Share/Freigabe existieren. Hier geht's um tftp.

- "PXE aufgegeben weil zu Gefummel": eigentlich ist das nicht wirklich kompliziert und funktioniert auch in sehr großen Umgebungen

- PXE hat einen großen Vorteil im Vergleich zu USB/iso: es gibt das smspxe.log, welches sehr hilfreich für das Troubleshooting ist. Bei USB/iso schaut man da eher komplett in die Röhre. Siehe dazu auch http://www.mssccmfaq.de/2012/02/04/cm12-pxe-boot-szenarien/, sprich Du siehst im smspxe.log, welche ResourceID verwendet wird, um zu ermitteln, ob es ein Deployment einer Tasksequenz für die anfragende MAC bzw Smbios-Guid gibt.

Link to comment
  • Solution

Hey zusammen.

Um euch ein Feedback zu geben, wie ich es gelöst habe:

Ich habe noch einmal die ISO´s neu verteilt, keine Verbesserung.

Dann habe ich im WDS eingestellt, dass er auch auf fremde Anfragen antwortet.

Keine Verbesserung.

 

Dann habe ich eine Nacht darüber geschlafen und am nächsten Tag mit vollem Elan nochmal ans Troubleshooting und es lief einfach...

Keiner weiß warum....

 

Dann hat er nie eine Tasksequenz gefunden.

Aber nach einiger Recherche habe ich festgestellt, dass dies ein MS Bug ist und die Bereitstellungszeit minus 24 Stunden angegeben werden muss damit es direkt freigegeben und verteilt wird.
Ansonsten kann dies einige Stunden bis hin zu angeblich einen Tag dauern weil er es dann nach Auslastung oder einem nicht vorhersehbaren Algorithmus tut.....

 

Nun habe ich aber bei einem Notebook ein weiteres Problem, für das ich aber einen neuen Thread aufmachen werde um auch anderen "Betroffenen" eine Antwort und Recherche zu ermöglichen.

 

 

Gruß und vielen Dank

 

 

Maik

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...