Jump to content

Client meldet sich nicht mehr beim WSUS


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Leute,

 

habe seit letztem Wochenende ein Problem mit einem Client (Windows Server 2008 64bit). Und zwar kann sich dieser anscheinend nicht mehr beim WSUS-Server melden.

 

Ich habe zuerst vermutet es liegt am Client, aber nachdem ich gestern einen halben Tag versucht habe, das ganze mit dem WSUShelper wieder zum laufen zu bringen befürchte ich dass es am Server liegt...

ResetID, Agent neu installieren, Force Patching, alles ohne Erfolg.

 

Als Fehler wird

 

AutomaticUpdates Failure Software Synchronization Windows Update Client failed to detect with error 0x8024400a

 

geloggt. Das Online-Update über Windows Update funktioniert problemlos. Ich hatte gestern den Client dann auch mal aus dem WSUS rausgelöscht, der ist bis heute nicht wieder aufgetaucht... Sieht also so aus als würde der Server die Verbindung nicht annehmen, bzw. nicht annehmen können...

 

Nachdem ich mir die Finger wund gegoogelt habe und keine zündende Lösung gefunden habe, hoffe ich hier mal auf Erfolg :-) Der letzte Schritt wäre natürlich WSUS neu zu installieren, das möchte ich aber unter allen Umständen vermeiden da ich dann ja (vermutlich) auch den LUP mit allen Updates nue aufsetzen müsste.... :-(

 

Also ich wäre für alle Ideen dankbar, mir sind sie ausgegangen....

Link to comment

habe seit letztem Wochenende ein Problem mit einem Client (Windows Server 2008 64bit). Und zwar kann sich dieser anscheinend nicht mehr beim WSUS-Server melden.

Anscheinend oder kann er sich nicht mehr beim WSUS melden? ;)

 

Ich habe zuerst vermutet es liegt am Client, aber nachdem ich gestern einen halben Tag versucht habe, das ganze mit dem WSUShelper wieder zum laufen zu bringen befürchte ich dass es am Server liegt...

ResetID, Agent neu installieren, Force Patching, alles ohne Erfolg.

Hast Du auch den Download Cache auf dem betroffenen Server geleert/gelöscht? Wozu braucht man ein Tool, Windows bringt alles mit.

 

net stop wuauserv

net stop bits

rd /s /q %windir%\SoftwareDistribution

net start wuauserv

net start bits

wuauclt /detectnow

wuauclt /reportnow

 

Ein blindes ResetID ist nicht besonders hilfreich.

 

AutomaticUpdates Failure Software Synchronization Windows Update Client failed to detect with error 0x8024400a

 

Dazu gibt es einen FixIt von MS: http://windows.microsoft.com/de-DE/windows7/Windows-Update-error-8024400a-8024400d-or-8024400e Hast Du den schon ausgeführt? Wenn ja, weshalb schreibst Du das nicht?

 

Überprüfe gem. WSUS-FAQ No. 44 die exakte Version deines WSUS: http://www.wsus.de/faq Da ist auch ein Bild dabei, dort findest Du die exakte Stelle der Versionsnummer.

 

 

 

 

 

geloggt. Das Online-Update über Windows Update funktioniert problemlos. Ich hatte gestern den Client dann auch mal aus dem WSUS rausgelöscht, der ist bis heute nicht wieder aufgetaucht... Sieht also so aus als würde der Server die Verbindung nicht annehmen, bzw. nicht annehmen können...

 

Nachdem ich mir die Finger wund gegoogelt habe und keine zündende Lösung gefunden habe, hoffe ich hier mal auf Erfolg :-) Der letzte Schritt wäre natürlich WSUS neu zu installieren, das möchte ich aber unter allen Umständen vermeiden da ich dann ja (vermutlich) auch den LUP mit allen Updates nue aufsetzen müsste.... :-(

Wenn andere Clients/Server kein Problem haben, liegt es wohl NICHT am WSUS. Der ist dumm wie Trocken Brot, steht nur da und stellt das zur Verfügung was Du genehmigst. Die Clients verbinden sich zum WSUS und holen die Updates ab.

 

EDIT: Ist denn das SP2 für Windows 2008 auch installiert?

Edited by Sunny61
Link to comment

Den Downloadcache hatte ich geleert, Fehler besteht weiterhin. Das Service Pack 2 für 2008 ist installiert. Version WSUS = 3.2.7600.262, also aktuell.

 

Aber mit dem Fixit habe ich ein Problem; da wird die Datei windowsupdate.diagcab runtergeladen, diese kann ich aber nicht ausführen... Ich habe sie runtergeladen, aber das System findet kein Programm mit dem die Datei zu öffnen ist...

Was mache ich da denn falsch??

Link to comment

Wird wirklich immer noch der gleiche Fehler in der WindowsUpdate.log angezeigt? Gibt es denn andere/weitere Fehlermeldungen im Eventlog auf dem Server?

 

Die DIAGCAB kannst einfach entpacken, da sind ein paar Powershell Scripte enthalten zum prüfen von Fehlern. Das ein oder andere kannst Du sicherlich auf dem Server ausführen lassen, anschließend immer gleich mal probieren ob es wieder klappt.

Link to comment

Ja, immer noch der gleiche Fehler. Anwendungs- und Systemlog sind sauber, nur im Log von Windows Update wird (logischerweise) "Fehler bei der Suche nach Updates: 0x8024400a." geloggt

 

Welche Scripte wären denn da für dieses Problem nützlich? Sind ja massig Scripte drin...

Edited by Marco31
Link to comment

Der WSUS ist ein W2K8 64bit, das sollte also nicht das Problem sein. Der Wsus läuft auf dem Standard-Port 80. In welche Logdatei muss ich da suchen?

 

In der %windir%\WindowsUpdate.log.

 

Downloade diesen WU-Agent: http://download.windowsupdate.com/WindowsUpdate/redist/standalone/7.4.7600.226/WindowsUpdateAgent30-x64.exe Zum installieren mußt Du den Paramter /WUFORCE dazu nehmen. Also über Start > Ausführen Pfad_zur_EXE /WUFORCE [ENTER]. Wenn der WU-Agent korrekt installiert wurde, wie o.g. das Verzeichnis SoftwareDistribution löschen, das WindowsUpdate.log auch gleich löschen und mit wuauclt /detectnow alles neu anfordern. Funktioniert es jetzt?

Link to comment

Habe alles so durchgeführt, aber keine Chance, immer noch der gleiche Fehler... Zum verzweifeln....

In der Logdatei wird der WSUS-Server auch richtig als VMWSUS:80 angezeigt.

Wie genau steht der WSUS dort drin? Kannst Du vielleicht eine kleine Logdatei uploaden oder einen Link dorthin hier posten? Ich bin es leid immer alles zu hinterfragen, ein unverändertes Log ist sehr ehrlich.

Link to comment

Zuerst bitte den Namen des WSUS im GPO korrigieren, das steht jetzt drin: http://vmwsus:80 Lass das :80 weg, HTTP ist Port 80. Wenn die Änderung auf dem Client ankommt, lass diese Befehle erneut laufen:

 

net stop wuauserv
net stop bits
rd /s /q %windir%\SoftwareDistribution
net start wuauserv
net start bits
wuauclt /detectnow
wuauclt /reportnow

 

 

Ruf diesen Link auf: http://vmwsus/selfupdate/wuident.cab Was passiert? Welche Fehlermeldung bekommst Du angezeigt?

 

Downloade dieses Tool: http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx Installieren und alle angebotenen .Net Framework Versionen deinstallieren, neu starten, anschließend Windows Update Online aufrufen und alle angebotenen .Net Framework Versionen installieren.

Link to comment

Hallo,

ich habe ein ähnliches Problem.

Nachdem ich den WSUS-Server neu aufgesetzt habe, erstellen mit Ausnahme neu aufgenommener Objekte keine Objekte der Domäne Berichte und holen auch keine Patche vom WSUS.

Platform ist W2K3 Standard Edition

WSUS 3.0 SP1

Bei den Clients handelt es sich um WinXP SP3, W2K3 SP2 und W2K8 R2 x64 Rechner.

Vor der Neuinstallation hat alles funktioniert.

Kann mir Jemand helfen?

Viele Grüße

Bernd

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...