Jump to content
Sign in to follow this  
nails80

Robocopy auf Win 2008 R2 mit einem Mac-Server

Recommended Posts

Hallo an alle,

 

wir haben unseren alten Win2003 File-Server gegen einen 2008R2 ausgetauscht. Soweit funtkioniert auch alles, aber ich habe ein Problem mit robocopy.

 

Wir lassen mit einer Batch-Datei einen robocopy-Befehl ausführen, der neue PDF-Dateien von einem MAC-Server auf den neuen 2008er-Server kopieren soll.

 

 

Die Batch-Datei sieht wie folgt aus: robocopy "X:" "D:\Pdf\" *.pdf /w:1 /r:1 /NS /NC

 

 

Folgender Fehler wird nur bei neuen/geänderten PDF-Dateien angezeigt:

"2011/12/07 16:02:35 FEHLER 2 (0x00000002) Zugriff auf Zielverzeichnis X:\

Das System kann die angegebene Datei nicht finden."

 

 

X steht für das Netzlaufwerk, welches mit "\\192.168.1.45\pdf" und den entsprechenden Benutzerinformationen des MAC-Servers verbunden ist.

Die IP-Adresse des Mac-Servers habe ich unter den Internetoptionen --> Lokales Intranet --> Sites hinzugefügt.

Im Windows-Explorer kommt dadurch auch keine Sicherheitwarnung, wenn ich Dateien von dem Mac-Server auf den Windows-Server kopiere. Unter 2003 macht die Batch keine Probleme, nur unter 2008...

 

Was hat sich den bei 2008 geändert, dass diese Batch nicht mehr funktioniert?

Hat irgendjemand eine Idee oder Ansatz, wo ich weiter suchen könnte? Mir sind die Ideen momentan leider ausgegangen...

 

Bin für jeden Tipp dankbar face-smile

 

 

Beste Grüße

Simon

Share this post


Link to post
Share on other sites

@zahni

Ja es ist die 2008R2 robocopy-Version.

 

@Dukel

Kann ich prinzipiell machen, aber der Server fragt normalerweise nach einem Benutzernamen und Password. Da ich diese nicht als Klartext in der Batch-Datei hinterlegen möchte, gehe ich den Weg über das Netzlaufwerk. Machte unter 2003 auch keine Probleme. Wie schon gesagt mit dem Windows-Explorer habe ich kein Problem die Datien zu kopieren.

Share this post


Link to post
Share on other sites

Es funktioniert tatsächlich mit der alten Robocopy-Version... was für ein schei...

 

Danke für den Tipp!!!

 

Wäre natürlich jetzt interessant zu wissen, warum das mit der neuen Version von robocopy nicht funktioniert und bei der alten schon, aber ich bin ja erstmal froh, dass es überhaupt funktioniert. Danke nochmal!

Share this post


Link to post
Share on other sites

Wir werden in den nächsten Monaten den alten Mac-Server eh raus schmeißen, also kann ich mit der Lösung bis dahin leben. Der alte MAc-Server wird gegen einen Windows-Server ersetzt, wo ich dann definitiv keine Probleme bezüglich robocopy haben werde.

 

Danke nochmal für den Tipp!

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...