Jump to content

Routing zwischen zwei Netzen


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

ich habe Verbindungsprobleme zwischen zwei Netze.

192.168.214

192.168.2

 

 

 

Folgendes Szenario:

 

Es sind zwei Server, Win2003 u. win2008(mit zwei Netzwerkkarten), u. ein XPclient

Win2003, DNS Server = 192.168.214.10, Mask=255.255.255.128, Gateway=192.168.214.1,

DNS=192.168.214.10 u.192.168.214.8

win2008, Mitgliedserver = 1. Netzwerkkarte -> 192.168.214.8, Mask=255.255.255.128, Gateway=192.168.214.1,

DNS=192.168.214.10 u.192.168.214.8

2. Netzwerkkarte -> 192.168.2.2, Mask=255.255.255.128,

DNS=192.168.214.8

 

XPclient (hängt an der 2. Netwekkarte vom Mitgliedserver) = 192.168.2.3, Mask=255.255.255.128, Gateway=192.168.2.2

 

folgendes Routing wurde eingegeben:

route add 192.168.2.0 mask 255.255.255.128 192.168.214.1

 

vom XPclient (192.168.2.3)-> Ping 192.168.2.2 oder 192.168.214.8 funktioniert

 

aber auf dem w2003 Server (192.168.214.10) funktioniert der Ping nicht,

auf die Gateway 192.168.214.1 auch nicht

 

Was mache ich falsch?

wer kann mir bitte weiterhelfen ?

Link to comment

Hast du auf dem Win 2008 Server den Routing und RAS Dienst installiert und konfiguriert ?

 

So wie ich das sehe möchtest du ja den 2008 Server routen lassen.

 

Der route add Befehlt ist Sinnlos. Da der Client sich ja bereits im 192.168.2.0er Netz befindet.

 

Du vergibst dem Client ja bereits ein Defaultgateway, welcher der 2008er Server ist, dahin leitet der Client all seine IP Pakete, die er in kein Netz stecken kann.

 

 

Beschäftige dich doch ein wenig mit den Grundlagen von Subnetting und Routing und versuch den Beitrag das nächste mal etwas klarer zu schreiben, das kann ja kaum einer aus einander frickeln ;)

Link to comment

Hallo,

 

auch hinsichtlich der Klarheit der Eröffnung schliesse ich mich meinem Vorschreiber an. Bitte strukturiere in Zukunft! Setze die Dinge auch deutlich voneinander ab. Es sollte lesbar sein wie eine Skizze.

Ich muss es gestehen, nach 10h Arbeit fällt mir solch ein Geschreibsel schwer zu lesen.

 

:)

 

Ich hatte mal sowas ähnliches: Der Sender erhielt Antwort von den Interfaces des Weges, nur nicht vom Ziel auf der anderen Seite.

 

Woran lag es?

 

Der Client auf der anderen Seite schickte die Antwort an sein Gateway, das war aber der Internetrouter seines Subnetzes nicht der routende Server.

 

Die Antwort muss also an das richtige Gateway.

Link to comment

Hallo,

erstmals Danke für die Antworten, ich versuche nochmals

die Konfiguration zu erklären.

Der Dienst auf dem Server2008 Routing u. RAS wurde installiert, u. ich möchte gerne

den Routing auf dem Server 2008 konfigurieren.

Es sind 3 PC's, zwei Server u. ein XP Client,

- Der erste Server (2003) hat die IP 192.168.214.10 u. die Gateway 192.168.214.1

eingetragen.

- Der zweite Server (2008), sind zwei Netzwerkkarten konfiguriert,

dier erste mit IP 192.168.214.8 Mask 255.255.255.128 Gateway 192.168.214.1, u. die zweite Netzwerkkarte IP 192.168.2.2 Mask 255.255.255.128,

- Der XP-Client IP 192.168.2.3 Mask 255.255.255.128 Gateway 192.168.2.2

 

Der XP-Client (IP 192.168.2.3) ist verbunden mit der zweiten Netzwerkkarte vom Server (2008) (IP 192.168.2.2),

nach dem Routing auf dem Server (2008)

route add 192.168.2.0 mask 255.255.255.128 192.168.214.1

ist der Ping möglich vom XP-client (ip 192.168.2.3) auf Server (2008) (zweite Netzwerkkarte) 192.168.2.2

u. auch auf Server (2008) (erste Netzwerkkarte) 192.168.214.8,

nur nicht auf dem Server (2003) ( IP 192.168.214.10) ist kein Ping möglich.

Es wäre notwendig eine Verbindung mit dem Server (2003) (IP 192.168.214.10) herzustellen, weil

er der DNS Server ist.

Link to comment

Tur mir leid,

 

schon beim Anschauen vergeht jede Lust zum Lesen.

 

Was soll denn bei RRAS konfiguriert werden? Normalerweise funktioniert auf einem WinServer mit zwei Interfaces das Routing dazwischen per Default.

 

Meine Vorgehensweise wäre:

 

- vom Sender ein Ping auf das erste Interface des ersten Servers, daher müsste eine Antwort empfangen werden.

 

- vom Sender ein Ping auf das zweite Interface des ersten Servers, daher müsste eine Antwort empfangen werden.

 

- vom Sender ein Ping auf das zweite Interface des zweiten Servers, daher müsste eine Antwort empfangen werden.

 

- vom Sender ein Ping auf das erste Interface des zweiten Servers, daher müsste eine Antwort empfangen werden.

 

Funktioniert das oder nicht?

 

Falls nicht, was nicht?

Edited by lefg
Link to comment

ganz wichtig, wie lefg schon sagte, du musst am Win2003 das gateway ändern, oder eine Route setzen.

 

Am XP Client und WIN 2008 müssen keine händischen Routen hinterlegt werden

 

Am XP Client bitte als Default GW die 192.168.2.2 eintragen

Am Win 2008 Server den Routing und RAS Dienst installieren.

 

Am Win 2003 Server folgende Route setzen:

 

route add 192.168.2.0 mask 255.255.255.0 192.168.214.8

 

Dann sollte das Routing auch funktionieren, vorausgesetzt der RRAS Dienst ist richtig konfiguriert auf dem Win 2008 Server.

 

Kann der Win 2008 Server den Win 2003 und den XP Client anpingen?

Link to comment

Zunächst würde ich vorschlagen: Ein Bild sagt mehr als tausend Worte ;)

 

Nun: Wer hat denn die 192.168.214.1? Die wird als Gateway definiert, die hab ich aber bei keinem Server gefunden?

Routing geht entweder über Gateway oder über definierte Routen (eben jenes "route add"). Route und Rückroute müssen klar sein, dann funktionierts.

Link to comment

Hallo,

Danke Snoopy20004, die Verbindungen sind jetzt in Ordnung, der Routing-Eintrag auf dem Server 2003 hatte gefehlt, die Gateway 192.168.214.1 ist extern da habe ich keinen einfluss darauf, der Ping vom XP-Client 192.168.2.3 auf die GW 192.168.214.1 funktioniert noch nicht, ich denke da fehlt auch noch ein Routing auf der GW, aber die anderen Verbindungen stehen. Die ganze Sache ist für einer produktiver Umgebung gedacht.

Ich möchte euch nicht nerven aber jetzt habe ich das nächste Problem, die Namensauflösung funktioniert auf dem XP-Client noch nicht 100%, fehlt da eine DNS weiterleitung ?, weil das ein anderes Netz ist, bei nslookup auf dem XP-Client findet er sofort den DNS Server 192.168.214.10 (windows 2003), nur wenn ich nochmals den Namen im "nslookup" vom (Win 2003) eingebe bringt er Timeout.

Ich habe nochmals ein Bild gemacht, vielleicht ist es jetzt verständlicher.

Server 2008 wurde folgeneder Route eingetragen:

route add 192.168.2.0 mask 255.255.255.128 192.168.214.1

Server 2003 wurde folgeneder Route eingetragen:

route add 192.168.2.0 mask 255.255.255.0 192.168.214.8

 

2199_001.tif

Link to comment

Hier ein Beispiel für die textliche Darstellung einer einfachen Struktur anhand der Daten aus der Eröffnung des Thread.

 

2003

DNS:192.168.214.10 u.192.168.214.8

Gateway:192.168.214.1

Mask:255.255.255.128

IP:192.168.214.10

|

|

IP:192.168.214.8

Mask:255.255.255.128

Gateway:192.168.214.1

DNS:192.168.214.10 u.192.168.214.8

1.Interface

2008

2.Interface

DNS:192.168.214.8

Mask:255.255.255.128

IP:192.168.2.2

|

|

IP=:192.168.2.3

Mask:255.255.255.128

Gateway:192.168.2.2

XP

Edited by lefg
Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...