Jump to content
Sign in to follow this  
g1n

DHCP-Probleme mit Win7 Professional 32bit

Recommended Posts

Hi Leute,

 

da ich seit neustem meine Laptops auf Arbeit nach und nach auf Windows 7 Professional umstelle, bemerke ich nach und nach immer mehr Problem mit dem Netzwerkstack (kann sein das diese Problem bereits unter Windows Vista bestanden, habe ich nur nie eingesetzt im Unternehmen). Wenn die Thinkpads (T400s/T400/L412) mit Netzwerkstecker angesteckt hochfahren ist alles in Ordnung. Wenn dann aber der Netzwerkstecker entfernt und später wieder eingesteckt wird, kommt es sehr häufig vor, dass der Rechner vom DHCP-Server keine IP mehr zugewiesen bekommt (die Netzwerkerkenung mahnt dann ein "nicht identifiziertes Netzwerk" an). Der DHCP-Server läuft auf einem Windows 2003 R2 Server, wo es mit diesen Rechnern die vorher mit Windows XP SP3 liefen, nie solche Probleme gab.

 

Ich habe spaßeshalber per Regedit auf einigen der Rechner die Netzwerkidentifizierung deaktiviert ([HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet\

"EnableActiveProbing"=dword:00000000), was aber nicht unbedingt einen großen Effekt hatte. Ich verwende, soweit ich das sehe, die aktuellste treiber für die Netzwerkchips.

 

Hat jemand bei sich ähnliche Situationen beobachtet und evtl. eine Idee wie man solche Vorkommnisse minimieren kann?

 

Beste Grüße und danke fürs Lesen,

g1n

Share this post


Link to post

Als Sicherheitssoftware verwenden wir die Windows Firewall, die aber exakt genauso konfiguriert ist wie davor unter Windows XP. Ich hatte auch erst die Vermutung das diese evtl. dazwischenfunkt und habe sie testhalber deaktiviert. Leider ohne Erfolg.

Als Antivirensoftware setzten wir F-Secure for Windows Workstations in Version 9 ein, dort wird nicht in die Netzwerkkonfig eingegriffen.

 

Hier mal IP-Config eines der Rechner...wie es der Zufall will, lässt sich das Problem gerade nicht reproduzieren ;) ich hab aber jedesmal bei der ipconfig reingeschaut wenn das Problem bestand. DHCP stand auf aktiv und Windows hatte dem Rechner einfach eine 169er IP zugeteilt mit 255.255.0.0 Subnetzmaske...der Klassiker wenn Windows kein DHCP-Signal bekommt ;)

 

Windows-IP-Konfiguration

 

Hostname . . . . . . . . . . . . : PC-4200100

Primäres DNS-Suffix . . . . . . . : domain.local

Knotentyp . . . . . . . . . . . . : Unbekannt

IP-Routing aktiviert . . . . . . : Nein

WINS-Proxy aktiviert . . . . . . : Nein

DNS-Suffixsuchliste . . . . . . . : domain.local

 

Ethernet-Adapter LAN-Verbindung 3:

 

Verbindungsspezifisches DNS-Suffix: domain.local

Beschreibung. . . . . . . . . . . : Marvell Yukon 88E8057-PCI-E-Gigabit-Ethernet-Controller

Physikalische Adresse . . . . . . : 44-87-FC-44-F1-63

DHCP aktiviert. . . . . . . . . . : Ja

Autokonfiguration aktiviert . . . : Ja

Verbindungslokale IPv6-Adresse . : fe80::f5ad:21cb:5c1a:de04%15(Bevorzugt)

IPv4-Adresse . . . . . . . . . . : 192.168.3.34(Bevorzugt)

Subnetzmaske . . . . . . . . . . : 255.255.255.0

Lease erhalten. . . . . . . . . . : Freitag, 3. September 2010 09:29:39

Lease läuft ab. . . . . . . . . . : Samstag, 4. September 2010 09:29:39

Standardgateway . . . . . . . . . : 192.168.3.2

DHCP-Server . . . . . . . . . . . : 192.168.3.11

DHCPv6-IAID . . . . . . . . . . . : 306481148

DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-13-91-4C-BF-00-01-6C-95-A0-3B

 

DNS-Server . . . . . . . . . . . : 192.168.3.11

192.168.3.12

NetBIOS über TCP/IP . . . . . . . : Aktiviert

 

Tunneladapter isatap.domain.local:

 

Medienstatus. . . . . . . . . . . : Medium getrennt

Verbindungsspezifisches DNS-Suffix: diffferent.local

Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter

Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0

DHCP aktiviert. . . . . . . . . . : Nein

Autokonfiguration aktiviert . . . : Ja

Share this post


Link to post
Als Sicherheitssoftware verwenden wir die Windows Firewall, die aber exakt genauso konfiguriert ist wie davor unter Windows XP. Ich hatte auch erst die Vermutung das diese evtl. dazwischenfunkt und habe sie testhalber deaktiviert. Leider ohne Erfolg.

 

Ich hab noch nie gesehen das die Windows FW für solche Probleme verantwortlich war.

 

Als Antivirensoftware setzten wir F-Secure for Windows Workstations in Version 9 ein, dort wird nicht in die Netzwerkkonfig eingegriffen.

 

Ein deinstallieren zum testen an einem Client kann nicht schaden.

 

Hier mal IP-Config eines der Rechner...wie es der Zufall will, lässt sich das Problem gerade nicht reproduzieren ;) ich hab aber jedesmal bei der ipconfig reingeschaut wenn das Problem bestand. DHCP stand auf aktiv und Windows hatte dem Rechner einfach eine 169er IP zugeteilt mit 255.255.0.0 Subnetzmaske...der Klassiker wenn Windows kein DHCP-Signal bekommt ;)

 

Setz doch auch mal die beiden Einstellungen aus der GPO-FAQ No. 36 und starte die Clients zweimal durch. FAQ-GPO Dann würde ich bei so einem Problemclient auch mal das TCP/IP resetten.

 

Start > Ausführen > cmd [ENTER]

 

netsh int ip reset ipreset.txt [ENTER]

netsh winsock reset [ENTER]

netsh firewall reset [ENTER]

netsh firewall set icmpsetting 8 [ENTER]

netsh firewall set service FILEANDPRINT ENABLE SUBNET [ENTER]

 

Neustart.

Share this post


Link to post

sorry das ich solange nicht geantwortet habe, war krank.

@Sunny

 

danke für den Tipp, dass GPO-Setting ist bei allen Rechner aktiviert (gab sonst Probleme bei der Installation von MSI-Paketen per GPO). Ich werde bei der nächsten Gelegenheit werde ich die netsh-Befehle mal probieren.

 

melde mich

g1n

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...