Jump to content
Sign in to follow this  
dormi98

IMCEAEX Fehler

Recommended Posts

Hallo zusammen!

 

Ich habe hier auf Wunsch des Kunden eine neue Domäne angelegt und alles auf neuen Win2008 und Exchange2007 Servern neu gemacht. Bitte erklärt mir nicht, dass das nicht clever ist, es war ausdrücklicher Kundenwunsch dass das AD neu gemacht wird.

 

Es hat eigentlich alles super funktioniert. Die Mailboxen wurden mit exmerge und import-mailbox übernommen,.... läuft alles.

 

Auf den Clients habe ich überall die Outlook.NK2 (Datei für manuell eingegebene Adressen) gelöscht.

Schreibt ein User ein Mail an einen anderen internen User funktioniert das wenn er das Kürzel eingibt und auf Namen prüfen klickt und wenn er sich über die globale Adressliste den Empfänger raussucht.

Was aber nicht funktioniert, ist wenn man auf ein E-Mail antwortet, welches vor der Umstellung geschrieben wurde.

In diesem Fall bekommt man folgende NDR:

 

Generierender Server: neuerservername.neuedomäne.local

 

IMCEAEX-_O=Firmenname_OU=ERSTE+20ADMINISTRATIVE+20GRUPPE_CN=RECIPIENTS_CN=Empfängername@neuerDomänenname

#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

 

2 Sachen sind mir dabei unklar. :confused: Ich dachte dass Outlook versuchen wird auf die alte Domän zu antworten, was aber offensichtlich nicht der Fall ist. Gibt es eine Möglichkeit Adressen auf dem neuen Server anzulegen, sodass der diese Nachrichten akzeptiert. Ich dachte da an X400 Adressen. Ich konnte am 2007er zwar eine X400 Domäne anlegen, aber da brauchen ja wohl die Mailboxen auch X400 Adressen.

 

Danke

Gerald

Share this post


Link to post

Antworten an alte Mails gehen an den "LegacyExchangeDN" des damaligen Absenders. Do kannst jedem Benutzer eine zusätzliche sekundäre Adresse vom Typ X500 verpassen mit dem Aufbau "/O=orgname/ou=Name der Admingruppe/cn=Recipients/cn=alias". Also neue E-Mail Adresse, benutzerdefiniert, X500 und dann den String eingeben den du aus der alten Umgebung noch gewinnen oder raten musst.

 

Grüße

Wolfgang

Share this post


Link to post

hey danke - hat super geklappt.

Habe nur noch ein kleines Problem damit.

Lege ich die Adresse vom Typ X500 manuell an klappt es perfekt. Der String sieht so aus:

"/O=Firmenname/ou=Erste administrative Gruppe/cn=Recipients/cn=alias"

 

Jetzt wollte ich noch die E-Mail Adressrichtlinie adaptieren sodass alle eine solche E-Mail Adresse bekommen. Aber der String

"/O=Firmenname/ou=Erste administrative Gruppe/cn=Recipients/cn=%m"

wird bei der Erstellung für die Adressrichtlinie nicht akzeptiert.

 

%m ist die Variable für Exchange Alias

 

Müsste der String dann anders lauten?

Share this post


Link to post

Das wird nicht funktionieren mit der X500 Adresse in einer Empfängerrichtlinie. Der Exchange hat dafür keine DLL mit der er diese generieren könnte. Bleibt nur Handbetrieb.

 

Grüße

Wolfgang

Share this post


Link to post

Ich habe gerade kein AD zur Hand. Aber hier der Blogeintrag vom MSExchange Team.

 

Once you have your users selected, the X500 address option is on the Email Addresses Continued tab.

Share this post


Link to post

sauber, das funktioniert. Die alte 1.6er Version kann das noch. Gibt man ins X500 Feld den Wert "/O=Firmenname/ou=Erste administrative Gruppe/cn=Recipients" ein passt es schon, der Alias wird von selber angehängt.

Share this post


Link to post

Nicht schlecht dieses ADModify. Allerdings läufts noch nicht so richtig.

Ich kann zwar alles in ADModify einstellen und es läuft auch ordnungsgemäß durch, allerdings erscheint in der Exchange Konsole die angelegte Adresse nicht. Auch nicht nach einer AD Replikation sowie einem Serverneustart.

Share this post


Link to post

Hmm. Nach der Objektauswahl erscheinen die Benutzer im rechten Fensterbereich. Hast du dort die gewünschten Benutzer mit <strg> Klick oder "select all" markiert? Die spätere Operation wirkt nur auf die ausgewählten Objekte.

Share this post


Link to post

Ja habe ich. Der Assistent sagt auch dass X Werte erfolgreich geschrieben wurden.

 

Ich habe aber mitlerweile eine andere Methode gefunden. Und wie könnte es anders sein über die Powershell. Da steckt wirklich was drin.

 

$temp = get-mailbox -identity testuser

$temp.EmailAddress.add("X500:/O=Firmenname/ou=Erste administrative Gruppe/cn=Recipients/cn=testuser")

Set-Mailbox -Instance $temp

 

Diese Zeilen muss man nun nur noch mit allen Userdaten befüllen und in ein Powershell Script schreiben.

 

Trotzdem vielen Dank für Eure Hilfe.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...