Jump to content
Sign in to follow this  
Anax

Ein alter Server nervt...

Recommended Posts

Hi! Ich habe ein Problem mit einer Systemumstellung: Ich habe einen NT4.0-Server gegen einen 2003-Server ersetzt, inkl. Exchange und allem drum und dran.

 

Als ich die alte Kiste jedoch abschaltete, knallte es: Die Rechner im Netzwerk versuchen alle, irgendwelche NetBIOS-Namensauflösungen über den (jetzt ausgeschalteten) Server zu machen, und hängen für ca. 30s, weil sie natürlich keine Rückmeldung kriegen. Die Rechner versuchen bei fast jeder (auch lokalen) Dateioperation auf den alten Server zuzugreifen, UND ICH HAB KEINEN BLASSEN SCHIMMER, WIESO!

 

Wenn man NetBIOS über TCP/IP abschaltet, ist das Problem gelöst, nur ist dann halt die Arbeitsgruppe flöten; da nicht alle Rechner hier bei uns sich direkt an der Domäne anmelden, müssen wir aber die Arbeitsgruppe behalten.

 

WARUM WOLLEN DIE COMPUTER ALLE NOCH WAS VON DIESEM LUMPIGEN ALTEN SERVER? Ich bin für jeden Hinweis ECHT dankbar!!

 

Viele Grüße,

Anax

Share this post


Link to post

tja viel kann ich leider auch nicht zu deinem Problem sagen.

Hast du schonmal versuch an einem Client Netbios zu deinstallieren. Und dann einfach nochmal neu draufzubügeln.

Ich denke es werden noch Einträge auf den Nt Server zeigen.

 

 

Haben alle Pc´s auch die in der Domäne dieses Problem.??

 

Und ich dachte eigentlich immer das er die Namensauflösung über DNS und Wins (NT) macht und nicht über NetBios.

 

So long Phoenix

Share this post


Link to post

Hi Phoenix:

 

NetBIOS kann man auf XP-Rechnern (glaube ich) nicht explizit deinstallieren, sondern man kann nur bei den TCP/IP-Einstellungen "NetBIOS über TCP/IP deaktivieren". Das funktioniert, wie gesagt, damit killt man aber auch die Workgroup-Anzeige. Wo sind denn diese Einträge gespeichert, die Du ansprichst? Kann man die vielleicht manuell löschen?

 

Vielen Dank erstmal für Deine Hinweise,

viele Grüße,

 

Anax.

Share this post


Link to post

Hi fweiner:

 

Echt? Wie ist denn Deine Konfiguration?

 

Der neue Server bei mir ist so eine Multifunktions-Kiste: WINS, DNS, Exchange, Drucker, etc. pp. Wo muss man denn an den DNS-Einstellungen drehen? Momentan holen sich die Clients sämtliche DNS-Abfragen von diesem Server (der die Anfragen an einen "richtigen" DNS-Server weiterleitet, wenn er die Adresse nicht kennt).

 

Viele Grüße,

Anax.

Share this post


Link to post

Hi Anax !

Hast Du Einträge der Wins-Server an den Clients gecheckt ?

Eventuell steht dort der NT-Server noch drin.

Ansonsten könnte es auch ein Eintrag in der lmhosts. sein, die noch auf den NT-Server verweist als DC (falls lmhosts-Einbeziehung in die Namensauflösung aktiviert ist an den Clients).

 

Daß es ein DNS-Problem ist, bezweifel ich.

Share this post


Link to post
Ich habe einen NT4.0-Server gegen einen 2003-Server ersetzt

Interessant wäre zu wissen, wie du ihn ersetzt hast.

Alter Name, alte IP, neuer Name, neue IP?

 

Die Rechner im Netzwerk versuchen alle, irgendwelche NetBIOS-Namensauflösungen über den (jetzt ausgeschalteten) Server zu machen

Das heisst, sie senden dort ein Paket mit Namensauflösung an den Port 137 hin? Oder per Broadcast? Oder was tun die Clients genau in Bezug auf den alten Server?

 

Ist mir alles etwas unklar :confused:

 

 

grizzly999

Share this post


Link to post

Moin!

 

Erstmal vielen Dank für die vielen Postings! Also, es sieht folgendermaßen aus:

 

1. Der neue PDC hat eine neue IP, einen neuen Namen, und die Domäne heißt auch anders (die alte ist tot). Der neue PDC ist jetzt ein 2003-Server, bis jetzt noch gemischt konfiguriert, bis ich die alten Maschinen aus dem Netz sortiert habe, der alte war ein NT4.0.

 

2. Das Paket geht an netbios-ssn (Port 139). Es ist also anscheinend doch keine Namensauflösung, sorry. Aber warum wollen die Rechner alle eine NetBIOS-Session mit der alten Maschine aufbauen?

 

3. Die WINS-Einträge der Clients zeigen alle auf den neuen Server.

 

Ich habe ein wenig gepfuscht, muss ich zugeben, denn ich habe die Rechner nicht aus der alten Domäne (d. h. aus den Listen des Servers) entfernt, sondern sie nur der neuen angeschlossen. Das habe ich gerade gemacht, und es riecht nach Besserung der Situation. Falls es das war: ASCHE AUF MEIN HAUPT! Tut mir leid, hier alle so beschäftigt zu haben. Falls es das nicht war, frage ich demnächst weiter :)

 

Vielen Dank nochmal an alle,

bis denne,

 

Anax

Share this post


Link to post

Ich bin's nochmal! Also, die Server-Problematik habe ich jetzt anscheinend im Griff; manche Netzwerk-Probleme muss man wohl einfach aussitzen ... So wie ich es sehe, war ein einzelner Arbeitsplatzrechner schuld, der noch versuchte, per DNS auf den alten Server zuzugreifen. Der broadcastete dann anscheinend die Adresse über das NetBIOS-Netzwerk, und die anderen Computer zogen dann irgendwie nach ... wie dem auch sei, nun läuft alles.

 

Trotzdem, mal was anderes: Warum greifen eigentlich die Computer bei jeder popligen Dateioperation (öffnen, Eigenschaften anzeigen, etc.) über NetBIOS auf das Netzwerk zu? Was hat das für einen Sinn, und kann man das ggf. abstellen? Schaltet man das Netzwerk ab, laufen die Rechner schließlich immer noch!

 

Nochmal, vielen Dank für die klasse Unterstützung hier,

bis denne,

 

Anax.

Share this post


Link to post

Hi Anax,

das hat nur bedingt was mit Netbios zu tun.

In den meisten Fällen (z.B.MS-Anwendungen) wird der Speicherort einer Datei im UNC-Pfad abgespeichert, also \\Servername\Freigabename\Dateiname

Selbst bei Dateien, die lokal auf dem betreffenden PC liegen, ist das so.

Das Problem ist die Namensauflösung von \\Servername.

Da gibt es halt bestimmte Regeln, in welcher Reihenfolge dieser Name aufgelöst wird. Je nachdem, wieviele Möglichkeiten der Namensauflösung es gibt (= Anzahl der installierten NW-Client), dauert das dann. Wenn Du Pech hast, steht die Prüfung, ob der lokale PC eventuell der \\Servername ist, ziemlich weit hinten, weil andere NW-Clients sich vordrängeln - bildhaft gesprochen.

Mit Netbios kommt eine weitere Möglichkeit der Namensauflösung dazu.

Deshalb gilt generell, nur soviele Protokolle wie nötig, installieren.

Das gleiche trifft dann sinngemäß auch auf die NW-Clients zu.

Share this post


Link to post

Hi zuschauer!

 

Yo, alles klar - also eher eine Sache zum Mit-Abfinden als eine Sache, die man lösen kann. Es ist auszuhalten - meist pendelt die Verzögerung durch den Netzwerkzugriff so um 0.5 bis 1 sec., ist also auszuhalten. An Protokollen und Clients gibt's nicht viel abzuschalten: Wir haben den Microsoft-Netzwerk-Client, die Datei-Freigabe, und das TCP/IP-Protokoll mit aufgesetztem NetBIOS.

 

Vielen Dank für Deine Erklärung - wenigstens weiß ich jetzt, worüber ich mich ärgere ;-)

 

Viele Grüße,

Anax

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...