Jump to content
Sign in to follow this  
Volker Racho

Trotz Automatik: Kein Runterladen von Updates

Recommended Posts

Hallo WSUS-Experten!

 

Ich habe einen WSUS nach der Installationsanleitung auf WSUS-Praxis aufgesetzt und auch die GPO, angepasst an die Umgebung, so erstellt, wie dort vorgegeben, u.a. mit der Installationsoption-Option 4, wonach die Updates runtergeladen und installiert werden. Mit gpupdate /force habe ich diese GPO zur schnellen Anwendung gebracht. Sie ist auch, wie angelegt, auf dem Client angekommen. Ich habe die Nachguckfrequenz allerdings auf 1 Stunde minimiert. Der Installationszeitpunkt 12.00 Uhr, aber die sofortige Installation nach dem Download ist angehakt.

 

Dennoch lädt der Rechner unter einem eingeschränkten Benutzer die freigegebenen Updates nicht. Ich habe nur eines genommen, damit ich sehe, ob es funktioniert. Als Admin bekomme ich die Meldung das Updates da sind, muss sie aber auch manuell anstoßen.

Mit wuauclt.exe /detectnow sucht der Client zwar, lädt auch die Updates runter, installiert sie aber scheinbar nicht, s. WindowsUpdate.log

 

AutomaticUpdates	Success	Content Install	Installation Ready: The following updates are downloaded and ready for installation. This computer is currently scheduled to install these updates on Dienstag, 26. Februar 2008 at 12:00:  - Microsoft Office 2003 Service Pack 3 (SP3) - Kumulatives Sicherheitsupdate für Internet Explorer 7 unter Windows XP (KB942615)
2008-02-26	09:53:37:728	 840	684	Report	REPORT EVENT: {24AB3842-7858-42BC-8687-3F2C60F5B584}	2008-02-26 09:53:32:731+0100	1	162	101	{E2BD7F45-47F9-402F-8FDA-14F78030FE70}	101	0	AutomaticUpdates	Success	Content Download	Download succeeded.
2008-02-26	09:53:48:424	 840	684	Report	Uploading 3 events using cached cookie, reporting URL = http://s-wsus/ReportingWebService/ReportingWebService.asmx
2008-02-26	09:53:48:474	 840	684	Report	Reporter successfully uploaded 3 events.

 

Ist daran die Einstellung der täglichen "Installation um 12.00 Uhr" in Diskrepanz mit "sofort nach Download installieren" Schuld?

 

Gruß,

MD

Share this post


Link to post
Share on other sites

hmm komisch, aber als admin siehst du die updates zwar musst sie aber nicht umbedingt anwählen, sie werden automatisch nach dem zeitintervall installiert. bei mir funktioniert das richtig gut...! also ich glaube das der user die updates gar nicht sehen darf. installiert werden müssten sie aber trotzdem...! also ich habe folgende einstellungen gemacht

 

automatische updates konfigurieren 4

geplatner installationstag 0 - Täglich

geplante installationszeit 12:00

interner updatedienst http://server

wartezeit nach systemstart 20min

 

und bei mir funktionierts, jetzt weiss ich halt nicht wie es sich mit dieser option sofort nach download auswirkt...

Share this post


Link to post
Share on other sites

Pah, es hat doch noch geklappt.

Ich habe das GPO noch einmal neu erstellt und zugewiesen. Warum es allerdings erst einmal nicht gelappt hat, weiß ich nicht, aber auch die Zuteilung des SP3 für Office 2003 hat geklappt.

 

Wo soll ich den Eintrag HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate

ElevateNonAdmins auf 1 setzen und was bewirkt dieser?

 

Ist es sinnvoll per Script die Befehlszeile wuauclt.exe /detectnow mit in das GPO für das WindowsUpdate einzufügen, damit bei Übernahme der Gruppenrichtlinie gleich mal anch Updates gesucht wird?

 

 

Beste Grüße,

MD

Share this post


Link to post
Share on other sites

Dennoch lädt der Rechner unter einem eingeschränkten Benutzer die freigegebenen Updates nicht. Ich habe nur eines genommen, damit ich sehe, ob es funktioniert. Als Admin bekomme ich die Meldung das Updates da sind, muss sie aber auch manuell anstoßen.

 

Ja, das ist klar. Du hast vermutlich auch eine Benutzereinstellung aktiviert: Zugriff auf alle WindowsUpdate Funktionen entfernen. Und diese Richtlinie auch nur auf die OU mit den Benutzern verlinkt. Der angemeldete Admin ist vermutlich der Domain Admin, und der bekommt diese Richtlinie nicht mit, und das ist auch gut so.

 

Mit wuauclt.exe /detectnow sucht der Client zwar, lädt auch die Updates runter, installiert sie aber scheinbar nicht, s. WindowsUpdate.log

 

Du hast eine Installationszeit angegeben, um genau diese Uhrzeit werden die Updates installiert. Schau mal ins Eventlog von dem Client, dort findest Du die passenden Einträge.

 

Ist daran die Einstellung der täglichen "Installation um 12.00 Uhr" in Diskrepanz mit "sofort nach Download installieren" Schuld?

 

Du meinst vermutlich, diese Einstellung hier: Automatische Updates sofort installieren.

Diese Einstellung hat aber mit der Installationszeit um 12.00 Uhr nichts zu tun. Lies dir mal das Explain zu der Richtlinie durch.

 

Heute um 12.00 Uhr werden die Updates installiert. Wenn nicht, schau ins Eventlog auf dem Client und in die WindowsUpdate.log auf dem Client.

Share this post


Link to post
Share on other sites
Pah, es hat doch noch geklappt.

Ich habe das GPO noch einmal neu erstellt und zugewiesen. Warum es allerdings erst einmal nicht gelappt hat, weiß ich nicht, aber auch die Zuteilung des SP3 für Office 2003 hat geklappt.

 

Welche Option hast Du jetzt auswgewählt? Immer noch die 4? Wenn ja, dann sollte erst um 12.00 Uhr installiert werden.

 

Wo soll ich den Eintrag HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate

ElevateNonAdmins auf 1 setzen und was bewirkt dieser?

 

In der GPO: Nicht Administratoren gestatten, Updatebenachrichtigungen zu erhalten. Diese Einstellung ist aber nicht zu empfehlen, welcher User schaut schon in den Systray, ob da dieses kleine Updatesymbol vorhanden ist. Und wenn er es sieht, muß er es anklicken und die Installation durchführen. Einfach nichts einstellen.

 

Ist es sinnvoll per Script die Befehlszeile wuauclt.exe /detectnow mit in das GPO für das WindowsUpdate einzufügen, damit bei Übernahme der Gruppenrichtlinie gleich mal anch Updates gesucht wird?

 

Nein, das macht der WU-Agent auf dem Client schon alleine. Du solltest auch die Zeit von 1 Stunde wieder auf den Default einstellen. Jeder Client sieht mind. 1 x am Tag nach ob neue Updates vorliegen oder nicht. Und das natürlich auch beim ersten starten am Morgen.

Share this post


Link to post
Share on other sites

Hallo Sunny!

 

Ich hatte die Zeit nur schon mal auf 11 Uhr vorverlegt, weil ich nicht so lange warten wollte. :)

 

Das Intervall wollte ich wieder auf 22 Stunden ausdehnen. Ich wollte auch hier nur sicher gehen, ob es für meinen Rechner (VM) hier funktioniert.

 

Die Benachrichtigungs- und Installationsoption wollte ich sowieso nicht den Usern überlassen. Die wissen z.T. leider kaum, wie ihr Passwort nochmal war. Es war der DomainAdmin, ja. Admins sollen auch benachrichtigt werden, User nicht. genauso tut's nun auch.

 

Die Erklärungen finde ich z.T. etwas verwirrend: "Wählen Sie akktivieren, wenn sie nicht wollen, dass diese Richtlinie nicht angewendet wird." usw.

 

Alle freigegebenen Updates wurden installiert und eingespielt. Ich bin somit zufrieden und mein "Problem" ist gelöst.

 

 

Danke für Eure ausführliche, geduldige Hilfe.

MD

Share this post


Link to post
Share on other sites

Ich hatte die Zeit nur schon mal auf 11 Uhr vorverlegt, weil ich nicht so lange warten wollte. :)

 

OK, dann ist ja alles klar. ;)

 

Das Intervall wollte ich wieder auf 22 Stunden ausdehnen. Ich wollte auch hier nur sicher gehen, ob es für meinen Rechner (VM) hier funktioniert.

 

Warum soll es nicht funktionieren? ;)

 

Die Benachrichtigungs- und Installationsoption wollte ich sowieso nicht den Usern überlassen. Die wissen z.T. leider kaum, wie ihr Passwort nochmal war. Es war der DomainAdmin, ja. Admins sollen auch benachrichtigt werden, User nicht. genauso tut's nun auch.

 

Sehr gut.

 

 

Die Erklärungen finde ich z.T. etwas verwirrend: "Wählen Sie akktivieren, wenn sie nicht wollen, dass diese Richtlinie nicht angewendet wird." usw.

 

Das ist ja noch harmlos, warte bis Du auf eine doppelte Verneinung stösst. ;)

 

Alle freigegebenen Updates wurden installiert und eingespielt. Ich bin somit zufrieden und mein "Problem" ist gelöst.

 

Welches Problem? ;) Deine Ungeduld? ;)

 

Danke für Eure ausführliche, geduldige Hilfe.

MD

 

Bitte, gern geschehen und Danke für die Rückmeldung. ;)

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...