Jump to content
Sign in to follow this  
julian86

VPN-Verbindung raubt mir den allerletzten Nerv...

Recommended Posts

Hallo Leute!

Hoffe Ihr könnt mir weiterhelfen. Ich bin jetzt echt am Ende....

 

Seit Freitag früh versuche ich eine VPN-Verbindung laut der Anleitung von WinTotal unter WinTotal - Artikel - VPN mit Windows XP einzurichten. Bin auch genau danach vorgegangen und habe an meinem Server(1) wie auch an meinem Client(2) alle Einstellungen vorgenommen (und bereits mehrmals kontrolliert - da passt alles).

Ich verwende zwar statt dynDNS einen anderen Anbieter, aber das sollte ja keinen Unterschied machen.

 

Da sich der Client momentan noch innerhalb meines LANs befindet konnte ich testen, mittels der LAN-IP eine VPN-Verbindung aufzubauen. Das klappt einwandfrei!!!

Von außerhalb jedoch kommt stets die Fehlermeldung 678 Der Remotecomputer antwortet nicht.

 

Am Router(3) ist der PPTP-Port 1723 weitergeleitet zum Server. Mehr muss ich da laut der Anleitung und auch laut einem MediaMarkt-Menschen nicht machen.

Im Internet wird immer noch vom GRE-Protokoll geredet. Das wird aber für PPTP eben NICHT benötigt (Sagt der Mensch vom MediaMarkt)

 

Aber nun endlich mal zu meinen Rechnern:

 

(1) Der Server:

Windows 2000 Professional

192.168.2.77

DynDNS über Anbieter no-ip.com

 

(2) Der Client:

Windows XP Home

192.168.2.7 (bzw. wenn außerhalb: 192.168.0.7)

 

(3) Der Router:

D-Link DIR 100

192.168.2.1

PPTP Passthrough wird unterstützt

Port 1723 TCP auf 192.168.2.77 weitergeleitet

 

Habe auch schon versucht den Server als DMZ Host einzusetzen - leider ohne Erfolg, selbes Ergebnis.

 

Auf beiden Rechnern ist Norton Internet Security installiert, aber korrekt eingerichtet. Auch wenn ich die Firewalls deaktivieren funzt es nicht. Immer wieder Fehler 678.

 

Bin echt am Verzweifeln!!!!

Hoffe ihr könnt mir helfen. Bin echt über jeden noch so kleinen Hinweis dankbar!

 

 

Vielen Dank und schon mal liebe Grüße an alle!

 

Julian

Share this post


Link to post
Share on other sites
.

 

Am Router(3) ist der PPTP-Port 1723 weitergeleitet zum Server. Mehr muss ich da laut der Anleitung und auch laut einem MediaMarkt-Menschen nicht machen.

Im Internet wird immer noch vom GRE-Protokoll geredet. Das wird aber für PPTP eben NICHT benötigt (Sagt der Mensch vom MediaMarkt)

Sicher wird GRE benötigt (wird normalerweise durch PPTP-Passthrough ermöglicht), ist also Quatsch. Wenn es intern funktioniert, wird das Problem nicht am "Server", sondern eher am Router liegen, möglicherweise auch an der Firewall auf den Rechnern. Poste bitte als erstes mal IPCONFIG /ALL der beiden beteiligten Maschinen. Ist die Firmware des Routers aktuell ? Was sprichst Du von aussen ? Der "Server" ist fest auf 192.168.2.77 eingestellt ? Du hast Port 1723 nach innen geleitet, TCP oder UDP ?

Share this post


Link to post
Share on other sites

Hallo julian86 und herzlich Willkommen,

 

Off-Topic:

 

Sagt der Mensch vom MediaMarkt. :jau:

Die sagen doch auch ich bin doch nicht **** und zocken dich dann ab

 

Hast du die Möglichkeit den XP Rechner mittels ISDN Karte oder Modem ins Internet zu bringen ?

Share this post


Link to post
Share on other sites
Sicher wird GRE benötigt (wird normalerweise durch PPTP-Passthrough ermöglicht), ist also Quatsch. Wenn es intern funktioniert, wird das Problem nicht am "Server", sondern eher am Router liegen, möglicherweise auch an der Firewall auf den Rechnern. Poste bitte als erstes mal IPCONFIG /ALL der beiden beteiligten Maschinen. Ist die Firmware des Routers aktuell ? Was sprichst Du von aussen ? Der "Server" ist fest auf 192.168.2.77 eingestellt ? Du hast Port 1723 nach innen geleitet, TCP oder UDP ?

 

Hey.....danke für die schnelle Antwort!

 

Naja dann hoffe ich mal, dass es trotzdem nicht am Router liegt. Dort habe ich nämlich auch nichts bezüglich GRE gefunden. Aber den Hinweis auf der Verpackung dass er wohl PPTP Passthrough unterstützt....

 

Ich hab den Port 1723 auf den Server weitergeleitet. Mit "von außen" meinte ich von außerhalb des lokalen Netzwerkes. Also so wies später auch sein soll - eben über das Internet.

 

Alle Rechner haben Ihre feste IP. DHCP habe ich deaktiviert.

 

Hier die gewünschten Einstellungen

 

1. vom Server

 

Windows 2000-IP-Konfiguration

 

Hostname. . . . . . . . . . . . . : apollo13

Prim„res DNS-Suffix . . . . . . . :

Knotentyp . . . . . . . . . . . . : Hybridadapter

IP-Routing aktiviert. . . . . . . : Ja

WINS-Proxy aktiviert. . . . . . . : Nein

 

Ethernetadapter "LAN-Verbindung":

 

Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : SiS 900-Based PCI Fast Ethernet Adapter

Physikalische Adresse . . . . . . : 00-0B-6A-D7-34-D8

DHCP-aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.2.77

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

Standardgateway . . . . . . . . . : 192.168.2.1

DNS-Server. . . . . . . . . . . . : 192.168.2.1

Prim„rer WINS-Server. . . . . . . : 192.168.0.1

 

und 2. vom Client

 

 

 

Windows-IP-Konfiguration

 

 

 

Hostname. . . . . . . . . . . . . : jutho

 

Primäres DNS-Suffix . . . . . . . :

 

Knotentyp . . . . . . . . . . . . : Unbekannt

 

IP-Routing aktiviert. . . . . . . : Nein

 

WINS-Proxy aktiviert. . . . . . . : Nein

 

 

 

Ethernetadapter Drahtlose Netzwerkverbindung:

 

 

 

Verbindungsspezifisches DNS-Suffix:

 

Beschreibung. . . . . . . . . . . : Atheros AR5006EG Wireless Network Adapter

 

Physikalische Adresse . . . . . . : 00-C0-A8-CC-80-E6

 

DHCP aktiviert. . . . . . . . . . : Nein

 

IP-Adresse. . . . . . . . . . . . : 192.168.2.7

 

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

 

Standardgateway . . . . . . . . . : 192.168.2.1

 

DNS-Server. . . . . . . . . . . . : 192.168.2.1

Share this post


Link to post
Share on other sites
Hallo julian86 und herzlich Willkommen,

 

Off-Topic:

 

Sagt der Mensch vom MediaMarkt. :jau:

Die sagen doch auch ich bin doch nicht **** und zocken dich dann ab

 

Hast du die Möglichkeit den XP Rechner mittels ISDN Karte oder Modem ins Internet zu bringen ?

 

Könnte es probieren....aber warum das? :confused:

Share this post


Link to post
Share on other sites

hallo julian,

 

schau dir mal die wiki-seite von pptp an. gre wird definitiv benötigt, wie auch schon weiter oben beschrieben. wenn nur der port forgewarded wird, dann bekommt du zwar einen connect, jedoch bei der authentifizierung wirst du eine fehlermeldung bekommen.

 

auch möchte ich dir anraten, den mediamarktburschen nicht wirklich alles zu glauben (es mag zwar ausnahmen geben, aber der rest - naja). ;-)

 

vorab würde ich dir mal raten, die firmware zu aktualisieren, falls noch nicht erledigt...

 

mfg

hannes

Share this post


Link to post
Share on other sites

naja ok...überredet ;-)

 

Aber was heißt das jetzt für mich?

Kann an meinem Router nichts von wegen GRE einstellen. Kann es trotzdem funktionieren?

 

Dann mach ich jetzt erst mal ein Firmwareupgrade. Wenn das klappt melde ich mich dann später wieder. (Hoffe es geht nichts schief...... hab mit sowas schon mal schlechte erfahreungen gemacht...)

Share this post


Link to post
Share on other sites

Hallo Julian,

 

du gehst mit dem Anschluß ins Internet welchen du gleichzeitig von extern ansprechen

willst. Das beherrschen die meisten Router nicht. Daher meine Frage bezgl Modem / ISDN.

 

Damit hätte der Client einen getrennten Zugang und du könntest es realistisch testen.

Wenn du also am Client die Möglichkeit hast nutze diese zum testen für den VPN.

 

Zum Router kann ich dir nichts sagen weil mir nicht bekannt. Wenn dieser aber Passtrought

unterstützt sollte mit dem Forward des 1723 auch das GRE Protokoll passen, ausser er

hat eine extra Einstellung für den Passtrought im Menu.

Share this post


Link to post
Share on other sites

ich kann dir da leider nicht konkret weiterhelfen - ich habe keine d-links im einsatz (mit denen hab ich schlechte erfahrung gemacht). du könntest aber auch den d-link support bemühen...

 

mfg

hannes

Share this post


Link to post
Share on other sites

So....

Firmwareupgrade is durch. Habs Gott sei Dank geschafft.

Allerdings hat es leider rein gar nichts an meinem Problem verändert :-(

 

@ XP-Fan

Habe das Einwählen von "Aussen" schon probiert, in dem ich bei nem Kumpel mich ins Netz geklingt hab und von dort versucht hab, mein Netz bzw. meinen Server anzuwählen...völlig erfolglos leider: Fehler 678.

 

Noch mal zum Router:

Ich habe ausschließlich den Port 1723 auf den Server weitergeleitet. Weiter habe ich NICHTS gemacht. Eine Funktion GRE weiterzuleiten gibt es nicht. Eine Funktion Passthrough zu aktivieren/deaktivieren kann ich auch nicht finden.

Ist das normal?

Share this post


Link to post
Share on other sites

Warum ist der Client eigentlich im IP-Bereich des Servers, ist er momentan intern ? Warum ist ein WINS-Server im 192.168.0.0 Netz eingetragen ?

Laut Anleitung (aus dem Internet geladen) auf Seite 31 soll es eine Checkbox für PPTP und L2TP Passthrough geben, was ich auf dem gezeigten Bild allerdings auch nicht gesehen habe. Hast Du auf dem Router Firewall-Regeln erstellt ?

Share this post


Link to post
Share on other sites
Warum ist der Client eigentlich im IP-Bereich des Servers, ist er momentan intern ? Warum ist ein WINS-Server im 192.168.0.0 Netz eingetragen ?

Laut Anleitung (aus dem Internet geladen) auf Seite 31 soll es eine Checkbox für PPTP und L2TP Passthrough geben, was ich auf dem gezeigten Bild allerdings auch nicht gesehen habe. Hast Du auf dem Router Firewall-Regeln erstellt ?

 

Der Client ist momentan ist momentan noch intern, ja. Funktioniert aber von außerhalb auch nicht, einen VPN Tunnel aufzubaun...

Wenn er außerhalb ist, sind die Einstellungen aber ähnlich. Der einzige Unterschied ist das Subnetz.

Wenn außerhalb:

IP: 192.168.1.7

Gateway: 192.168.1.1

 

 

Die Sache mit dem WINS-Server hat mich vorhin auch ein wenig irritiert.... Keine Ahnung warum der da drin stand. Hab ihn jedenfall rausgelöscht. Der hat da ja gar nix verloren.

 

 

Die Bedienungsanleitung hab ich auch.....aber da steht bei mir nichts von der Checkbox (mal ganz davon abgesehen, dass die auch nicht existiert...)

Hast du auch die richtige Anleitung? DLINK DIR-100?

Share this post


Link to post
Share on other sites
Hier habe ich es gelesen, der Button ist aber auch auf dem Bild nicht zu sehen ...

ftp://ftp.dlink.de/dir/dir-100/documentation/DIR-100_reva_man_en_Manual.pdf

 

Das ist ja mal echt lustig.... In der deutschen Übersetung (die hab nämlich ich) steht da gar nichts davon.... naja jedenfalls gibts diese Funktionen PPTP und das alles zu aktivieren oder deaktivieren nicht....

was nun????

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...