Jump to content

Crashbreaker

Members
  • Content Count

    141
  • Joined

  • Last visited

Community Reputation

10 Neutral

About Crashbreaker

  • Rank
    Newbie

Recent Profile Visitors

448 profile views
  1. Also ich habe sämtliche Parameter eingebaut die hier im Forum vorgeschlagen wurden. Nichts hat zur Besserung beigeholten. Resultat ist bis aufs Byte größe gleich geblieben. Habe das gesamte Verzeichnis komplett gelöscht und wieder komplett mehrfach schon Neu kopiert aber nichts hat geholfen. Im Punkt 2: Wo genau im Screenshot siehst du die fehlenden Verzeichnisse? Bin ich etwa blind vor frustration? Wäre dir dankbar, wenn du mir das Zeigen könntest. Mein bisherige befehl sieht folgendermaßen aus: ... robocopy %sourceDir% "%targetDir%\\" /R:3 /W:2 /MIR /COPYALL /ZB /V /XD "System Volume Information" "$RECYCLE.BIN" RECOVER RECYCLER $Recycle.Bin /log:%logDir% attrib -h -s -r /S /d %targetDir% .... Komme damit aber nicht zum Ziel. Den Schalter habe ich reichlich analysiert. Jedoch weiß ich nicht mehr was ich daraus noch entnehmen kann, was ich ja eh schon ausgiebig - meiner Meinung nach - im oberen Code entnommen habe. Der Resultat des Schalters /V sieht so aus: ------------------------------------------------------------------------------ Insgesamt KopiertÜbersprungenKeine Übereinstimmung FEHLER Extras Verzeich.: 9697 0 9697 0 0 0 Dateien: 100062 0 100062 0 0 0 Bytes: 225.565 g 0 225.565 g 0 0 0 Zeiten: 0:01:31 0:00:00 0:00:00 0:01:31 Beendet: Mittwoch, 19. Juni 2019 12:44:19
  2. Hey danke für den Tipp. Werde es nachher mal testen. Mit dem Schalter /V dürfte ich, dann sehen was nicht kopiert wurde ...
  3. Zu Punkt 1: ehm, vielleicht habe ich es übersprungen zu schreiben aber genau das tue ich bereits. Lasse den gesamten Log in eine "txt" Datei schreiben. Nur wie gesagt, müsste tausende Zeilen dann entsprechend einzeln händisch vergleichen, womit ich dann wahrscheinlich in 10 Jahren fertig wäre. Zu Punkt 2: Werde ich nochmal das durchgehen. Zu Punkt 3: Hm, da könntest du recht haben, dass ich nicht auf alles direkten Zugriff habe ... Werde detailliert das Ganze im Admin Account überprüfen. Melde mich dann gleich nochmal ...
  4. Danke für den Hinweis, jedoch lese ich mich in der Hilfe ein. Finde aber nicht so das passende ... Ja führe das ganze mit einem Admin Account durch aber statt Shell, teste ich es in der administrativen CMD aus. Gibt es zwischen den beiden bzgl. Robocopy Unterschiede? Den Flag /ZB werde ich mir gleich anschauen. Danke für den Hinweis.
  5. TreeSize habe ich ausprobiert. Im TreeSize sehe ich das der Verzeichnis "recoverit" sich um 100 MB unterscheiden. Sonst sehe ich, da keinen Unterschied im Gegensatz zu dem was von Windows kommt (rechts in der Abbildung). Nein markiere alle Verzeichnisse mit Strg+A (die Systemdateien etc. sind ausselektiert) ... Gute Idee, werde ich mal ausprobieren. Hoffe, ich bekomme es hin. Der Log-Ausgabe hat Folgendes ausgegeben: ------------------------------------------------------------------------------ Insgesamt KopiertÜbersprungenKeine Übereinstimmung FEHLER Extras Verzeich.: 1 0 1 0 0 0 Dateien: 0 0 0 0 0 0 Bytes: 0 0 0 0 0 0 Zeiten: 0:00:00 0:00:00 0:00:00 0:00:00 Beendet: Mittwoch, 19. Juni 2019 10:20:11 Hier sehe ich, das 1 Verzeichnis übersprungen wurde. Jedoch wie kann man rausfinden, welches Verzeichnis übersprungen wurde?
  6. Hallo Weingeist, ich weiß, dass du mir versucht hast zu helfen und es ja weiterhin noch tust. Dafür danke ich dir wirklich vom Herzen. Bin auch froh darüber. Es tut mir leid, dass ich auf deine Frage mit gegen Frage so wie oben zitiert ankam. Als deine Frage so allgemein kam und ich mit der Sache hier sehr frustriert war, konnte ich dich auf das Problem bezogen nicht ganz nachvollziehen. Aber deine jetztige Erklärung bzgl. meinem falschen interpretation habe ich dich sehr gut verstanden. Dann macht es mit dem Flag setzen überhaupt keinen Sinn und da hast du recht. Den Befehl habe ich auch aus der Hilfe und nach Google habe ich es anscheinend falsch verstanden bzw. falsch interpretiert. Denn ich bin davon ausgegangen, dass nicht der Explorer, sondern das gesamte Windowssystem auf 256 Zeichen beschränkt sei und ich mit dem Befehl das dadurch erweitern könnte. Ich denke, dass in der Hilfsbeschreibung hier keine ausführliche Dokumentation vorliegt. Ich habe die Systemordner und Papierkorbordner mit "/XD ..." ausselektiert, daran dürfte es nicht liegen. Ich habe vorhin nochmal robocopy gestartet und so sieht der Log aus: ------------------------------------------------------------------------------ Insgesamt KopiertÜbersprungenKeine Übereinstimmung FEHLER Extras Verzeich.: 9697 0 9697 0 0 0 Dateien: 100062 0 100062 0 0 0 Bytes: 225.565 g 0 225.565 g 0 0 0 Zeiten: 0:00:31 0:00:00 0:00:00 0:00:31 Beendet: Mittwoch, 19. Juni 2019 09:11:01 Wenn man dies mit dem Image den ich in die Anlage bei gefügt habe vergleicht, dann sind da gravierende Unterschiede zu sehen. Danke für die Information. Werde ich gleich mal ausprobieren.
  7. Danke für den Hinweis. Werde den Flag dann entsprechend rausnehmen.
  8. Erstmal danke ich für die Antwort. Ich verstehe ebenfalls nicht, warum man mehrere Versuche hier miteinander vermischt?! Versuch A hat mit versuch B nichts zu tun. Da die Versuche nicht das gewünschte Resultate bringen konnten, habe ich verschiedene Kopierversuche durchgeführt. Einer der Versuche war auch mit Robocopy. Die andere war z.B. mit Total-Commander 2 Verzeichnisse miteinander vergleichen und beides dann entsprechend synchronisiert. Ich habe auch mit WinMerge gearbeitet, was auch ein weiterer versuch war. Nichts davon haben mir geholfen. Den Flag "/256" habe ich daher gesetzt, weil Windows/Microsoft im 21. Jahrhundert immer noch nicht begriffen hat, dass Pfade auch mehr als 256 Zeichen haben können. Es sollte quasi, da wo mehr als 256 Zeichen in den Pfaden sind, Dateien auch kopiert werden. Daher habe ich diesen Flag setzen müssen. Also soll es quasi mehr als 256 Zeichen unterstützen. Ich habe diesen Flag so verstanden, wenn man diesen Flag setzt, dann unterstützt es bis zu 32.000 Zeichen, was vollkommen ausreicht. Setzt man diesen Flag nicht, dann verhält Robocopy sich ganz normal nach Windowsregeln die leider bis 256 Zeichen beschränkt sind. Habe ich da etwas falsch interpretiert? Falls ja bitte ich euch mich dringend zu korrigieren. Wie soll man in den Subordnern die Anzahl Dateien überprüfen können? Hier sind es laut über 100.000 Dateien und knapp 10.000 Ordnern?! Da wäre ich in 10 Jahren noch dran. Wenn es paar Ordner wären, hätte ich all diesen Aufwand gar nicht getrieben.
  9. Hallo nochmals, also ich habe das Freeware Tool heruntergeladen und installiert. Danach Backup durchgeführt und im Anschluss auf Zielpfad Restore gemacht aber leider fehlen mir immer noch wie oben 20 GB an Daten. Wieso passieren mir so merkwürdige Dinge, verstehe ich gar nicht. Gibt es noch etwas anderes an Möglichkeiten? 20 GB ist auch nicht wenig, wenn es paar MB wären, hätte ich auch darauf verzichtet. Kann es denn sein, dass Windows hier die Berechnung falsch oder anders handhabt? Schließlich sind es andere Platten und wahrscheinlich auch andere Sektorgrößen. Müsste ich mal nach schauen. Ich kann mir eigentlich nichts erklären ... Habe ich da etwas falsch gemacht? Würde mich freuen, wenn du mich aufklären könntest. MfG Daniel
  10. Oh du bist Klever ... Nicht schlecht die Idee. Jedoch Veeam ist nicht kostenlos. Zwar kann man sie für 30 Tage Testen aber da muss man sich dann für registrieren was bei mir nicht infrage kommt. Solche Methoden was die anbieten, um Daten zu klauen, finde ich absolute scheiße und hinzukommt, dass es total lästig ist. Deren Marketing Abteilung sollte man mal ansc***en. Gibt es eine andere Programm die das Gleiche anbietet?
  11. Toll, befehle die er anscheinend nicht richtig ausführt. Weiß gar nicht was ich noch ausprobieren soll, um 2 Pfade identisch zu halten.
  12. Winmerge habe so eben auch getestet nach dem ich es heruntergeladen habe. War auch eine gute Idee, jedoch hat dies auch nichts gebracht. Der hat jede Datei einzeln geprüft, ob die beiden Pfade identisch sind. Laut der Angabe des Programms sind die beiden Pfade identisch. Aber wenn ich in den Eigenschaften nach schaue, fehlen mir da 20 GB an Daten. Symlinks sind dort keine. Habe ich trotzdem danach geprüft und keins festgestellt. Ich bekomme nen Föhn ... Wieso macht Windows so eine Scheiße ...?!
  13. Hallo Leute, leider habe ich mit Robocopy kein Erfolg gehabt. Das Resultat ist Haar genau wie davor auch. Habe verschiedene Variationen mit Robocopy ausprobiert. Das letzte habe ich so ausgeführt: "robocopy %sourceDir% %targetDir% /R:3 /W:5 /MIR /COPYALL /256 " Resultat ist so: ------------------------------------------------------------------------------ Insgesamt KopiertÜbersprungenKeine Übereinstimmung FEHLER Extras Verzeich.: 9699 0 9699 0 0 0 Dateien: 100075 0 100075 0 0 0 Bytes: 225.586 g 0 225.586 g 0 0 0 Zeiten: 0:00:23 0:00:00 0:00:00 0:00:23 Beendet: Sonntag, 16. Juni 2019 17:17:57 Welche Möglichkeiten gibt es noch? Kann mir jemand helfen? MfG Daniel
  14. Die Festplatten werde ich noch in Anspruch nehmen. Bin noch mit der Sicherung meiner Daten zugange. Wegen der Arbeit komme ich nicht ganz so dahinter. Daher dauert es etwas noch. Robocopy ist eine gute Idee. Werde das mal damit angehen.
  15. Hallo Leute, irgendwie funktioniert das Kopieren nicht so, wie ich es mir vorstelle und hoffe auf eine Erklärung. Nachdem ich erfolgreich 3 Verzeichnisse von A nach B kopiert habe, sind die Inhalte nicht identisch gleich groß. Hierzu habe ich in die Anlage ein Bild eingefügt, wo es eindeutig zu sehen ist. Kann mir jemand erklären, warum mehr als 20.000 Dateien, ca. 20 GB an Daten im Zielpfad fehlen? Habe jegliche Art von Kopierfunktionen im Windows getestet. Selbst mit Total-Commander Programm komme ich auf das gleiche Resultat zurück. Bin etwas Ratlos und hoffe, dass ihr mir hier eine Lösung geben könntet, wo ich wirklich zu 100 % ig alles kopieren kann. Bedanke mich im Voraus. MfG Daniel
×
×
  • Create New...