Zum Inhalt wechseln


Foto

Server 2016 bringt Fehler 0x8024500c bei WSUS

WSUS

  • Bitte melde dich an um zu Antworten
9 Antworten in diesem Thema

#1 Cirederf

Cirederf

    Newbie

  • 3 Beiträge

 

Geschrieben 06. Mai 2017 - 14:22

Hallo Zusammen,

 

meine Umgebung:

Neu installierte Server 2016

Neu installierter 2016er WSUS auf Server 2016

Der WSUS darf ins Internet und zieht sich ohne murren seine Updates.

 

mein Problem:

meine Clients 7, 8 und 10 holen sich Updates vom WSUS

meine 2008er und 2012er Server auch

meine neuen 2016er Server streiken.

 

 

Inzwischen sind auf meiner Testmaschine folgende Updates installiert:

KB4015217

KB4013418

KB3199986

Die anderen Kumulativen Updates, die empfohlen werden, finde ich entweder nicht im Update Katalog oder gehen nicht.

 

Es wird nur eine Einzige GPO auf den Server angewendet:

Nicht im Internet nach Updates suchen.

Windows Update Location

Client Side Targeting

do not include drivers

 

 

Hier noch WindowsUpdate Log:

2017.04.28 14:44:32.3531835 936   348   ComApi          Unable to get SLS chunk. (hr=8024500C)
2017.04.28 14:50:11.6019563 3976  1676  ComApi          * START *   Init Search ClientId = TrustedInstaller FOD
2017.04.28 14:50:11.6019588 3976  1676  ComApi          * START *   Search ClientId = TrustedInstaller FOD
2017.04.28 14:50:11.6108698 1056  2496  Agent           * START * Queueing Finding updates [CallerId = TrustedInstaller FOD  Id = 14]
2017.04.28 14:50:11.6108753 1056  2496  Agent           Removing service 00000000-0000-0000-0000-000000000000 from sequential scan list
2017.04.28 14:50:11.6108779 1056  2496  Agent           Added service 00000000-0000-0000-0000-000000000000 to sequential scan list
2017.04.28 14:50:11.6110033 3976  1676  ComApi          Search ClientId = TrustedInstaller FOD
2017.04.28 14:50:11.6146166 1056  4916  Agent           * END * Queueing Finding updates [CallerId = TrustedInstaller FOD  Id = 14]
2017.04.28 14:50:11.6181545 1056  4916  Agent           * START * Finding updates CallerId = TrustedInstaller FOD  Id = 14
2017.04.28 14:50:11.6181552 1056  4916  Agent           Online = Yes; AllowCachedResults = No; Ignore download priority = No
2017.04.28 14:50:11.6181556 1056  4916  Agent           Criteria = CategoryIDs contains 'e104dd76-2895-41c4-9eb5-c483a61e9427'""
2017.04.28 14:50:11.6181585 1056  4916  Agent           ServiceID = {00000000-0000-0000-0000-000000000000} Third party service
2017.04.28 14:50:11.6181589 1056  4916  Agent           Search Scope = {Machine}
2017.04.28 14:50:11.6181614 1056  4916  Agent           Caller SID for Applicability: S-1-5-21-1229461200-1096492676-1210191635-24242
2017.04.28 14:50:11.6181622 1056  4916  Agent           RegisterService is set
2017.04.28 14:50:11.6230507 1056  4916  Misc            EP: error: 0x8024500C : - failed to get SLS data
2017.04.28 14:50:11.6230547 1056  4916  Misc            Failed to obtain 9482F4B4-E343-43B6-B170-9A65BC822C77 redir SecondaryServiceAuth URL, error = 0x8024500C
2017.04.28 14:50:11.6230631 1056  4916  Agent           Failed to obtain the authorization cab URL for service 7971f918-a847-4430-9279-4a52d1efe18d, hr=0
2017.04.28 14:50:11.6230638 1056  4916  Agent           Caller UpdateOrchestrator failed to opt in to service 7971f918-a847-4430-9279-4a52d1efe18d, hr=0X8024500C
2017.04.28 14:50:11.6236457 1056  4916  Misc            EP: error: 0x8024500C : - failed to get SLS data
2017.04.28 14:50:11.6236497 1056  4916  Misc            Failed to obtain 9482F4B4-E343-43B6-B170-9A65BC822C77 redir Client/Server URL, error = 0x8024500C
2017.04.28 14:50:11.6236559 1056  4916  ProtocolTalker  PTError: 0x8024500c
2017.04.28 14:50:11.6236599 1056  4916  ProtocolTalker  Initialization failed for Protocol Talker Context 0x8024500c
2017.04.28 14:50:11.6391468 1056  4916  Agent           Exit code = 0x8024500C
2017.04.28 14:50:11.6391476 1056  4916  Agent           * END * Finding updates CallerId = TrustedInstaller FOD  Id = 14
2017.04.28 14:50:11.6627841 3976  4668  ComApi          *RESUMED* Search ClientId = TrustedInstaller FOD
2017.04.28 14:50:11.6631516 3976  4668  ComApi          Updates found = 0
2017.04.28 14:50:11.6631523 3976  4668  ComApi          Exit code = 0x00000000, Result code = 0x8024500C
2017.04.28 14:50:11.6631527 3976  4668  ComApi          * END *   Search ClientId = TrustedInstaller FOD
2017.04.28 14:50:11.6642985 3976  1676  ComApi          ISusInternal:: DisconnectCall failed, hr=8024000C
 
 
Ich bin langsam mit meinem Latein am Ende und daher für jede Hilfe dankbar.
 
Im voraus schon mal Danke für die Hilfe


#2 Sunny61

Sunny61

    Expert Member

  • 22.255 Beiträge

 

Geschrieben 06. Mai 2017 - 20:12

Es gibt einen dritten Eintrag:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate
UpdateServiceUrlAlternate

http://DeinWSUS:8530 eintragen. Dienst WUAUSERV auf dem Server/Client neu starten, der sich nicht meldet, und wieder suchen lassen. Jetzt kann gedownloadet und installiert werden.

Gibt es übrigens seit Januar 2017 auch als GPO-Einstellung.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#3 Cirederf

Cirederf

    Newbie

  • 3 Beiträge

 

Geschrieben 08. Mai 2017 - 08:46

Hi,
 
habe gestern schon die ADMX Files aktualisiert. Daraufhin keine Besserung. Dann habe ich gerade mal einen 2016er Server neu installiert. Auch hier der gleiche Fehler wie vorher.
 
...und ich war sooo optimistisch  :(

 

zu1c9.png

 


Bearbeitet von Cirederf, 08. Mai 2017 - 08:48.


#4 Sunny61

Sunny61

    Expert Member

  • 22.255 Beiträge

 

Geschrieben 08. Mai 2017 - 10:23

Und du hast auch das %windir%\SoftwareDistribution nach der Installation einmal gelöscht?


Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#5 Cirederf

Cirederf

    Newbie

  • 3 Beiträge

 

Geschrieben 08. Mai 2017 - 10:52

Gerade auf beiden Servern. Immer noch der 0x8024500c auf beiden Servern.



#6 Sunny61

Sunny61

    Expert Member

  • 22.255 Beiträge

 

Geschrieben 08. Mai 2017 - 19:53

OK, probier diesen Lösungsvorschlag aus: https://community.sp...update-via-wsus
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#7 Marco31

Marco31

    Junior Member

  • 389 Beiträge

 

Geschrieben 08. Juni 2017 - 08:16

Ich bin gerade mit unserem ersten Windows 2016 Server wohl in das gleiche Problem gelaufen... Fehler 0x8024500c sobald ich in den GPO's "Keine Verbindungen mit Windows Update Internetadressen herstellen" aktiviert habe; merkwürdigerweise hat diese Einstellung bei meinen Win10 1607 Clients keine negativen Auswirkungen. Und außerdem SOLL der Server ja gar keine Verbindungen mit Windows Update aufbauen...

Ist das jetzt ein Bug oder ein "Feature"?



#8 Sunny61

Sunny61

    Expert Member

  • 22.255 Beiträge

 

Geschrieben 08. Juni 2017 - 09:25

Vermutlich ist es ein Feature das noch einen Bug enthält. :)
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#9 Marco31

Marco31

    Junior Member

  • 389 Beiträge

 

Geschrieben 09. Juni 2017 - 05:45

Ok, diesmal war das Problem nicht Microsoft sondern der vor dem Monitor :D Ich hatte wohl manuell in den Einstellungen (nicht per GPO) "Featureupdates zurückstellen" angehakt, das gehört ja zu den Einstellungen die man für Updates über WSUS nicht setzen darf. Haken raus und schon zieht der W2K16 brav seine Updates vom WSUS. :thumb1:  



#10 Sunny61

Sunny61

    Expert Member

  • 22.255 Beiträge

 

Geschrieben 09. Juni 2017 - 06:11

Freut mich für Dich und Danke für die Rückmeldung. ;)

BTW: Das nächste Mal machst Du dann auch einen eigenen neuen Thread dazu auf, fremde Threads kapert man einfach nicht, Danke.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/



Auch mit einem oder mehreren der folgenden Tags versehen: WSUS