Jump to content
Sign in to follow this  
ReneKr

VMWARE und DHCP Win2003 Server

Recommended Posts

Hi zusammen,

 

Ich habe auch mal eine Frage bez.: W3K Server aud VMWARE und DHCP.

 

Ich bekomme es nicht hin das der Win DHCP Server IPS verteilt.

Habe den W3K SRV auf Host Only und den VMWARE Client auch auf Host only.

 

Ich habe dann Netmoni laufen lassen und keine DHCP Discoffer MEssages.

Broadcasts bekomm ich im Server vom Client aber nicht zurück.

 

Habe auf dem 1. Adapter im W3K Srv die 192.168.115.28 IP , habe auch mal mit 2. Lan Karte probiert und dieser die IP 115.100 gegeben.die dann wie den clientauch auf vmnet2 gesteltl da ging dann dhcp.

 

Aber ich habe alle Services auf .28 IP eingestellt ( Netisntall Datenbank ) da komm i vom Client nicht hin.

Anderst herum ( also die 2. KArte auf Hostonly und die 1 auf vmnet2 ging auch nicht mehr mit IP Adresse verteilen.

 

DNS geht und DHCP ist 100 % richtig eingestellt.

 

Kann mir da jemand nen Tip geben?

 

Ich habe die Frage schon in einem anderen Thema gestellt und mache wie mir geraten wurde hier nun ein neues thema auf:

Das ist dein Problem, VMWare-Host-Only NICs sind an einen VMWare eigenen DHCP gebunden. Wenn du Windows DHCP nutzen willst, nutze einen der Custom-Switches (VMNet 2-7 oder 9). Da funzt DHCP ausgezeichnet.

 

Also ich habe es ja schon mit 2 Lan Karten probiert ( 1. Hostonly und 2. in VMNET2 wie client, aber anderst ehrum gings dann nciht,also Lan 1 mit der ( 115.28 an den vmnet2 und die 2 mit 115.100 an den host only.da ging dann DHCP nicht mehr.

 

Wie ist es denn wenn ich die 2 vms mit VMNET2 vernetze ,wie komme ich dann vom client drauf?

Danke.

Share this post


Link to post

Wie ist es denn wenn ich die 2 vms mit VMNET2 vernetze ,wie komme ich dann vom client drauf?

 

:confused: Was meinst Du genau?

 

Du erstellst eine VM für den Server mit einer NIC in z.B. VMNet2 und den Client auch mit einer NIC in VMNet2. Beide sind dann vom physischen Netz natürlich abgekoppelt. Der VMClient kann sich dann aber vom VM-DHCP Server eine IP holen.

 

Wozu soll die 2. NIC sein? Musst Du denn von einer physischen Maschine (z.B. dem VMWare Host) auch auf die VM(s) zugreifen können?

 

Christoph

Share this post


Link to post

Hi,

 

Also ich erkläre es mal etwas Ausführlicher:

Ich muss vom Host in den W3K Server reinkommen,weil ich damit Software PAcketieren will ( Netinstall).

 

DHCP Range 115.110-150

Ich habe 2 Szenarios mal eben getestet:

 

1.: W3K - 1 NIC 115.28 an VMNET2 // Client ist eigentlich immer gleich auf VMNET2 mit DHCP nix eingestellt,DNS gateway.

DHCP geht net, aber mit Fester IP kann i ihn pingen.

2.NI Host mit 115.100 IP

DHCP Server 115.28

 

1.: W3K - 1 NIC 115.28 an Host // Client ist eigentlich immer gleich auf VMNET2 mit DHCP nix eingestellt,DNS gateway.

DHCP geht sofort

2.NI VMWARE2 mit 115.100 IP

DHCP Server 115.100

 

 

Aber ich will das der 115.28 als DHCP Server spielt udn ich mit host über die 115.100 kommuniziere,weil die NETI DB auf 115.28 ist und eingestellt ist.

 

Danke

Share this post


Link to post

Hi,

Definitive nicht.

Habe den Bereich gelöscht und den Services gestoppt.

 

Also egal welche Kombi ich nehme der Dhcp geht nur auf der 2. Lan Karte im W3Server. wollte ja die 1 also Server ,also VMNET2 nehmen und die 2.als Host.(habe auch die IP Range geändert von 1. und 2. LAn Adapter damit da nix pasiert.

 

Ich habe nun mal nur 2. Lan karte aktiviert udn die 1. deaktiviert,

Wenn die 2. die IP 115.28 hat geht dhcp nicht wenn se 115.100 hat als IPÜ geht DHCP.

DHCP Server habe ich natürlich umgestellt.

 

Ich blick langsam net mehr durch.

 

danke

Share this post


Link to post

Ich blicke durch deine Worte leider auch nicht mehr so ganz durch :confused:...

 

An wen soll der DHCP Server in der VM denn nun Adressen verteilen, nur an weitere VMs?

 

Und das Netinstall Programm läuft wo? Auf dem Host zusammen mit den Daten, aus denen die Netinstall-Pakete kreiert werden sollen?

 

Und diese Pakete sollen dann auch an die VM Clients verteilt werden?

 

Habe ich das so richtig verstanden?

 

Sonst erkläre das Szenario noch mal ganz genau, bitte.

 

Christoph

Share this post


Link to post

Also der W3K Server hat DB von NEtinstall und soll als DNS und DHCP für weitere Clients aggieren. auf einer Karte.

Die 2. Karte soll nur am Host hängen mit anderer Subnet und andere IP Range.

Damit ich Dateien auf den W3K Server vom Host kopieren kann.

 

Und von den Clients hole ich diese vom W3K Server und installiere sie .

 

PS: Ich mache mal ne Excel Liste wo ich alles reinschreibe wo DHCP geht und wo net.Ich blick da nämlich a net durch wen ni es durchlese .

Sorry

 

danke

Share this post


Link to post

Hi,

hier mal 2 Szenarios.:

 

Szenario 1: W3 K Server

 

Lana 1 Host ( VM1 ) / Lana 2 VM2 / DHCP SRV / DHCP Adress Pool

192.168.215.28 / 192.168.222.100 / 192.168.222.100 / 222.110-222.150

 

Client IP ADRESSE: geht DHCP

192.168.222.110

 

 

Szenario 2:

Lana 1 Host ( VM1 ) / Lana 2 VM2 / DHCP SRV / DHCP Adress Pool

192.168.215.28 / 192.168.115.28 / 192.168.115.28 / 115.30-115.50

 

Client IP ADRESSE: geht nicht DHCP

APIPA

 

 

Weiter werde ich morgen posten:

 

Es muss aber am Ende so sein:

Ein Adapter mit 192.168.115.28 wegen Netinstall DB. VMNET2 mit Clients und DHCP DNS

Ein Adapter egal nur Kommunikation mit VM1 per Host.

Share this post


Link to post

Hi,

wie ist es eigentlich:

Wenn ich VMWare Server installiere bekommen die VMNET 1+8 ja feste IPS.

 

Ich habe die in der 1 ja geändert und wenn ich die Feste IP 115.28 dem W3K Server vergeben geht es auf Teufel komm raus nciht das die clients DHCP IPs bekomme.

 

Hat da VMW ein Problem wenn man die IPs der Adapter umstellt oder ändert?

 

Beim Range von 192.168.222.xyx geth dhjcp problemlos immer ( Adapter 1 od.2 )

Kann es sein das die VM2 dann iergendwie mit der VM1 Probleme hat?

 

Danke

Share this post


Link to post

Hi,also ich habe es nun so hinbekommen wie ich es will.

Weiß net aru mes vorher nicht ging.

Aber iergendwie ist das mit DHCP und VM schon ein bisschen buggi.

 

Also Lan 1 = Host

Lan 2 = VM2 mit DHCP Server W3K und er vergibt IPs auf dem VMNET2.

 

Nun noch ne FragE?

Wie ist es wenn ich den DHCP Server in mein normales Lan spucken lassen will?

Reicht es dan nwenn ich die VMNET2 im Server auf Bridged stelle?

Geht es dann?

 

Danke.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...