Jump to content

Netzwerkumgebung leer, was mach ich falsch?


Guest
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Zusammen!

 

Ich habe gelesen, dass einige ganz ähnliche Probleme haben wie ich, trotzdem habe ich keine Hilfe in den bestehenden Beiträgen gefunden.

 

Wir haben in unserer WG ein kleines Heimnetz, welches über einen Linksys-Router mit dem Internet verbunden ist.

 

Installierte Dienste auf den XP-Compis:

- Client für MS Netzwerke

- TCP/IP

- Datei und Druckerfreigabe

 

Über die IP-Adresse kann ich direkt per TCP/IP auf den anderen Compi zugreifen (\\192.1.68.1.101\c$). Aber die Netzwerkumgebung bleibt trotzdem leer...

Beide Computer befinden sich in derselben Arbeitsgruppe. Teils zeigt es auf einem Computer beide PCs in der Netzwerkumgebung an, wenn man dann auf den anderen klickt kommt "Auf \\pc1 kann nicht zugegriffen werden... Der Netzwerkpfad wurde nicht gefunden".

 

Um Probleme mit dem Router auszuschliessen habe ich die Compis direkt mitteils eines crossover-Kabels verbunden und ihnen statische IPs gegeben. Das Problem ist nicht gelöst. Mir ist klar, dass ich mittels einer lmhost-Datei Computernamen statisch einer IP zuordnen kann. Der Router arbeitet aber via DHCP.

 

In der Eingabeaufforderung klappt:

- immer: PING <ip adresse des anderen computers>

- immer: PING <netbios-namen des eigenen computers>

- NIE: PING <netbios-namen des anderen computers>

 

Es ist zum aus-der-Haut-fahren! Das hat doch früher auch geklappt, oder täusch ich mich da? Muss ich tatsächlich das NWLink IPX/SPX/Netbios-Protokoll installieren. Das sollte doch auch nur mit TCP/IP klappen, in dem sich ein Computer quasi als Master "outet" und die Liste der verfügbaren Compis zusammenstellt... (Ich weiss, dass ich diesem Prozess etwas Zeit geben muss, das hilft leider auch nicht).

 

Besten Dank für Lösungsvorschläge! (danke, danke, danke) :)

 

greetz

 

Floppy21

Link to comment

Hi !

Wenn Du die Threads wirklich gelesen hast, wird Dir aufgefallen sein, daß es mit dem DHCP-Dienst der Router oft Probleme gibt.

Als erstes würde ich Dir aus diesem Grund schon mal empfehlen, von DHCP auf manuelle Vergabe der IP umzustellen.

Um dann ganz sicher zu gehen, würde ich die beteiligten PC in der HOSTS. Datei auf jedem Computer eintragen (lmhosts ist bei reiner XP-Umgebung nicht notwendig, aber die paar Einträge tun auch nicht weh) alle neu starten und mal sehen, wie es dann aussieht in der Netzwerkumgebung.

Wenn man sowieso schon bei der Netzwerkkonfiguration ist, kann man die interne Firewall gleich mit deaktivieren, um diese als Fehlerquelle auszuschließen.

 

Macht mal los, mal sehen, was rauskommt !

 

zuschauer

Link to comment

Danke für eure Antworten!

 

Es kann nicht am DHCP liegen, da ich 2 XP-Compis sogar mittels crossover-Kabel vernetzt habe und ihnen eine statische IP zugewiesen haben.

 

Die XP Firewall habe ich selbstverständlich deaktiviert. Hat die überhaupt jemand aktiviert? :)

 

Ich kann mich erinnern, dass ich früher "ping pc1" problemlos ausführen konnte, ohne dass ich eine host-datei anlegen musste. Mir ist klar, dass das Problem damit umgangen werden kann...

 

Anstatt einer Symptombekämpfung würde mich (und einige andere User in diesem Forum ziemlich sicher auch *g* ) die Ursache interessieren, warum das nicht (mehr) klappt.

 

Thx & greetz

Floppy21

Link to comment

nun,

 

gehen wir mal davon aus:

Du hast Netzwerk-Connectivity, aber die Namensauflösung funktioniert scheinbar nicht.

 

Wie löst Win2K NAmensabfragen aus:

 

entweder DNS - hast Du einen DNS-Server im NEtz und die Clients entsprechend konfiguriert?

NetBios - in den erweiterten Einstellungen von TCP/IP findes Du die NetBios-Einstellungen;

sollte NetBios over TCP/IP deaktiviert sein, könnte das das Problem sein.

Link to comment

Nein, ich habe keinen DNS.

 

Netbios über TCP/IP ist aktiviert...

Ich habe auch schon bei beiden Computer die Konfiguration gelöscht und neuaufgesetzt. Leider nichts...

 

:(

 

trotzdem danke vielmals für euer feedback!

Link to comment

Hi Floppy !

Zu Deinen direkten und indirekten Fragen u. indirekten Antworten:

- ein Arbeitsgruppennetzwerk funktioniert im Normalfall immer, wenn nur TCP/IP installiert ist, andere Protokolle sind nur zusätzlicher Ballast

- in diesem Arbeitsgruppennetzwerk macht einer den Hauptsuchdienst ("outet sich als Master")- welcher das ist, wird zwischen den Clients ausgehandelt

- die HOSTS. u. LMHOSTS. sind für ein MS-Netzwerk nicht zwingend notwendig, im Normalfall geht´s auch ohne.

- ab W2k aufwärts (also auch XP) ist auch Netbios nicht mehr zwingend notwendig für ein funktionierendes Netzwerk

 

Du hast also durchaus recht, HOSTS, LMHOSTS und Netbios sind Symptombekämpfungen, um das Netzwerk ans Laufen zu bringen.

 

Das Schwierige bei dieser Fern-Diagnose/-Hilfe ist, man kann die Situation nicht nachstellen. Ich glaube nicht, daß man ein funktionierendes Netzwerk bewußt so hinbekommt, daß es nicht mehr funktioniert (außer man verwendet manipulierte HOSTS und LMHOSTS, damit es auch wirklich nicht mehr funktioniert.)

 

Aus diesem Grund, versuch ich es in solchen Fällen immer mit den oben genannten Symptombekämpfungen.

Das "Problem" bei Dir, und anderen, liegt darin begründet, daß MS versucht, die Organistion des Netzwerkes so weit wie möglich automatisch zu regeln, damit der Nutzer nicht einen Netzwerkspezialisten braucht. Im Normalfall funktioniert das auch, die anderen melden sich z.B. hier im Board.

Diese Netzwerkkonfiguration/Organisation wird in der Registry des PC gespeichert und bei Veränderungen des Netzwerkes angepaßt. Veränderungen wären z.B. eine Firewall, ein installierter ICS, eine Änderung des Arbeitsgruppennamens, Hinzufügen und Entfernen von anderen Protokollen.

 

Und nun zu Deinem Problem:

Wenn nur 2 PC im Netz sind, kann man schon mal schwer einkreisen, welcher von beiden spinnt. Den Router als Fehlerquelle hast Du schon ausgeschlossen. Es steht also fest, daß die Registry-Einträge von mindestens einem von beiden hinüber sind, die Gründe dafür sind nicht nachvollziehbar.

Das Sinnvollste an dieser Stelle ist, die Mechanismen, die MS eingebaut hat, zur Herstellung einer funktionierenden Netzwerkumgebung zu nutzen.

Dazu versetzt man den PC wieder in den jungfräulichen Zustand eines PC ohne Netzwerk, und bastelt alles vorn. Problem dabei ist, die vorhandenen Registry-Einträge zu entfernen.

Da das Entfernen des TCP/IP-Protokolls bei Euch nicht geholfen hat, macht folgendes ( in der Reihenfolge und auf beiden PC):

In den Netzwerkeigenschaften:

- MS-Client für´s Netzwerk entfernen

- TCP/IP entfernen

- die Netzwerkkarte entfernen

Den PC runterfahren und die Netzwerkkarte ausbauen.

Den PC wieder hochfahren = jungfräulicher PC ohne Netzwerk

Den PC runterfahren, die Netzwerkkarte wieder einbauen und das Netzwerk über den Netzwerkinstallationsassistenten (schönes Wort für Scrabble :D ) wieder konfigurieren.

(Der Assi sollte bei XP immer verwendet werden, auch wenn man die paar Klicks per Hand machen könnte).

 

Versucht´s mal und sagt Bescheid.

 

Gruß Nino

Link to comment

@Nino

Besten Dank für Deinen ausführlich Beschrieb! Das ist auch so in etwa das, was ich mir gedacht habe. Nur das ich absolut keine Lust zu einer Neuinstallation hatte. :)

 

@all

Unterdessen ist das Problem gelöst! Ich musste den Registryeintrag HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\DHCPNodeType löschen. Ein ähnlicher Lösungsvorschlag hatte ich hier bereits einmal gelesen, der Eintrag in der Registry war allerdings etwas anders, so dass ich ihn nicht auf Anhieb fand.

 

Dieser Eintrag wird jedesmal von Windows eingefügt wenn mein Compi mittels DHCP eine IP-Adresse vom Kabelprovider (Cablecom, Schweiz) holt. Dieser Eintrag verhindert NETBIOS-Broadcasts.

Dies geschieht jetzt nicht mehr, da wir seit einiger Zeit einen Router haben, der Eintrag war noch von früher, als die Compis direkt am Kabelmodem hingen.

 

Der Provider will damit wohl die User schützen:

Viele unwissende ******-User haben die Datei und Druckerfreigabe ans TCP/IP gebunden und weder Router noch Firewall. Dadurch sind diese extrem gefährdet, da das Microsoft SMB Protokoll und NETBIOS (sofern an TCP/IP gebunden) über TCP139, UDP137, TCP445, UDP445, UDP138 laufen. Dazu kommt, dass viele Benutzer nicht mal ein Admin-Passwort haben. So würde sich ohne grossen Aufwand auf dessen Harddisk zugreifen lassen.

Da viele Cablecom-IPs im selben Subnetz sind, könnte so ein "Hobby-Hacker" mittels Netzwerkumgebung direkt die anderen ******-Computer sehen (und zugreifen).

 

Allerdings sooo super ist dieser Schutz auch nicht. Mit Portscanner besagte Ports scannen und mittels \\ip-adresse\c$ auf den entsprechenden Win2k/WinXP-Compi zugreifen...

 

Besten Dank für Eure Ratschläge!

 

So long,

Floppy

Link to comment

@Nino (zuschauer)

 

Ich hab's doch auch nicht vorher gewusst... :)

Trotzdem vielen Dank für Deinen ... Roman *g*

 

Bin wirklich froh, dass die Leute hier alles dransetzen, dass einem geholfen wird. Bin zwar noch neu hier, find's aber schon echt Klasse!

 

So long, Floppy

Link to comment

seit ca. 4 Wochen renne ich genau diesem Phänomen hinterher. Natürlich hätte man eine Lösung über hosts ... machen können, aber das ist nicht wirklich befriedigend. Leider findet man auch nirgendwo eine systematische Analysemöglichkeit.

 

Jetzt hats - dank eures Tips - geklappt.

 

Übrigens: diese Einstellung war auf einem vorkonfigurierten Rechner Fujitsu-Siemens mit WinXP-Home eingetragen.

 

Nochmals vielen Dank!!!

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...