Jump to content
Sign in to follow this  
Khelben

RIS - vollautomatische Benutzerinstallation

Recommended Posts

Hallo zusammen,

 

ich habe ein RIS-Abbild erstellt und installiert. Funktioniert soweit, aber am Ende muss ich immer noch von Hand einen Benutzer anlegen sowie die Produktregistrierung bestätigen / ablehnen. Kann man das auch irgendwie automatisieren? Mir ist kein Parameter in der Doku aufgefallen..

 

2. Bei einer unattened - Installation kann ich ja ohne weiteres die Hardware - Treiber unter I386 - $oem$ usw angeben. Für die Netzwerkkartentreiber bei RIS mache ich das ja im selben Verzeichnis, wo auch I386 steht. Kann ich da auch die anderen Treiber für die RIS Installation hinein stellen?

 

Danke für Infos :)

 

Gruß

 

Markus

Share this post


Link to post

Benutzer kann man mit net users in einer Batch anlegen lassen. Die anderen Sachen gehen über eine Antwortdatei, die Unattended Hilfe (deploy.chm in der deploy.cab bemühen).

 

Bei RIS kommt das $OEM$-Verzeichnis PARALLEL zum I386, nicht unterhalb

 

 

grizzly999

Share this post


Link to post

Hallo

 

erstmal danke. Das mit den Treibern klappt jetzt, aber bei dieser Produktregistrierung und dem Computerbenutzer bekomme ich noch junge Hunde... :cry: Bei einer normalen Unattended-Installation bekomme ich die beide nicht angezeigt nicht, nur bei RIS... warum? :confused:

 

Das einzige was ich in der Hilfe gefunden habe, war SkipWelcomeScreen, aber ich glaube das ist der WelcomeScreen bei der Anmeldung.

 

Außerdem habe ich versucht die Installation nur auf eine 5GB große Partition zu packen. Aber das klappt auch nicht. Entweder nimmt er die ganze Platte oder fragt mich was er tun soll. Dabei habe ich ExtendOEMPartition=5000 gesetzt und sowie ich die Hilfe verstanden habe, sollte das klappen.

 

Die HD ist im übrigen komplett leer und nicht formatiert beim Installationsversuch.

 

Habe mal meine ristndrd.sif mal beigefügt, vielleicht findet ihr ja den Fehler :confused:

 

;SetupMgrTag

[data]

floppyless="1"

msdosinitiated="1"

OriSrc="\\%SERVERNAME%\RemInst\%INSTALLPATH%"

OriTyp="4"

LocalSourceOnCD=1

DisableAdminAccountOnDomainJoin="yes"

AutoPartition=1

UnattendedInstall="Yes"

 

[setupData]

OsLoadOptions="/noguiboot /fastdetect"

SetupSourceDevice="\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

 

[unattended]

OemPreinstall=Yes

OEMPnPDriversPath = drivers\nic;drivers\aclient;drivers\audio;drivers\dm500;drivers\eab;drivers\lcrms;drivers\video;drivers\mouse;drivers\rdea;drivers\sw_ver;drivers\wbem

DriverSigningPolicy=Ignore

FileSystem=LeaveAlone

ExtendOEMPartition=5000

TargetPath=\WINDOWS

OemSkipEula=Yes

InstallFilesPath=\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%

LegacyNIC=1

UnattendMode=FullUnattended

NtUpgrade=No

OverwriteOemFilesOnUpgrade=No

 

[userData]

FullName="Markus"

OrgName="Testorg"

ComputerName=evomcse

ProductKey=ein gültiger

 

[GuiUnattended]

OemSkipWelcome=1

OemSkipRegional=1

TimeZone=%TIMEZONE%

AdminPassword=f0d412bd764ffe81aad3b435b51404ee209c6174da490caeb422f3fa5a7ae634

EncryptedAdminPassword=Yes

AutoLogon=Yes

AutoLogonCount=1

 

[Display]

BitsPerPel=16

XResolution=800

YResolution=600

VRefresh=60

 

[Networking]

InstallDefaultComponents=Yes

ProcessPageSections=Yes

 

[identification]

JoinDomain=DOMAENE2

DoOldStyleDomainJoin=Yes

 

[RemoteInstall]

Repartition=yes (bei no fragt er mich, in welche Partition er installieren soll)

UseWholeDisk=No

 

[OSChooser]

Description="Windows Professional - Standardinstallation"

Help="Diese Option installiert eine Standardkonfiguration von Windows Professional."

LaunchFile="%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"

ImageType=Flat

Version=5.1

 

[setupMgr]

DistFolder=D:\windist

DistShare=windist

 

[branding]

BrandIEUsingUnattended=Yes

 

[Proxy]

Proxy_Enable=0

Use_Same_Proxy=0

 

Vielen Dank für eure Hilfe :)

 

Gruß

 

Markus

Share this post


Link to post

Partitionieren bei RIS ist nicht, also nicht im Sinne von "Ich hätte gern 5000 Gramm von der da" :D

Entweder die ganze Platte als eine Partition oder Repartition=No und vorher manuell partitionieren.

 

Ist der Product in Hochkommas (muss glaube ich lt. Hilfedatei bei XP so sein)?

 

Bei welchem Computerbenutzer bekommst du Junge?

 

 

 

grizzly999

Share this post


Link to post

Hallo Khelben,

 

falls du nach erfolgter Installation nicht "gezwungen" werden willst einen

neuen Benutzer anzulegen nimm:

 

[unattended]

UnattendSwitch=Yes

 

thorgood

Share this post


Link to post

Danke für die Antworten :)

 

Ob der Produkt-Key in Hochkommas steht weiß ich gerade nicht, aber der ist nicht das Problem, denn danach fragt er mich nicht.

Mein Problem ist, dass nach der Installation (noch vor dem 1. anmelden) ein Wizard aufgeht, wo versucht wird eine Internetverbindung aufzubauen damit XP aktiviert (mein Fehler - hab immer von Registrierung gesprochen :rolleyes: ) werden kann. Direkt im Anschluß daran, kommt ein Screen wo ich weitere Benutzer anlegen kann bzw. einen weiteren anlegen muss.

 

Dieser Wizard sollte einfach nicht erscheinen. Werd das mit dem von thorgood genannten Parameter mal testen.

 

Das mit der Partion werde ich mal ausprobieren. Hab bisher immer auf blanke Platte versucht zu installieren. Allerdings verstehe ich dann den Parameter ExtendOEMPartition nicht. Wofür soll der gut sein?

 

Meld mich wieder sobald ich es getestet habe :)

 

Gruß

 

Markus

Share this post


Link to post

UnattendSwitch=Yes

 

Das wars...alle Probleme gelöst. Firma dankt und bis zum nächsten Problem :D

 

Und es zeigt sich immer wieder...so schön es theoretisch in den Büchern beschrieben wird sieht die Realität nie aus. Habt mir sehr geholfen und einen Verständnis-Stein zur 70-270 aus dem Weg geräumt :)

 

btw. der Product-Key muss nich in Hochkommas.

 

Gruß

 

Markus

Share this post


Link to post

Probiere mal den:

 

[unattended]

AutoActivate = No

 

 

 

Das mit dem ExtendOEMPartition ist so gedacht, wie du gedacht hast :D

aber eben nicht mit RIS, sondern nur mit Unattended.

 

 

grizzly999

Share this post


Link to post

Hab mir das gerade mal angeschaut.

 

In der Hilfe steht, das Default-Value = No ist. Wenn dem so ist, warum muss man sowas noch explizit angeben... so richtig logisch is das nich, oder seh ich das falsch? :confused: ...aber es hat ja auch schon mit UnattendSwich funktioniert von daher..

 

So, nachdem Unattend und RIS so klappen wie ich mir das vorstelle, lass ich mich von Sysprep überraschen, was da noch so klappt und was nich... :D

 

Gruß

 

Markus

Share this post


Link to post

Bei der SYSPREP-Installation über RIS gibt es die Möglichkeit, die Grösse der Partition zu steuern.

Mit folgenden Werten kann das erreicht werden:

 

[unattended]

ExtendOEMPartition=10240

 

[RemoteInstall]

Repartition=Yes

UseWholeDisk=No

 

So hab ichs gemacht und er legt mir eine tolle 10GB- Partition an. Sollte es nicht klappen, muss ich nochmal nachschauen, ob nich doch noch Schalter fehler ;)

 

 

Bei der FLAT-type Installation geht es defenitiv NICHT

Share this post


Link to post
Bei der FLAT-type Installation geht es defenitiv NICHT

 

Was ist unter "FLAT"-Installation zu verstehen?

 

Leider klappen bei mir Deine Schalter nicht, es wird die komplette HDD partioniert und formatiert.

 

Grüße, e2e4

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...