Jump to content

E-Mails von extern über SMTP senden


Recommended Posts

Hallo zusammen

 

Ausgangslage:

Ich bin daran, mit einem Softwareanbieter die Möglichkeit bereitzustellen, dass E-Mails über den Exchange Server via SMTP von extern gesendet werden können. Genauer gesagt sollen die Nachrichten verschlüsselt mit dem Incamail Service der Schweizer Post gesendet werden (Infos dazu unter https://www.incamail.com/).

 

Wir haben dafür bereits ein eigenes Benutzerkonto erstellt, welches für den Mailversand genutzt werden soll. Das Login beim OWA funktioniert und von dort können auch E-Mails gesendet werden. Es ist aber nicht möglich, die Mails über SMTP zu senden. Ich sollte es nun so einrichten, dass die Daten in den Option - wie auf folgender Seite ersichtlich - angezeigt werden:

https://docs.microsoft.com/en-us/exchange/clients/pop3-and-imap4/configure-authenticated-smtp?view=exchserver-2016

 

Auf dem Exchange Server sind die standardmässigen Empfangsconnectors Default Frontend <Server name> (Port 25), Client Frontend <Server name> (Port 587) sowie Client Frontend <Server name> (Port 465) vorhanden. Zusätzlich gibt es einen benutzerdefinierten Empfangsconnector Mailrelay (Port 25), bei dem unter Remotenetzwerkeinstellungen einige interne IP-Adressen (mehrheitlich Drucker) eingetragen sind. Ich habe einen zusätzlichen Empfangs.

 

Eine Abfrage des Befehls 'Get-ReceiveConnector -Identity "Client Frontend*" | Format-List Name,Fqdn,TlsCertificateName' ergibt Folgendes.

Name               : Client Frontend SERVER
Fqdn               : Server.int.domain.ch
TlsCertificateName :

Bei den anderen Empfangsconnectors ist es gleich.

 

Die Abfrage von Get-ExchangeCertificate ergibt Folgendes:

Thumbprint                                Services   Subject
----------                                --------   -------
2239DD3445EFD32BB45FC9FF10527D4DB877C6D8  IP.WS..    CN=owa.external-domain.ch
FDCEEC8CCBC59BEFC632F1E19257E8FC32ECBBF9  .......    CN=Microsoft Exchange Server Auth Certificate
035973657EA3D9E94B4074395D6DDCE8DE2B627D  .......    CN=Server
0FDA59EFA36F4E63B5200F8CE088D0B61E672591  .......    CN=WMSvc-SHA2-SERVER

 

Fragen:

- Welches Zertifikat muss/kann für TlsCertificateName - authentifiziertes SMTP - ausgewählt werden?

- Muss sonst noch etwas gemacht werden, damit der SMTP-Versand möglich ist?

 

Anmerkung, sofern relevant:

Der Exchange-Server ist mit Office 365 verbunden.

 

Besten Dank im voraus

Edited by CorneliaH
Kleine Anpassung
Link to post

Wenn man bei Incamail per SMTP einliefern will, muss man ein Formular ausfüllen, auf dem man ihnen mitteilt, mit welchem Zertifikat sich der Server (per SMTP mit STARTTLS) meldet. Das muss ein "offizielles" Zertifikat sein. Es geht bei Incamail ja darum, "eingeschriebene" E-Mails zu schicken und da müssen sie wissen, dass die E-Mail vom richtigen Server kommt.

 

Dies für den Fall, dass die E-Mails von einem lokalen Exchange gesendet werden. Falls die Nachrichten über Exchange Online geroutet werden, ist das Setup evtl. anders. Dort weiss man ja weder die IP noch ist das Zertifikat kundenspezifisch. Habe auf die Schnelle keine Informationen gefunden, aber der Support von Incamail sollte gut weiterhelfen können. Du bezahlst ja schliesslich eine Setup-Gebühr. :-)

Link to post

Danke schon mal für die Antworten

 

Die Postfächer sind nur on-premise, nicht online.

 

Was die Einstellungen bei Incamail betrifft, liegen mir keine Informationen vor. Der externe Supporter der Softwarefirma stellte nur die Forderung, die richtigen (funktionierenden) Zugangsdaten für den Server zu erhalten. Um die Konfiguration bzw. Schnittstelle zu Incamail kümmert er sich selbst.

In der Setup Documentation von Incamail sind für 'SMTP/TLS Auth' die Server gw1.incamail.com und gw2.incamail.com erwähnt. Deren IP-Adressen habe ich jetzt in zwei zusätzlichen, für Incamail erstellten, Empfangsconnectoren eingetragen - einen für Port 25 und einen für Port 587.

 

Das erste Zertifikat der obenstehenden Liste ist offiziell. Ich habe dieses mit dem Incamail Empfangsconnector für Port 587 verknüpft.

Die Abfrage des Connectors ergibt jetzt Folgendes:

Name               : Incamail
Fqdn               : Server.int.domain.ch
TlsCertificateName : <I>CN=RapidSSL RSA CA 2018, OU=www.digicert.com, O=DigiCert Inc,
                     C=US<S>CN=owa.external-domain.ch

 

Vom Softwareanbieter werde ich den Mailversand nochmals testen lassen.

 

Anmerkung/Nachtrag:

Testhalber habe ich das Zertifikat zusätzlich mit dem Empfangsconnector Client Frontend <Server name> verknüpft in der Hoffnung, dass die Angaben danach in den Einstellungsoptionen von OWA erscheinen würden. Da dies jedoch nicht der Fall war, habe ich das Zertifikat für diesen Connector wieder entfernt.

 

Edited by CorneliaH
Korrektur/Nachtrag
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...