Jump to content

"Verzerrter" Sound über RDP Verbindung


Recommended Posts

Hi,

 

ich habe das Problem, dass Sound, der über eine RDP Verbindung abgespielt wird, nach ein paar Sekunden so richtig kratzig und hochtönig wird.

 

Wenn ich dann keinen Sound mehr abspiele, ein paar Sekunden (ca 20 - 30) warte und wieder Ton Abspiele, ist der Ton wieder ein paar Sekunden normal.

 

Kennt jemand das Phänomen?

 

Link to post

Ist auch gerne mal Ressourcenabhängig

- Reservierte Ressourcen machen weniger Ärger

- Überlastetes LAN macht SEHR gerne Ärger

- LAN mit mieser Qualität - nicht Quantität - macht SEHR gerne Ärger (Paketloss ist hier das Stichwort)

- Maschinen mit eher hoher Auslastungen machen gerne mal Ärger

- abgespeckte Maschinen machen deutlich weniger Ärger (Alles abdrehen was unnötig aufzeichnet, Telemetrie etc. Hilft allgemein bei VDI. Sprich alle unnötigen IOPS/Cycles weg)

- Alles was energiesparen auf USB-Basis ist, harmoniert nicht mit Sound und auch sonst vielem (etwas pauschal, weil mancherort funktionierts aber hilft halt oft doch bei Ärger)

 

Das ganze Telemetrie-Geraffel könnte ich mir gut vorstellen, dass es nach grösseren Update-Runden wieder Probleme macht. Kommt ja immer wieder was neues dazu und die Kisten sind dann oft fleissiger am aufzeichnen und der Ärger ist ja sehr oft nach Update-Runden. Habe das aber schon länger nicht mehr analysiert.

 

Das Problem gibt es auch sehr gerne wenn Sound per USB angebunden ist, da Sound ähnlich wie manche Industrie- und Laborgeräte oder auch Kameras mit "insochronus Transfer Mode" übertragen. Quasi die Nordwand in Sachen USB-Übertragung. Wie genau die Durchreichung in RDS-Sessions genau funktioniert weiss ich jetzt nicht da schon länger nicht mehr gemacht, bei PCoIP geht das via USB. Daran scheitern auch viele USB-LAN Server (Silex kanns zum Beispiel).

 

Mittlerweile schau ich, dass entweder der zugreifende Client selbst Audio/Video erledigt oder ich den Sound/Kamera mit einem USB-LAN-Server direkt in die VM bringen kann. Keine Lust mehr auf das ewige hin und her. Das hat bis jetzt am zuverlässigsten funktioniert und ich habe meine Ruhe. Wiederkehrende Probleme schalte ich gerne komplett aus und gehe Ihnen aus dem Weg. :D

  • Thanks 1
Link to post

Gute idee.

 

Ich werde mal mein Klinke Headset testen.

Ich render im Hintergrund auf der Remote Maschine auch immer Videos, was die CPU Last hoch treibt. Werd ich auch mal weg lassen.

 

Packet loss etc ist alles im Rahmen. Wurde auch erst von nem Profi analysiert

Link to post
vor 1 Minute schrieb Gu4rdi4n:

Packet loss etc ist alles im Rahmen. Wurde auch erst von nem Profi analysiert

Das mit dem "im Rahmen" ist bei zeitkritischen Dingen wie Sensordaten, Sound etc. immer so eine Sache wenn es in "normale" IP-Pakete gepackt wird, in der richtigen Reihenfolge ankommen muss und nicht mit entsprechenden Protokollen priorisiert separat an allem vorbei läuft. Das ist halt relativ schwierig mit RDS/VDI über das normale LAN. Selbst die Provider kriegen das nicht immer sinnvoll hin, auch wenn die Sound-Streams nur ein paar KB's sind. :D

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...