Jump to content

RDS Zertifikat Probleme Session Hosts


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

ich habe eine neue RDP Umgebung mit folgenden Server aufgebaut.

 

1x Connection Broker, WebAccess

2x RDP Hostserver (LoadBalance)

 

ich habe die Umgebung komplett durchkonfiguriert, bis auf blöde Zertifikatswarnmeldungen funktioniert auch alles. Aber da komme ich einfach nicht weiter!

 

Ich habe bei unserer internen CA das WebServer Zertifikat geklont und entsprechend angepasst. Ich habe alle relevanten DNS Namen zuätzlich eingetragen, inklusive des LoadBalancing DNS Namens.

Dieses Zertifikat habe ich den Rollen auf dem Broker zugewiesen. WebAccess funktioniert ohne Probleme. Das Zertifikat habe ich auch auf den SessionHosts ebenfalls unter "eigene Zertifikate" hinterlegt.

 

Spreche ich nun per mstsc den RoundRobin DNS Namen an, kommt es für den SessionHost zu einer Zertifikatsfehlermeldung! Ich versteh es einfach nicht ;(

Link to post

Die Frage wäre, warum es zu einer Zertifikatsfehlermeldung kommt, wenn ich den RoundRobin DNS-Eintrag anspreche. Mein erstelltes Zertifikat habe ich entsprechend überall verteilt. Die DNS Namen ALLER relevanten Server sind als alternative DNS Namen im Zertifikat hinterlegt.

 

Ich habe die WebServer Vorlage entsprechedn dupliziert und dafür verwendet, natürlich habe ich als Erweiterung Serverauthentifizierung hinzugefügt.

 

Gehe ich per MSTSC direkt auf einen der Server, kommt keine Fehlermeldung.

Edited by Robinho1986
Link to post

Hi,

 

warum installierst du einen Broker und machst dann "DNS Round Robin"? Wenn du dich korrekt über den Broker verbindest und auf einen Session Host "gebrokerd" wirst, wirst du vermutlich auch keine Zertifikats-Warnung mehr haben.

 

Option 1) Verteile den RDWebFeed per GPO auf deine Clients und lass die User sich darüber verbinden

Option 2) Gehe immer über den WebAccess

Option 3) Gehe mit dem Firefox auf den WebAccess und nutze die heruntergeladene RDP Datei

Option 4) Erstelle eine RDP Datei mit dem Ziel "Connection Broker" und passe die RDP Datei im Editor an (“use redirection server name:i:1“ / "loadbalanceinfo:s:tsv://MS Terminal Services Plugin.1.<Name der Sammlung>")

 

Gruß

Jan

Link to post
vor 7 Minuten schrieb cj_berlin:

Weil das unter 2008R2 so war ;-) 

Früher war halt nicht alles besser. :-P Auch wenn damals™ Freibier noch fünf Mark kostete und Gummistiefel aus Holz waren.. ;)

 

vor 10 Minuten schrieb Robinho1986:

ja und da habe ich das zuletzt einen aufgesetzt! Nun läuft es! Vielen Dank!

SCNR: Vorheriges RTFM hilft häufig. Wer kann denn auch ahnen, dass sich nach mehr als 10 Jahren in der IT mal was ändert. ;)

 

Danke für die Rückmeldung und viel Erfolg!

Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...