Jump to content
Sign in to follow this  
MrB

Automatische Updates auf allen Clients funktionieren nicht mehr

Recommended Posts

Hallo und guten Tag

Ich hoffe, das ich bei euch Hilfe finde.

Ich habe auf unserem Server die Festplatten gewechselt um mehr Platz zu bekommen. Jetzt danach habe ich verschiedene Probleme mit Freigaben gehabt, wo die Rechte nicht mitkopiert wurden. Dies sollte jetzt ausgeräumt sein.

Problem ist aber immer noch, das keiner der Clients die Automatischen Updates ausführt. Ich habe schon versucht die GPO einfach mal umzustellen und wieder zurückzustellen. Leider kein Erfolg (  gpupdate per cmd versucht kein Erfolg).

 

Mit gpresult bekomme ich nichts, das auf die Updateeinstellungen hinweisen würde.

 

Wenn zusätsliche Infos von nöten sind bitte Fragen bin leider noch nicht so erfahren, was Server angeht.

 

Ps WSUS habe ich auch schon neuinstalliert aber keine Änderung

 

Share this post


Link to post
Share on other sites

Hi,

 

Zitat

Mit gpresult bekomme ich nichts, das auf die Updateeinstellungen hinweisen würde

Dann wird deine GPO am Client nicht gezogen. Ich nehme an, das du die Clients auch im WSUS nicht siehst.

Client und Richtlinie ist in entsp. OU zugewiesen?

Um welche Clients handelt es sich? Alles Windows 10?

 

Übersteuert evtl. eine andere GPO die Updateeinstellungen?

Hatte es zuvor funktioniert?

Nur aus Neugierde - wurde durch das Tauschen der Festplatten der Server neu installiert oder wurden "nur" die Datenplatten ausgetauscht? 

 

Gruß Sebastian

Share this post


Link to post
Share on other sites

Hallo danke für die schnelle Antwort

Rechner sind im WSUS sichtbar.

Clients sind gemischt WIN10 und WIN7 wobei der WIN10 ist recht unwichtig.

Die Platten enthalten nicht nur Daten sondern auch das System habe einfach die Platten getauscht und rebuild machen lassen.

Dann, weil nicht anders möglich nicht den vorhandenen Raid vergrößert sondern einen neuen erstellt.Wollte einfach die vorhanden Platten mit dem neuen Platz vergrößern war aber nicht möglich.

C: Server

D:Daten

E:Daten2

T:Daten(neu erstellt)

S:Daten2 (neu erstellt)

nach der Erstellung alle Daten rüberkopiert und Laufwerksbuchstaben angepasst, sodas alles wieder da ist wo es sein soll.

Ich weis sehr umständlich aber jetzt würde ich das anders machen.

Grüße Cord

 

PS hatte Probleme mit verschwundenen Rechten auf den Datenpartitionen kann das hier eine Rolle spielen ?

und der WSUS hat noch nix an Updates runtergeladen

 

Edited by MrB

Share this post


Link to post
Share on other sites

Hallo Cord,

 

wenn am Client nach Updates gesucht wird, erhälst du einen Fehler bzw. einen Fehlercode?

Bitte auch mal ins Eventlog des Clients einen Blick rein werfen.

 

Hast du am Client ggf. den "Klassiker" auch schon versucht?

Auszuführen in einer adminis. CMD.

net stop wuauserv
net stop bits
rename c:\windows\SoftwareDistribution SoftwareDistribution.bak
net start wuauserv
net start bits

 

Gruß Sebastian

Edited by Sanches

Share this post


Link to post
Share on other sites

Habe das probiert und mit gpupdate tatsächlich eine Änderung festgestellt (Testweise Automatische Updates auf 5 gestellt)

Aber bei händischer Suche bekomme ich WindowsUpdate_80244010

Was auch komplett fehlt scheint der Download vom Microsoftserver in dem nach der Installation neu zugewiesenen Ordner sind nur 2 Ordner aufgetaucht.

 

Cord

 

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb Sanches:

net stop wuauserv
net stop bits
rename c:\windows\SoftwareDistribution SoftwareDistribution.bak
net start wuauserv
net start bits

 

 

Das rename kannst Du dir sparen, ich hab noch nie jemanden gesehen der später das alte Verzeichnis wieder benötigt hat. Lieber gleich so:

 


rd /s /q %windir%\softwaredistribution

Wenn Du das alte Verzeichnis nicht löscht, schlummert wieder 1-2 GB auf der Platte sinnlos rum. ;)

 

Edited by Sunny61

Share this post


Link to post
Share on other sites

Du könntest noch das Rücksetzen des Authorisationscookies versuchen.

wuauclt /resetauthorization /detectnow

 

PS: Sunny hat Recht, das Verzeichnis schaut sich später weder einer an noch benötigt es einer noch - daher löschen.

 

 

Share this post


Link to post
Share on other sites

So nachdem ich das von Sebastian gepostete erledigt habe

22 hours ago, Sanches said:

net stop wuauserv net stop bits rename c:\windows\SoftwareDistribution SoftwareDistribution.bak net start wuauserv net start bits

war auf einem Rechner wieder ein Update auf anderen passierte auch heute Morgen leider nix.

Ich versuche jetzt erstmal die Ordner ( leider hat mein Vorgänger alles auf eine USB Platte ausgelagert) zu bereinigen hänge aber in der Luft, da ich nirgends sehen kann welcher Ordner für den contend zuständig ist. (Leider ist mein Wissen sehr rudimentär).

Ausserdem ist der WSUS Ordner jenseits 700 GB was jawohl auch nicht sein kann.

Habe den schon neu aufgesetzt und einen ganz anderen Ordner angegeben ist mir doch recht schleierhaft alles.

Habe jetzt heute morgen noch

19 hours ago, Sanches said:

wuauclt /resetauthorization /detectnow

ausgeführt und komme nicht mehr weiter, da er mir was von Server arbeitet noch eine frühere Konfigurationsänderung ab als Meldung anzeigt, wenn ich irgendwas ändern will.

 

Cord

 

Edited by MrB

Share this post


Link to post
Share on other sites

Hallo Cord,

 

ich kommt jetzt irgendwie nicht mehr ganz mit...

Ein Client lädt immer noch keine Updates? und dieser wurde dann neu aufgesetzt?

Aber 700 GB content (!) das ist dann eher der Server. Hast du dann den WSUS neu aufgesetzt? Oder den kompletten Server?

Was das jetzt noch mit der USB Platte auf sich hat, habe ich leider (in diesem Zusammenhang) noch nicht verstanden.

 

Da aber der Client im WSUS auftauchte und der Client die Updateprobleme hat, würde ich eher am Client weiter die Ursache suchen.

 

Gruß Sebastian

Share this post


Link to post
Share on other sites

Wenn das WSUS-Content 700 GB hat, solltest Du einfach mal in den Produkten und den Klassifizierungen prüfen, ob alles was eingestellt ist, auch benötigt wird. Sprachen werden gern auch übersehen, auch selbst prüfen.

 

Zusätzlich alte Updates manuell ablehnen. Servicepacks für Produkte die nicht mehr eingesetzt werden kann man auch ablehnen. Und unbedingt täglich eine Serverbereinigung ausführen. Auf https://wsus.de/scripts

findest Du 2 Scripte, eines davon einsetzen. Das räumt schon mal ordentlich frei.

 

Den Rest verstehe ich allerdings überhaupt nicht.

Share this post


Link to post
Share on other sites

Guten Morgen

ich versuche jetzt nochmal etwas Klarheit in die ganze Sache zu bringen.

Ich habe gestern den WSUS nochmal neu installiert wie hier beschrieben.

Danach habe ich den neu installiert alles auf dem immer noch vorhandenen Server ( kein extra Server für WSUS)

Rechner wurden erkannt scheinen aber keine Updates zu prüfen oder zu laden.

Die Auslagerung auf USB ist beendet (denke der Platz war alle, was auch der Grund war die HDD zu wechseln)

Jetzt stehe ich vor den tausenden Updates und weiß nicht was ich damit anfangen soll, alle ablehnen? alle zulassen ?

Die Klassifizierungen und Produkte habe ich erstmal so weit wie möglich eingeschränkt denke aber das ist ok so.

Ich bekomme auf meinem eigenen Client die unten angehängte Fehlermeldung ich versuche mit force die GPO zu erzwingen.

 

Ich hoffe, das war jetzt verständlicher und ich hoffe auf eure Hilfe

 

Cord

 

 

 

 

Ausschnitt.PNG

Fehler.PNG

Edited by MrB

Share this post


Link to post
Share on other sites

Man genehmigt nur die Updates, die auch von den Clients angefordert werden.

 

Was genau meinst Du mit der Auslagerung auf USB? Willst Du das Content des WSUS auf eine USB-HDD auslagern? Falls ja, das ist die schlechteste Idee die man haben kann.

 

 

EDIT: Was machst Du mit force auf deinem Client? Was genau gibst Du wo ein? Du sprichst sehr viel in Rätseln, das macht es nur unnötig schwerer dir zu helfen.

Edited by Sunny61

Share this post


Link to post
Share on other sites

Das mit dem Zusatz \force ist hier gefunden hat auch funktioniert jetzt( wollte gerade den Post vorher editieren)

 

Also schaue ich in die Berichte und genehmige von dort aus ? Habe hierzu 2 Bilder angehängt. 

Und der Rest ? Ablehnen über das Script ? 

18 hours ago, Sunny61 said:

Zusätzlich alte Updates manuell ablehnen. Servicepacks für Produkte die nicht mehr eingesetzt werden kann man auch ablehnen. Und unbedingt täglich eine Serverbereinigung ausführen. Auf https://wsus.de/scripts

findest Du 2 Scripte, eines davon einsetzen. Das räumt schon mal ordentlich frei.

 

Der content war bis gestern von meinem Vorgänger ausgelagert auf USB habe ich aber geändert ist jetzt auf einer eigenen Partition auf meiner HDD.

 

Die Rätsel beruhen nur auf meiner Unerfahrenheit denke ich wenn was unklar ist frage ab ich Antworte schnellstmöglich.

 

Und Danke für deine Geduld

 

Cord

 

updates.PNG.6f6008a095c762d2e25d5a26e239450d.PNG

neueupdates.PNG

Edited by MrB
Bild ersetzt

Share this post


Link to post
Share on other sites
vor 22 Minuten schrieb MrB:

Das mit dem Zusatz \force ist hier gefunden hat auch funktioniert jetzt( wollte gerade den Post vorher editieren)

 

Weißt Du denn genau was der Zusatz /force bedeutet? Bestimmt nicht. Einfach nur Anleitungen abarbeiten und nicht wissen was man tut, ist nicht besonders hilfreich. Ein GPO muss auch ohne /force übernommen werden, tut es das nicht, schau ins Eventlog oder mach einen Neustart. Und bei W10 hilft es immer den Schnellstart abzuschalten.

vor 24 Minuten schrieb MrB:

Also schaue ich in die Berichte und genehmige von dort aus ? Habe hierzu 2 Bilder angehängt. 

Und der Rest ? Ablehnen über das Script ? 

Es gibt auf der Startseite der WSUS-Konsole eine Ansicht: Für Computer erforderliche Updates. Die anklicken und die Updates genehmigen. Solange ein Update nicht genehmigt ist, wird auch nichts gedownloadet, also brauchst Du es auch nicht abzulehnen. Trotzdem sollte natürlich das Aufräumscript täglich laufen, es räumt ja auch ersetzte Updates auf.

Share this post


Link to post
Share on other sites

Ok dann mache ich die Genehmigungen und schaue was morgen gelaufen ist auf allen Rechnern.

 

Force ist für mich, das die Erneuerung erzwungen wird, wenn das Falsch sein sollte bitte ich um Berichtigung

 

Danke erstmal ich hoffe, das es jetzt wieder hinhaut

 

Cord

PS: Habe den WIN10 rausgenommen sind jetzt nur noch WIN7 Rechner über

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...