Jump to content
Sign in to follow this  
bits

RDS 2012 R2 Roaming Profiles zerschiessen sich - Error keine Schreibrechte

Recommended Posts

Guten Morgen Zusammen

 

Ich bin im Moment ziemlich ratlos zum Thema Roaming Profiles, die sich hie und da mal zerschiessen. Im Moment ist nur ein User betroffen.

 

Situation:

 

Zwei TS 2012R2 ein FileServer der auch TS Profile hat und ein Connection Broker (ist auch auf dem FileServer - war dazumal so Designed (kostengründen - ich finds ned so toll)).

 

- 2x 2012R2 RD Session Hosts

- 1x 2012R2 RD Connection Broker || RD Licensing || RD WebAccess (nicht in Verwendung) || RD Gateway || FileServer für Files und TerminalServer Profile (welche leider auch auch dem C:\shares\tsprofiles ist)

 

Meldet sich ein Benutzer an, kommt die Meldung:

 

image.png.43080fe60daa9e8ccb05bbe84c774d95.png

image.png.a7eabb5d0c80609e5765e0061ebc12c3.png

 

Interessant ist, dass es immer der gleiche User ist. Obwohl ich schon den Unser anstatt User1 neu mit User2 der dann genau 3 Monate lief. Nun haben wir uns entschieden wieder auf User1 zu gehen (natürlich heisst der Useraccount nicht so).

 

Was ich bis dato festgestellt habe bei einem anderen Kunden.

 

Auf Fileservern die noch Apps wie SQL drauf haben und viele Dateien, sind Roamingprofiles extrem anfällig auf Korruptionen. Ich denke es liegt an den I/O's, denn, ich habe dann einen Extra Server gemacht auf dem gleichen HyperV Host wo auch der Fileserver war, wo dieser "nur" TS Profile bedient (\\profileserver\tsprofiles$\%username%). Seit dem nie wieder Probleme.

 

Nur, ich habe keine Möglichkeit so auf die schnelle aus Kostengründen einen neuen zweiten Server hochzuziehen.

 

Wie sind da Eure Erfahrungen. Lese im Forum RoamingProfiles sind ned so toll? Ich hatte nie Probleme. Aber auch mit der Microsoft war ich bereits an diesem Case dran.

 

Fazit:

 

- Unklar woher das Problem kommt

- Verdacht und in einem Case bestätigt dass auf gut belasteten Fileservern wo eigentlich alles perfekt läuft mit Roaming Profiles Probleme entstehen (alle 1 Monate) -> Neuer TS Profiles Only Server brachte den Erfolg (I/O auf Dateisystemebene) - wohl..

- AntiVirus Ausschlüsse auf dem FileServer und \\fileserver\tsprofiles$\ vorhanden . Jedoch auf dem lokalen RDS Session Host Servern sind die C:\users "nicht" ausgeschlossen vom Virenscan (muss ja sein) - Bei meinem anderen Case brachte der Betrieb (testweise für 1 Woche (Besprechung mit MS)) auch nichts.

- Eventuell nur noch TSProfiles Server hochziehen. Am besten auf SSD Discs. Wir haben bei dem anderen Kunden wo ein eigener Server steht für TS Profile SAS Platten mit 10K. Zum Glück läuft es gut.

 

Wie macht Ihr das so?

 

Liebe Grüsse Bits

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Moin

 

Was ist das denn für eine Datei, wozu gehört sie, gehört sie überhaupt wirklich dazu? Gibt es die Datei bei anderen Usern auch oder nicht?

Share this post


Link to post
Share on other sites

Hallo Lefg

 

Danke für Deine Antwort.

 

Es ist teilweise gemischt. Mal hat er kein recht auf die Datei Mal auf die andere. Echt Wirr. Es lief 4 Jahre ohne jegliche Probleme. Auf einmal gings los. Suche noch weitere Infos.

 

Grüsse Bits

Share this post


Link to post
Share on other sites

Hallo,

soweit ich es verstehe, sind bei dir Fileserver (mit Profilen) und die Session Hosts in der gleichen Site und netzwerkseitig über LAN verbunden.

Ich würde folgende Schritte tun:

a. die Berechtigungen auf beiden Servern prüfen

b. vor der Anmeldung des besagten Users, prüfen ob bereits eine Session besteht

c. den Fileserver neu booten und prüfen, ob anschließend die Fehlermeldung erneut auftritt

d. prüfen, ob der Broker korrekt funktioniert

Share this post


Link to post
Share on other sites

Hallo Speer

 

Ich schaue dies gerne nochmals an. Sessions sind keine mehr offen. Aber ein guter Hint. Interessant ist, dass Microsoft nichts feststellen konnte mit den Logs der Server. Es geschieht bei gewissen Benutzern erst frühestens nach 2 Jahren mal.. Also soo selten, dass es schwierig wird das genauer unter die Lupe zu nehmen.

 

a: sind sind gleich die Berechtigungen, wir haben auf dem C:\users  nie was geändert, löschten sogar komplett das Profil auf beiden Ts über system settings. Da wird auch gleich der Registrykey mitgelöscht

b: haben wir darauf geachtet, war niemand angemeldet. Was interessant war ist, dass wenn eine Session hieng mit kaputtem Profil, mal wie eine "leere" Session war. Das war einmal.

c: Haben wir auch schon gemacht, nicht viel besser. Beim anderen Kunden haben wir die Situation im Griff auf dem neuen UserProfile Only Server. Weil der Fileserver zu überladen ist

d: Mache ich, hast da noch ein paar Tipps oder Erfahrungswerte (Tunings oder ähnliches)?

 

Grüsse bits

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...