Jump to content
peterg

Optimale Planung für den Einsatz physischer 10Gbit-Netzwerkkarten unter Hyper-V

Empfohlene Beiträge

Hallo,

 

ich war leider etwas unterwegs. Vielen Dank für die vielen Rückmeldungen.

 

Ich folge der Devise "je einfacher desto besser".

-> Ein Team aus den beiden 10-GbE-Ports

-> Team-Modus auf "Switch-independent"

-> Gigabit-Karten deaktiviert

 

Ich muss leider noch etwas nerven.

Ich würde echt gerne wissen, ob die 10Gb-Anbidung der Backup-NAS (in NAS SFP+Port mit einem 10G Base-T SFP Transceiver) an den 10G BASE-T Port vom Switch via CAT6a Kabel sauber funktioniert? Das Kabel ist nur max. 1m lang. Da habe ich keinerlei Bedenken.

 

Hat jemand so was schon mal gemacht?

 

Ich frage auch mal bei QNAP bzgl. der Kompatibilität des 10G Base-T SFP Transceiver nach.

 

Gruß,

Peter

bearbeitet von peterg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Nils,

ich bin nun so wie von Dir vorgeschlagen vorgegangen (hoffe ich). Ich bin mir aber nicht sicher, ob alles stimmt.

 

Vorgehen:
1. HOST komplett installiert und aktualisiert (noch ohne Hyper-V Rolle)
2. Ein NIC-Team der beiden LWL-NICs mittels PowerShell "New-NetLbfoTeam "NIC LWL-Team" erstellt -> TeamingMode: SwitchIndependent; LoadBalancingAlgorithm: Dynamic  -> Ist das ok?
3. Hyper-V Rolle installiert

4. Virtuellen Switch "vSwitch-Team" über den Hyper-V Manager erstellt. Hier "Externes Netzwerk" und als NIC "Microsoft Network Adapter Multiplexor Driver" (das ist das NIC LWL-Team") ausgewählt. "Gemeinsames Verwenden dieses Netzwerkadapters für das Verwaltungsbetriebssystem zulassen" habe ich NICHT aktiviert (siehe Anlage)
5. Dann den ersten virtuellen Netzwerkadapter für den HOST an den virtuellen Switch via PowerShell angebunden -> Add-VMNetworkAdapter -SwitchName “vSwitch-Team” -ManagementOS -Name “Host”
-> Aufgefallen ist mir, dass nun "Gemeinsames Verwenden dieses Netzwerkadapters für das Verwaltungsbetriebssystem zulassen" aktiviert ist (siehe Anlage)

6. Diesen virtuellen Netzwerkadapter für den HOST habe ich dann die HOST-IP-Adresse gegeben (manuelle IP-Konfiguration)
7. Dann habe ich schon mal die anderen virtuellen Netzwerkadapter für die VMs via PowerShell wie unter Punkt 5 angelegt (siehe Anlage).
Ist hier "Add-VMNetworkAdapter -SwitchName “vSwitch-Team” -ManagementOS -Name “xxxxxx” richtig?

Nun würde ich die erste VM installieren und dort als Netzwerkkarte die entsprechende virtuelle Netzkarte auswählen.

Habe ich das alles richtig gemacht?

Schöne Grüße
Peter

 

vSwitch anlegen.JPG

Virtueller Switch HOST_Eigenschaften.JPG

Virtuelle Netzwerkkarten.JPG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 11 Minuten schrieb peterg:

Verwenden dieses Netzwerkadapters für das Verwaltungsbetriebssystem zulassen" habe ich NICHT aktiviert (siehe Anlage)

Dann brauchst du aber weitere Netzwerkverbindungen im Host, und Nils hatte dir genau was anderes geraten soweit ich mich erinnere.

Und klar, wenn du dann managment-OS wieder hinzufügst ist logischerweise der Haken drin.

Warum erzeugst du für JEDE VM nen eigenen VSwitch? Weise doch sinnvollerweise den oben erzeugten vSwitch-Team den VMs direkt zu. Oder spricht da irgendwas dagegen? Siehst du bei deiner Konfiguration überhaupt noch durch? Ich habe da Zweifel. :)

 

Bye

Norbert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Norbert,

danke für die Rückmeldung. Ich habe gerade alle "ManagmentOS" NICs (bis auf die erste" wieder via PowerShell gelöscht.  Dachte mir schon, dass hier was nicht stimmt :-)

Eine "ManagementOS" NIC brauche ich doch aber. 
--> Soll ich die Managemnt NIC und den Switch "vSwitch-Team" löschen und den Switch mit der aktivierten Option "Verwenden dieses Netzwerkadapters für das Verwaltungsbetriebssystem zulassen " neu anlegen?

 

Erzeugt habe ich aber nur einen vSwitch, aber zu viele Management-NICs. Da hatte ich einen Denkfehler.

 

Gruß,

Peter

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ja logisch brauchst du eine, wie willst du sonst an den Host kommen. Deswegen kann man auch einfach den Haken setzen. Alternativ gehts sicher auch per VLAN auf dem Adapterteam, wenn deine Infrastruktur das zuläßt, Du hast doch oben selbst geschrieben, dass dein erster Befehl den Haken quasi per Powershell wieder gesetzt hat. 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Norbert,

 

ich habe jetzt die erste VM installiert und als Netzwerkadapter im Assitent für neue virtuelle Computer den "vSwitch-Team" gewählt.

 

Folgendes habe ich festgestellt:

Im Status der Netzwerkkarte vom HOST (vEthernet (Host)) steht als Übertragungsrate 10 GBit/s

Im Status der Netzwerkkarte vom der ersten VM steht als Übertragungsrate 20 GBit/s

 

Das Teaming wurde aus meiner Sicht richtig erstellt. Habe ich bei der Erstellung des Netzwerkadapters für den HOST was falsch gemacht?

 

Gruß,

Peter

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Na ja, dachte, dass in der Netzwerkkarte vom HOST (vEthernet (Host)) auch 20 GBit/s  stehen sollte.

Ich habe leider noch nie ein Teaming erstellt. Daher die Frage.

bearbeitet von peterg
Ergänzung

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

 

ich komm grad nicht ganz hinterher ... in deiner Frage mit den vielen Screenshots hast du aber einen Fehler gemacht. Die NICs für die VMs erzeugst du natürlich nicht auf dem Host, was soll der damit? Die gehören natürlich nur in die VMs und konnektieren auf den gemeinsamen vSwitch.

 

Wichtig: Sobald du mit komplexen vSwitch-Aufbauten arbeitest, geht das nur noch per PowerShell. Das GUI dann nicht mehr anfassen und auf keinen Fall dort etwas ändern. Das GUI ist nur für simple Aufbauten gedacht und kommt mit den erweiterten Optionen oder mit mehreren Host-vNICs nicht klar.

 

Gruß, Nils

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Nils,

danke für Deine Rückmeldung. Ich hatte da einen Denkfehler bei der NIC für den Host.  Es gibt aktuell nur eine virtuelle NIC für den Host (siehe Screenshots). Wie oben beschrieben habe ich das Team mit den beiden 10GB Karten via PowerShell erstellt und damit dann einen virtuellen Switch über den Manager für virtuelle Switche (nicht über PowerShell).

Dann habe ich via PowerShell die virtuelle NIC für den Host erstellt ( Add-VMNetworkAdapter -SwitchName “vSwitch-Team” -ManagementOS -Name “Host”).

Im Assistent für virtuelle Maschinen habe ich dann bei der ersten VM unter Netzwerk den virtuellen Switch ausgewählt. Die erste VM läuft gerade.

Soweit sollte doch alles passen oder? Hätte ich den virtuellen Switch auch über PowerShell anlegen sollen?

 

Einzig ist mir nun aufgefallen, dass

im Status der Netzwerkkarte vom HOST (vEthernet (Host)) als Übertragungsrate 10 GBit/s steht und

im Status der Netzwerkkarte vom der ersten VM als Übertragungsrate 20 GBit/s

 

Da ich noch nie was mit Teaming gemacht habe würde ich gerne wissen, ob ich doch irgendwas bei der Erstellung der virtuellen NIC für den HOST falsch gemacht habe oder noch irgendwo ein Haken gesetzt werden muss. Anbei ein paar Screenshot der NICs.

 

Gruß,

Peter

Netzwerkadapterübersicht.JPG

Eigenschaften NIC LWL-Team.JPG

Eigenschaften vEthernet Host.JPG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×