Jump to content
Sign in to follow this  
xtragood

OAL - AD Benutzer nicht vorhanden

Recommended Posts

Hallo,

 

ich habe eine sehr kniffelige Frage auf die noch niemand bisher eine Antwort hatte.

 

Unser OALGenerator meldet jede Nacht (oder auch beim manuellen generieren), dass die SMTP addresse eines Users nicht korrekt ist:

 

MSExchangeSA: OALGen will skip user entry <username> in address list \Global Address List because the SMTP address is invalid.

 

Dieser User existiert aber faktisch nicht mehr. Weder im AD ist dieser zu finden, noch gibt es ein Exchange Objekt (mailbox, contact) dazu. Wie kann also der Generator ein Objekt finden, das nicht mehr existiert?

 

 

LG

Share this post


Link to post
Share on other sites

Hallo Nils,

 

das kann ich mit "Nein" beantworten.

 

Ich habe auf allen unseren DCs das Kommando repadmin /removelingeringobjects mit der jeweiligen GUID des DCs und der korrekten DirectoryPartition in der der User vorhanden sein muss mit dem Switch /advisory_mode ausgeführt und keine Objekte gelistet bekommen.

 

Die Replikation scheint also ok.

 

 

LG 

Share this post


Link to post
Share on other sites

Nein das vom Exchange. Oder wer generiert bei dir die OAL? ;) Also im Exchange (welche Version eigentlich) mal das Diagnose Log für den OAB Prozess höher drehen.

 

Bye

Norbert

Share this post


Link to post
Share on other sites

Hallo,

 

auch mit Logging auf "Expert" loggt mit der MSExchangeSA noch die o.a. Fehlermeldung. Und leider sonst auch nichts neues dazu.

 

Hier nochmal der genaue Eventlog Eintrag:

 

Event Type: Error
Event Source: MSExchangeSA
Event Category: OAL Generator 
Event ID: 9325
Date: 08.05.2014
Time: 08:50:03
User: N/A
Computer: <SERVER>
Description:
OALGen will skip user entry '<USER>' in address list '\Global Address List' because the SMTP address '' is invalid. 
- Default Offline Address List 
 
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
 
 
LG

Share this post


Link to post
Share on other sites

Natürlich.

 

Aber diese Lösungen setzen alle voraus, dass es noch einen existierenden User oder Mailbox gibt. Das ist aber bei uns nicht der Fall.

 

 

LG

Share this post


Link to post
Share on other sites

Moin,

 

wie lange gibt es den betreffenden User schon nicht mehr? Liegt er evtl. noch als Tombstone vor?

(Nicht dass dort die betreffenden Attribute noch vorhanden sein sollten, und wenn, dann sollten sie natürlich nicht ausgewertet werden ... nur als Idee, es gibt ja die lustigsten Fehler.)

 

Andere Idee: Den User gibt es noch, ihr findet ihn nur nicht, weil die Objektberechtigungen das nicht zulassen.

 

Gruß, Nils

Edited by NilsK

Share this post


Link to post
Share on other sites

Hallo Nils,

 

wie würde ich einen Tombstone finden?

 

Ich habe mich noch mal als 1. Administrator nach dem User gesucht, aber auch nichts gefunden. Wie findet man denn einen User, bei dem der Zugriff zu Ansicht entzogen wurde?

 

 

LG

Share this post


Link to post
Share on other sites

Moin,

 

Tombstones kannst du am komfortabelsten mit dem AD Explorer ansehen. Sie liegen im Container "Deleted Objects".

 

[AD Explorer]
http://technet.microsoft.com/en-us/sysinternals/bb963907
 

Die Sache mit den Berechtigungen ist eher unwahrscheinlich. Als Domain Admin bzw. als "der" Administrator solltest du alle Objekte sehen. Das ließe sich zwar auch einschränken, aber nicht ohne Weiteres, also wohl kaum "aus Versehen". Zudem hättest du dann eine Reihe weiterer Probleme, die du sicher schon bemerkt hättest.

 

Ist jetzt auch alles nur ein Ratespiel. Wenn es da nicht weitergeht, wäre ein Microsoft-Case erwägenswert.

 

Gruß, Nils

Share this post


Link to post
Share on other sites

Wie heißt denn der User? Ist das Müller/Meier/Schulze, oder eventuell ein Systemkonto/Öffentlicher Ordner?

Edited by NorbertFe

Share this post


Link to post
Share on other sites

Moin,

 

Tombstones kannst du am komfortabelsten mit dem AD Explorer ansehen. Sie liegen im Container "Deleted Objects".

 

[AD Explorer]

http://technet.microsoft.com/en-us/sysinternals/bb963907

 

Die Sache mit den Berechtigungen ist eher unwahrscheinlich. Als Domain Admin bzw. als "der" Administrator solltest du alle Objekte sehen. Das ließe sich zwar auch einschränken, aber nicht ohne Weiteres, also wohl kaum "aus Versehen". Zudem hättest du dann eine Reihe weiterer Probleme, die du sicher schon bemerkt hättest.

 

Ist jetzt auch alles nur ein Ratespiel. Wenn es da nicht weitergeht, wäre ein Microsoft-Case erwägenswert.

 

Gruß, Nils

 

Es gibt dort ein paar User die mit CN=UserDEL:<GUID> ansonsten gibt es dort keinen Eintrag mit dem User. Der User ist ein selbst angelegter Service Account, also kein System-Konto/PF.

 

Die nächste Frage wäre, wird uns das Problem bei einer Migration von Exchange 2007 auf 2013 verfolgen, oder wird es damit gelöst? Ansonsten würde ich ein MS Call erwägen, richtig.

 

 

LG

Share this post


Link to post
Share on other sites

Moin,

 

da die Ursache des Problems unbekannt ist, kann man logischerweise auch nicht sagen, wie es gelöst wird und ob es durch eine Migration verschwindet ...

 

Gruß, Nils

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...