Jump to content
Sign in to follow this  
TomZe

ipv6 wird immer bevorzugt

Recommended Posts

Hallo Board! Muss mich mal wieder mit einer Sache melden, bei der ich nicht Zentral blicke:

 

UMGEBUNG:

Server: Windows 2000 Domäne, Windows 2000 DNS und DHCP ipv4

Client: Windows 7 Pro, akt. Patches bis 02.06.2010

 

PROBLEM:

Bei Pings auf das Notebook mit dem Namen NBXX antwortet die ipv6-Adresse und nicht die ipv4-Adresse, außer, ich gebe -4 an, dann klappt es.

 

SCHON VERSUCHT:

- ping auf die ipv4-Adresse funktioniert

- ping auf den Notebooknamen: bei Parameter "-4" ok, bei "ping nbxx" antwortet die ipv6-Adresse

- ipv6 bezieht die Adresse per DHCP; hier gibt es aber keinen ipv6-DHCP-Server!

- ipv6 ist an den Netzwerkadapter gebunden, deaktivieren der Checkbox hilft nicht weiter

- deaktivieren der Tunnelingadapter im Gerätemanager hilft komischerweise auch nicht weiter; es sind dann zwar die 6zu4-Adapter bei ipconfig /all verschwunden, das Problem existiert aber weiter; es antwortet auch dann die ipv6-Adresse ?! hmm...

- nslookups zeigen den korrekten DNS Server sowie die IPV6-Adresse des Notebooks

 

WEITERE INFOS:

- ich habe noch andere Win7-Clients hier, die kein esolchen Zicken machen. Dieses Gerät hier wurde von mir komplett von neu aufgesetzt. Bei den anderen Geräten läuft das vorinstallierte System.

- der Windows DHCP-Server läuft seit Jahren ohne Probleme ebenso der DNS

 

MÖGLICHE LÖSUNG:

bei "ipconfig /all" steht hinter dem ipv6-Adapter "(bevorzugt)"; der soll aber nicht bevorzugt sein, sondern die ipv4-Adresse soll bevorzugt sein.

Kann ich das mit netsh oder anders switchen? Bei XP pro gab es die Möglichkeit in der Netzwerkeinstellung die Reihenfolge der Bindungen zu ändern. Gibt es die Möglichkeit bei Win7 auch?

 

weiß schon, viel zu lesen!:)

 

Danke trotzdem und einen schönen Tag!

 

Tom

 

UPDATE: der Beitrag hier geht schon in die richtige Richtung:

http://www.mcseboard.de/windows-server-forum-78/ping-nur-v6-adressen-163956.html

Leider ohne Ergebnis.

Edited by TomZe
UPDATE

Share this post


Link to post

Hallo Nico,

 

ja, die Checkbox habe ich schon deaktiviert - bei jedem Adapter (auch wlan etc) ABER: für die Tunneladapter gibt es in der Netzwerkumgebung keine Adapter. Ich kann die Tunneladapter über den Gerätemanager deaktivieren (nachdem: Auch verborgene Geräte anzeigen i.ä. unter Ansicht). Erst nachdem ich hier die IP4To6-Adapter deaktiviert habe, werden diese unter ipconfig /all nicht mehr angezeigt; aber komischerweise antwortet auch dann noch auf Pings die ipv6-Adresse.

 

Nein, ipv6 wird nicht benötigt.

Share this post


Link to post

IPv6 kann man auch in der Registry ausschalten, dann isses 100% aus.

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TCPIP6\Parameters

 

Da einen neuen DWORD Eintrag Namens: DisableComponets und den Wert auf FF setzen.

Share this post


Link to post

Hallo,

 

in welcher Bindungsreihenfolge stehen IPv4 und IPv6 an der LAN Verbindung ?

 

Netzwerk & Freigabecenter -> Adaptereinstellungen ändern -> oben der Punkt Erweitert -> Erweiterte Einstellungen -> Unter Verbindungen LAN-Verbindung anklicken -> unteres Kästchen dann beachten ;)

Share this post


Link to post

Die Bindungsreihenfolge ist ipv4 dann ipv6.

 

Ich habe im Gerätemanager die IPv6-Komponenten deaktiviert - dürfte dem Vorschlag von "kleiner-romeo" entsprechen.

 

Ich beobachte, ob sich daher die Geräte vermehren oder ob sich die Bindung ändert.

 

Danke für die Hilfen!

 

Tom :D

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...