Jump to content
Sign in to follow this  
opp

NET SEND o.ä. dauert extrem lange - Namensauflösungsproblem??

Recommended Posts

Hi Leute,

 

Habe einen Windows2000AdvancedServer im netz, der auch als DHCP und Internetrouter läuft. WINS ist auch installiert, DNS auch, wobei DNS nicht eingerichtet ist.

 

Wenn ich jetzt zB eine NET-SEND nachricht von einem client an einen anderen schicken will, so dauert das sehr sehr lange (Vom ENTER-Drücken nach der 'Ausführen'-Eingabe "net send <name> <nachricht>" mindestens 20 Sekunden, was wirklich zu viel ist. Ich habe schon genügend Netzwerke mit mehr clients gesehen wo das sofort ging.

 

Ich kann mir gut vorstellen, daß nicht nur der NET-Send Dienst so lahm ist. Liegt es an der Namensauflösung?

 

Woran liegt das und wie kann ich es beschleunigen, beheben?

Share this post


Link to post

Hallo,

 

mache folgenden Test:

 

Net send >IP< und net send >Name der Workstation<

 

Wenn es über die IP wie gewohnt geht stimmt etwas mit der Namensauflösung nicht. Du kannst zum Test deine LMHOST mit einem Testeintrag versehen (Neustart nicht vergessen).

 

Gruß

Share this post


Link to post

ja, über die IP geht es sofort, hatte ich vergessen zu sagen, hatte ich schon probiert. Das mit der LMhost ist aber unelegant, die IPs werden ja dynamisch von einem DHCP zugewiesen. Wie kann ich eine Art dynamische LMHost ;) erzeugen?

 

Gruß, OPP

Share this post


Link to post

Hallo,

 

versuche es mit nslookup um dein Problem einzugrenzen.

 

nslookup >ip< oder mit >name< wenn du hier keine Fehler bekommst ist der DNS o.k., aber der WINS hat ein Problem.

 

ABER, nachdem was ich von deinem Problem gelesen habe, ist der WINS nicht richtig eingestellt.

 

Eine dynamische LMHOST gibt es nicht von MS, das kannst Du per Script machen. Ist sehr umständlich und im Server/ Client für W2k nicht so wichtig. Da der DNS unter W2k eher wie ein dynamischer-DNS arbeitet und die Aufgaben des WINS mit erledigen soll.

 

Gruß

Share this post


Link to post

ok, nslookup gibt eine fehlermeldung aus. Die Clients suchen den DNS auf dem Server, können ihn aber anscheinend nicht finden.

C:\>nslookup opp

*** Der Servername für die Adresse 10.0.0.1 konnte nicht gefunden werden:

Non-existent domain

*** Die Standardserver sind nicht verfügbar.

Server: UnKnown

Address: 10.0.0.1

 

*** opp wurde von UnKnown nicht gefunden: Server failed

 

Hatte nach dem Computernamen OPP gesucht ...

 

Wie richte ich kurz und knackig den Win2K-DNS so ein, daß die lookups zumindest von Name zu IP funktionieren? zu beachten ist hierbei, daß die IPs dynamisch vom DHCP zugewiesen werden.

 

Wäre für kurze Anleitung dankbar ...

 

Gruß, OPP

Share this post


Link to post

Hi!

 

Sehe mal in der Serverhilfe nach, ist dort gut beschrieben.

 

DHCP und DNS gehören einfach zusammen.

 

Wenn der DNS nicht richtig konfiguriert ist gibt es Probleme.

 

Sehe Dir auch die Einstellungen vom DHCP für DNS (Serveroptionen) an.

 

Günter

Share this post


Link to post

hallo,

 

dynam. lmhost? dafür ist ja wohl der wins-server da... wenn "net send" lang dauert, ist da mal nachzuschauen.

"nbtstat -r" zeigt an, wie's um die namensauflösung von netbios-namen aussieht, broadcast oder über ns. wenn der ns nicht richtig läuft... broadcast-auflösung dauert halt.

ach so, ab dem 2. "net send" sollte es dann schneller gehen, dann ist die adresse ja aufgelöst. ;)

 

gruß

Share this post


Link to post

hm es geht ab dem 2. Netsend zu PCs die nicht derselbe sind wie der sender nicht schneller .... wie richte ich den wins ein?

Share this post


Link to post

ich meinte eigentlich mit ab dem 2. net send denselben pc, aber ich dachte, das sei dir klar...

wins ist ja schon inst. und unter norm. umständen muß man da nicht noch groß aufwand betreiben. füg den wins-server halt noch an der dhcp-console für den entspr. adress-pool ein, damit das an die clients kommuniziert wird. im wins kannst du dann nachschauen, wer sich schon registriert hat.

ob die namensauflösung klappt, kannst du dann am client sehen (nbtstat -r)... siehe mein früheres posting.

Share this post


Link to post

Hi!

 

Du kannst an deinen Rechnern schrauben bis Du alt und grau bist, wenn DNS nicht richtig läuft geht nichts!

 

Welchen IP-Bereich benutzt Du?

 

Einen WINS einzurichten ist zwar nicht schlecht, aber Deine Clients suchen nach DNS!

 

Läuft AD?

 

Günter

Share this post


Link to post

einen dhcp auzusetzen und dann keinen DNS ist eigentlich nicht

gerade schlau. Denn windows netzwerke sind IMHO nicht gerade intelligent, schon gar nicht was die Namensauflösung betrifft.

Wenn du nen AD laufen hast frag ich mich eh wie das ohne DNS geht.

Also bau die schnell nen DNS und dann passt das auch.

Share this post


Link to post

jut daher wollt ich ja DNS einrichten :)

 

Benutze den IP-Bereich 10.0.0.1 - 10.0.0.255 auf SNM 255.0.0.0 (wird vom DHCP zugewiesen).

 

Habe KEIN ActiveDirectory drauf, bin kein wirklicher Freund davon.

 

Kannst du mir helfen?

 

Gruß, OPP

Share this post


Link to post
Original geschrieben von AinSon

einen dhcp auzusetzen und dann keinen DNS ist eigentlich nicht

gerade schlau. Denn windows netzwerke sind IMHO nicht gerade intelligent, schon gar nicht was die Namensauflösung betrifft.

Wenn du nen AD laufen hast frag ich mich eh wie das ohne DNS geht.

Also bau die schnell nen DNS und dann passt das auch.

 

ähm, er schrieb doch, daß dns nicht konf. ist, also ist dein kommentar zu ad ziemlich überflüssig, denn das geht nicht, ohne daß dns konf. ist.

und dns hat damit auch nicht so wirklich was zu tun, denn hostnamen (dns) haben nicht unbedingt was mit computernamen (wins, netbios) zu tun. welchen zusammenhang du zwischen dhcp und dns siehst, kann ich auch nicht ganz nachvollziehen - die dienste laufen ziemlich unabhängig voneinander.

damals (unter nt) war dns noch nicht gerade gängig weil statisch. da lief aber die namensauflösung mit wins ziemlich prima... das zum thema windows netzwerke.

 

gruß

Share this post


Link to post

hmm...ich hab noch nie einen MS-DNS aufgesetzt, sofern du das vor hast. Ich kann dir nur sagen, dass es generell so laufen muss, dass der DHCP sich mit einem Schlüssel beim DNS authentifiziert und dann die Rechner dort einträgt. Dynamisch halt....so gehts beim bind9.

vielleicht hilft dir das trotzdem ein wenig

Share this post


Link to post

Hi!

 

Der DHCP möchte die Clients dynamisch in DNS einbinden.

 

Also nochmal!

 

OHNE DNS GEHT NICHTS!

 

Wir schreiben hier über W2K und nicht NT4!

 

Wie schon oben geschrieben: ein Blick in die Serverhilfe.

 

Dann einfach machen!

 

Vieles erklärt sich von selbst und bei Probs. einfach posten.

 

Günter

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...