Jump to content
Sign in to follow this  
Dschonny

verdrehte Laufwerksbuchstaben

Recommended Posts

Wie in nem anderen Thread schon beschrieben, ist mein System vorgestern etwas, nun ja , äh, ausgebrannt. Habe nun also n neues Mainboard und ne neue CPU eingebaut. Da ich nach dem Boardwechsel ja eh mein OS neu installieren muss, habe ich auch gleich noch ne neue Platte mit eingebaut und wollte diese eigentlich nun als meine C:\Platte verwenden. Also die neue Platte als Master eingebaut, die alte als Slave drangehängt und von der XP-CD gebootet, von dort Platte formatiert und XP installiert.

Die alte Platte hatte vier Partitionen (C-F), die neue hat nur eine.

Nach der XP-Installation hab ich jetzt allerdings die alten Laufwerksbuchstaben auf der alten Platte, G ist das DVD-LW und die neue Platte hat H:. Ich hätte aber gerne wieder C: als Systemlaufwerk. Wie kriege ich das denn jetzt hin? Könnte ja einfach die LW-buchstaben mit Partition Magic tauschen, allerdings verweisen doch w*****einlich schon Millionen und Abermillionen von Registry-Einträgen auf die H:-Platte. Erledigt der DriveMapper von PM das dann zuverlässig oder muss ich danach besser nochmal neu installieren? Habe bisher nur die GrundInstall von XP durchgeführt, wäre also nicht ganz so tragisch. Hat da jemand Erfahrung oder nen anderen, besseren Tipp?

 

Sorry für die langen Ausführungen...

 

Danke schonmal.

Gruß,

Dschonny

Share this post


Link to post

Hi,

 

kenne das Problem ;)

Ich habe keine nachträgliche Lösung für das Problem gefunden.

Daher habe ich mein XP ohne die zweite (alte) Platte installiert und erst später, nach der Installation, die Platte wieder hinzugefügt.

 

Das ging dann.

 

Gruß,

 

Roi Danton

Share this post


Link to post

Software ist ... fehlerhaft - das sah ich beim Lesen des Beitrags: @Dschonny war sehr fleißig.

 

[Edit] Ich wollte eine Grafik anhängen - es funktioniert nicht.

 

... hier stand einmal eine eingebundene Grafik ...

 

[Noch ein Edit] Jetzt funktionierts - soviel zu Software-Bugs

 

[Edit 3] Soeben habe ich - 22:50 - meine Grafik wieder entfernt - it's not a bug, it's a joke! Immerhin bin ich drauf reingefallen.

Share this post


Link to post

Mal zum Thema...

 

Setup "merkt" sich die Laufwerksbuchstaben, d.h. am Anfang, wo du ie Partition auswählen kannst, in die du installieren willst, werden Laufwerksbuchstaben festgelegt - auch wenn du Setup aus einem alten Windows raus startest.

 

Das ganze wird aber nur in irgendeine ini- (oder inf- ?) Datei geschrieben, die dann nach dem ersten Reboot, wo nur die wichtigsten Install-Dateien kopiert werden wieder eingelesen wird. Die liegt meist auf C:, wo genau steht kurz vorm Reboot in der Boot.ini...

 

Also neu installieren wirst du wohl müssen, um den Systemlaufwerksbuchstaben zu ändern, dann entweder

 

- diese Datei manipulieren, bevor Setup nach dem Reboot Setup weiterläuft oder

 

- beim Booten/Installieren direkt von CD einfach die andere Platte abklemmen. Hier bringt das Setzen auf "None" im BIOS nix, Setup erkennt die trotzdem. Also da hilft nur Controller im BIOS deaktivieren, sofern die neue Platte da nicht mit dranhängt oder halt Stecker der alten Platte so lange ziehen... Wenn du den Controller deaktivierst, nach dem ersten Reboot wieder aktivieren (da ist diese Datei dann "sauber"), damit er im neuen System dann auch drin ist (Hardwareerkennung...)!

 

 

Grüße,

SIGSEGV

Share this post


Link to post

@Roi Danton

 

Yep! Könnte aber ja sein, dass man die alte Platte oder zumindest eine der 4 Partitionen bei der Installation braucht, weil da z.B. irgendwelche Daten (wie Treiber etc.) drauf liegen...

 

Kurz: Man _muss_ die zweite Platte nicht "abklemmen", aber es ist wohl das einfachste, wenn man sie nicht braucht...

 

btw: Suche aber auch immer noch nach einer _eleganten_ Lösung das ProgramFilesDir schon bei der Installation woanders hinzulegen als nach %SystemDrive%\Programme... Bei "Dokumente und Einstellungen" kein Problem, aber das "Programme" muss man umständlich über Registry-Gefrickel umbiegen - und dann drauf warten, dass das irgendeinen Installer gar nicht juckt, der dann wieder freudig nach "C:\Program Files" installiert:-/

 

Irgendwelche Ideen dazu?

 

Grüße,

SIGSEGV

Share this post


Link to post

naja, ich habs dann auf dem umständlichen wege gelöst, neu installiert mit abgezogener 2. Platte, dann hatte mein CD-Rom bloß leider den Buchstaben D belegt und wollte da auch nicht mehr von weg, also dachte ich, ohne CD-Rom starten und die LW-Buchstaben mit Partition Magic zuordnen, das mochte allerdings meine Platte nicht und hat immer nur 'BAD' als eine Riesen-Partition angezeigt, also nochmal ins WinSetup, alle Partitionen auf der 2. Platte dort gelöscht, ohne CD-LW wieder gestartet, mit PM die Partitionen eingerichtet und dann das CD-LW wieder angehängt... war zwar ziemlich umständlich, aber jetzt ist's wenigstens so wies sein sollte...

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...