Jump to content
Sign in to follow this  
pablovschby

WINS/DNS-Probleme: Entweder WINS sauber zum laufen bringen oder ganz deaktivieren?

Recommended Posts

Hallo liebes Forum

Unsere Mitarbeiter beklagen sich hier über ein langsames Netzwerk. Vor allem zeigt es sich, wenn man über den Windows Explorer auf Server-Shares browsed. Nun gut. Erstmal möchte ich absichern, dass auf dem Server sicher alles gut läuft. Ich habe keine Warnungen oder Errors mehr im Eventlog.

Ich habe auch google abgesucht, aber keine hier passende Lösung gefunden.

 

Ich gehe also davon aus, dass es sich um ein DNS- oder WINS-Problem handelt. 2 Möglichkeiten:

 

 

1. Möglichkeit: WINS/Netbios sauber zum laufen zu bringen.

Wenn ich auf dem (einzigen) Domain Controller (2k3 Standard SP264Bit, auch DHCP- und DNS-Server) ein dcdiag laufen lasse > alles passed

Wenn ich aber ein netdiag laufen lasse, kommt mir folgende Meldung:

 

WINS service test. . . . . . . . . . : Passed

 

NetBT name test. . . . . . . . . . : Passed

[WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.

 

 

Okay. Als primärer WINS-Server ist auf dem DC als 1. 127.0.0.1 und als 2. %IP des DCs% eingegeben. "Enable LMHOSTS lookup" ist angekreuzt. Netbios-Einstellung: Default...usw netbios settings from DHCP-Server

 

Auf dem DHCP-Server ist die IP %IP des DCs% als WINS-Server konfiguriert und als "046 WINS/NBT Node Type" der Wert 0x8 angegeben. Auf dem DHCP-Server sind eingetragen als DNS: 1.%IP des DCs% 2.1.öff.DNS-IP 3. 2.öff.DNS-IP .

 

Der Service "Workstation" läuft sowieso auf dem DC. Komischerweise bleibt aber die Meldung oben "[WARNING] You don't have a single interface.... <03> 'Messenger Service'..." bei Eingabe von "netdiag" weiterhin, auch wenn ich den Service "Messenger" auf dem DC (zum Test nur) gestartet habe.

 

Was kann ich da noch tun, damit dieser Service sauber läuft?

 

 

2. Möglichkeit: WINS und Netbios einfach deaktivieren.

So wie mir bekannt ist, scheint WINS nicht nötig zu sein in einer (ab Win2000 aufwärts-kompatiblen) AD-Domäne. Kann ich problemlos den ganzen Service einfach deaktivieren, nachdem ich auf dem DHCP die Scope-Options "044 WINS/NBNS Servers" sowie "046 WINS/NBT Node Type" gelöscht und den WINS in den TCP/IP-Einstellungen des DCs herausgenommen habe? Alle Clients arbeiten mit Windows XP Service Pack2.

 

Abklärungen, ob andere Software, die auf dem Server läuft, WINS benötigen, sind im Gange.

 

 

Besten Dank fürs Lesen.

Einen schönen Tag

Pablo

Share this post


Link to post

Moin,

 

faq-o-matic.net Wie sollte WINS konfiguriert werden?

 

faq-o-matic.net Brauche ich noch WINS, wenn ich ein AD betreibe?

 

Nimm mal die 127.0.0.1 raus. Wenn du sowieso nur einen WINS-Server hast, trage nur die eine "richtige" IP-Adresse ein. Sorge darüber hinaus dafür, dass alle anderen Rechner auch diesen WINS-Server nutzen.

 

Gruß, Nils

Share this post


Link to post
Nimm mal die 127.0.0.1 raus. Wenn du sowieso nur einen WINS-Server hast, trage nur die eine "richtige" IP-Adresse ein. Sorge darüber hinaus dafür, dass alle anderen Rechner auch diesen WINS-Server nutzen
Hallo Nils.

 

Besten Dank für die Links, habe sie gelesen. Etwas widerspricht sich aber deinem Post:

 

Also ich sollte generell auf allen Clients den WINS-Server mit seiner "richtigen IP" eintragen. Und auf dem WINS-Server selbst aber die 127.0.0.1 als einzigen WINS-Server (laut deinem Link) oder seine "richtige IP" (laut deinem Post)?

 

 

Und wie bringe ich das hier weg? Weiss das ev. jmd.?:

[WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.

 

 

Okay, danke... bis auf diese Kleinigkeit sind die ganzen Einstellungen genau wie vorher und damit kann ich das Serverproblem ausschliessen, wenn ich jetzt noch Sonntag morgen um 05:00 Uhr einen Task Schedule, der mir die DHCP- und WINS-Datenbanken bereinigt.

 

Danke & Gruss

Pablo

Share this post


Link to post
Hallo Nils.

 

Besten Dank für die Links, habe sie gelesen. Etwas widerspricht sich aber deinem Post:

 

Also ich sollte generell auf allen Clients den WINS-Server mit seiner "richtigen IP" eintragen. Und auf dem WINS-Server selbst aber die 127.0.0.1 als einzigen WINS-Server (laut deinem Link) oder seine "richtige IP" (laut deinem Post)?

 

Wo steht in dem Link, dass du die 127.0.0.1 eintragen sollst?

 

Bye

Norbert

Share this post


Link to post
Wo steht in dem Link, dass du die 127.0.0.1 eintragen sollst?

 

Bye

Norbert

Der WINS-Server muß in seiner Netzwerkkonfiguration auf sich selbst (und nur auf sich) selbst zeigen.

 

Entschuldigung, das habe ich falsch interpretiert. Natürlich.

[WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.
Was kann ich da noch tun? Wenn ich den "Messenger" service auf dem WINS-Server temporär aktiviere... erscheint diese Meldung auch und der "Workstation" service läuft sowieso.

 

Gibt es da noch was, was ich machen könnte?

 

Danke euch

Pablo

Share this post


Link to post

Kann man da nix mehr machen?

 

Gibts es keine Netzwerktest-tools für WINS und/oder DNS?

 

Hmmm... muss man da wirklich über einen Netzwerksniffer gehen? *arg*

 

gruss&thx

Pablo

Share this post


Link to post
Moin,

 

dies hast du schon durchgesehen?

netdiag You don't have a single interface - Google-Suche

 

Gruß, Nils

Ja, alles schon durchgemacht.

 

Auf WINS-Server ist der Registry-Eintrag "IsDomainMaster" auf "True" und "MaintainServerList" auf "Yes". Auf dem anderen Server (nicht WINS-Server) ist "IsDomainMaster" auf "False" und "MaintainServerList" auf "Auto".

 

... siehe hier

 

Richtig, oder?

 

 

Also da gibts nichts mehr zu machen? Niemand eine Idee, wie ich die Meldung von netdiag lösen kann?

Share this post


Link to post

Tut mir nochmals leid, muss da noch nachhaken:

[WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.
Ich habe jetzt einiges durchsucht und ich finde diese Option einfach nicht, auch nicht in den Netzwerkeinstellungen.

 

Wo muss/kann ich ein "single interface" mit den "Workstation Service", "Messenger Service" und "WINS" Namen definieren?

 

Keiner eine Ahnung... hmmmm? :confused:

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...