Jump to content
Sign in to follow this  
phoenixcp

Installation eines MSI-Paketes

Recommended Posts

Hallo Gemeinde

 

Ich habe hier ein kleines Problem:

 

Ich will ein MSI installieren, bekomme aber folgenden Fehler vor die Füße geworfen:


MSI (c) (64:70) [11:51:34:917]: Note: 1: 2720 2: 2
Systemrichtlinien verhindern diese Installation. Wenden Sie sich an den Systemadministrator.
[/Code]

 

in einem weiteren Log ist von Error 1625 die Rede.

 

Laut AppDeploy > Windows Installer Errors > Error 1625 ist dafür wohl die dort benannte Policy verantwortlich.

 

Laut MS-KB (http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/92832.mspx?mfr=true) habe ich den entsprechenden Regeintrag geprüft, der nicht vorhanden ist. Damit würde gelten:

The policy is disabled or not configured. Users can search for installation files. The Browse button is disabled only when non-Administrators are using system permissions to install programs.

[/Quote]

 

Somit fällt für mein Problem die entsprechende Policy aus dem Kontext. Welche könnte evtl. noch zutreffen? Weitere Verdachtskandidaten?

 

Bei dem System handelt es sich um Win XP SP2, aktueller Patchstand. MSI Installer 3.0.

Share this post


Link to post
Share on other sites

Die habe ich ja. Aus denen habe ich ja genau diese Infos. Wir sind dem Problem grade ein Stück weiter auf die Spur gekommen. Ein Kollege hat aus Spaß ein blankes XP SP2 ohne weitere Patches genommen. Und voila: Dort geht es.... Jetzt heißt es also: jeden Patch seit SP2 prüfen, welcher der Verantwortliche ist und dann evtl. nen Workaround bauen...

 

Zum Glück gibts da nicht so viele Patches... *heul*

Share this post


Link to post
Share on other sites
Die habe ich ja. Aus denen habe ich ja genau diese Infos. Wir sind dem Problem grade ein Stück weiter auf die Spur gekommen. Ein Kollege hat aus Spaß ein blankes XP SP2 ohne weitere Patches genommen. Und voila: Dort geht es.... Jetzt heißt es also: jeden Patch seit SP2 prüfen, welcher der Verantwortliche ist und dann evtl. nen Workaround bauen...

 

Da würde ich gleich mal den aktuellen Installer ausprobieren: Downloaddetails: Windows Installer 3.1 Redistributable

Das ist eines der ersten Updates, die ein blanker XPSP2 Client verpasst bekommt. Ob WU oder WUSS ist dabei ziemlich egal.

 

EDIT: Der IE7 flasch konfiguriert könnte auch eine Ursache sein.

Share this post


Link to post
Share on other sites

Der 3.1er Installer wird hier nicht verteilt, auch IE7 ist hier noch nicht am Start. Für die Updates sowie die restlichen SW-Installation setzen wir hier eine Softwareverteilungsengine ein. Somit ist steuerbar, was auf den Maschinen ankommt und was nicht.

Share this post


Link to post
Share on other sites

OK, dann hast Du ja schon 2 evtl. Ursachen weniger. Machts aber trotzdem nicht leichter. Viel Erfolg. ;)

 

Was genau verteilst Du denn da? Und wie mit was verpackt?

Share this post


Link to post
Share on other sites
OK, dann hast Du ja schon 2 evtl. Ursachen weniger. Machts aber trotzdem nicht leichter. Viel Erfolg. ;)

 

Danke

 

Was genau verteilst Du denn da? Und wie mit was verpackt?

 

Aus gewissen Gründen hast du die Antwort als PN vorliegen. Danke für dein Verständnis.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...