Jump to content
Sign in to follow this  
MurphY MacManus

Ati-Treiber und Vista

Recommended Posts

Hallo Leutz,

 

ich hab mir vor kurzem einen neuen PC komplett selbst zusammengestellt. Dieser PC hauptsächlich aufs Zocken ausgelegt.

 

Kurz zur HW:

ASUS Blitz Extreme Mainboard

Intel Core2Duo E6750

PowerColor ATI Radeon HD3870 512MB

Kingston DDR3-Speicher 2GB (2x 1GB)

2x 500GB S-ATA2 Festplatten die im RAID1 (wird noch auf Matrix RAID geändert :D ) laufen.

 

Betriebssystem: Vista Ultimate 32bit

 

Ich bin jetzt schon zum 3. mal am Neuinstallieren und es treibt mich in den Wahnsinn!!!

Es ist so dass ich den aktuellen Catalyst-Treiber von ATI verwendet habe. Jedoch hatte ich immer ein Problem unterm zocken (Crysis, Call of Duty 4):

 

Wenn man in den oben genannten Spielen schnell mit der Maus hin und herfährt hat man an den meisten Objekten eine Art grünen Schleier der sich über die Objekte / Figuren zieht. Kommt die Maus wieder zum stehen sieht alles wieder normal aus jedoch nach 5-30 Min stürzt das Spiel dann ab und ich lande auf dem Desktop mit der Fehlermeldung: Der Anzeigetreiber atimdag.xxx reagiert nicht mehr und wurde erfolgreich wiederhergestellt.

 

Andere bzw weniger Leistungsfressende Spiele wie z.B. Command&Conquer 3 laufen stundenlang einwandfrei und dort hab ich auch keine Abstürze o.Ä.

 

Temperatur scheint OK und konstant. Stromprobleme konnte ich nicht ausschließen jedoch hab ich ein nigelnagelneues 520W Netzteil und bin der Meinung das sollte auch ausreichen.

 

Windows-Update versucht. Kein erfolg. Google durchforstet, keine relevanten einträge gefunden.

 

Ich hab dann als letzte Möglichkeit versucht den ATI-Treiber zu deinstallieren (über Geräte-Manager -> Deinstallieren. Habs auch mit dem normalen Weg über Systemsteuerung versucht da werden die Komponenten aber nicht angezeigt). Danach hab ich den DriverCleaner drüberlaufen lassen um alle anderen ATI-Applikationen und Registryeinträge zu entfernen. Jetzt wenn ich versuche einen älteren Treiber zu installieren kommt die Meldung -> Die Installierten Komponenten sind auf dem neuesten Stand. Das selbe dann auch wieder mit dem aktuellsten Treiber. Ich kann die ATI-Software (DisplayDriver, Catalyst Control Center usw.) nicht mehr installieren..

 

zum ****en! Hab dann versucht zumindest den DisplayDriver manuell (über im Paket enthaltene ini Dateien) zu installieren. Dort werden aber nur ältere Modelle angezeigt. meine HD3870 fehlt. Jetzt läuft mein System mit dem Treiber für die 2900XT, den ich willkürlich aus der Liste gewählt habe. So wird die Grafikkarte nun auch im Geräte Manager angezeigt als 2900XT. PC läuft aber meine Games haben immer noch die selben Probleme!

 

Ich seh mich schon wieder am Neuinstallieren...

Habt ihr Tipps für mich was ich noch versuchen kann oder was muss ich tun damit ich wieder frei von sämtlichen Treiberresten bin so dass der PC meine Grafikkarte wieder als HD3870 erkennt?

 

Sollt ich in meiner Wut irgendwas vergessen haben zu erwähnen einfach nachfragen ;)

 

Peace

MurphY

Share this post


Link to post
Share on other sites

Hallo,

 

soviel zu Vista... teste es doch mal gegen mit xp... damit kannste wenigstens einen hardwarefehler aussschließen.

 

bei nvidia kannst du z.b. auch beta treiber für die graka laden. kA wie es bei ati ist. mir hat das auch schon mal geholfen.

 

gruß

elendil

Share this post


Link to post
Share on other sites

Ich habs sowohl mit Crysis-Patch probiert als auch ohne (nach neuinstallation des Rechners)

 

Es gibt auch von Microsoft einen Patch der irgendwie die Abstürze bei den Spielen verhindern soll. Tut er aber bei mir nicht...

 

Verwendete Catalyst version ist 8.1 (vom 16.01.08)

 

Eigentlich wollte ich XP vermeiden da ich gern Directx 10 nutzen würde und ich bin mir ziemlich sicher dass es kein Hardwareproblem ist. Mit allen anderen Spielen / Anwendungen habe ich keine Probleme läuft alles einwandfrei...

 

Jetzt wart ich hier noch ein paar tipps ab und sollte ich dann immer noch nicht weiterkommen installier ich XP...

 

Grüße,

 

 

edit: sorry hab mich verlesen gulp...es gibt für vista einen crysis patch das hat aber mit dem graka-treiber an sich nix zu tun. Gibts wirklich einen Catalyst mit einem Crysis patch?? Kannst du mir evtl. den Link schicken dann kann ich sagen ob ich den schon versucht hab. Nicht das wir aneinander vorbeireden ;)

Share this post


Link to post
Share on other sites

Es gibt für den Catalyst 7.10 einen seperaten Crysis Patch ....

 

Hast Du denn schon mal die Treiber der 7er Serie (7.10-7.12) ausprobiert?

 

Ist Deine 3870er eventuell eine für den AGP Port, denn da gibt es Probleme mit den ATI Treibern, die funktionieren meistens nur mit den Herstellertreibern.

 

Grüsse

 

Gulp

Share this post


Link to post
Share on other sites

nein ich hab bisher nur den neuesten treiber (8.1) verwendet!. und meine graka ist pci-express! nix mehr agp-port ;)

 

ich wollte ja den 7.10er installieren aber da schimpft die ati installation immer das meine treiber auf dem neuesten stand wären!

 

selbst wenn ich die graka im geräte manager deinstallier und zusätzlich noch alle treiberdateien mit drivercleaner lösch bringt er mir die meldung...

 

gruß

Share this post


Link to post
Share on other sites

hier mal ein error-log von einem call of duty 4 absturz:

 

Protokollname: Application

Quelle: Application Error

Datum: 01.02.2008 18:58:58

Ereignis-ID: 1000

Aufgabenkategorie:(100)

Ebene: Fehler

Schlüsselwörter:Klassisch

Benutzer: Nicht zutreffend

Computer:

Beschreibung:

Fehlerhafte Anwendung iw3sp.exe, Version 0.0.0.0, Zeitstempel 0x47044075, fehlerhaftes Modul iw3sp.exe, Version 0.0.0.0, Zeitstempel 0x47044075, Ausnahmecode 0xc0000005, Fehleroffset 0x002033fd, Prozess-ID 0x1608, Anwendungsstartzeit 01c864fa4ad73b9a.

Ereignis-XML:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="Application Error" />

<EventID Qualifiers="0">1000</EventID>

<Level>2</Level>

<Task>100</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2008-02-01T17:58:58.000Z" />

<EventRecordID>1425</EventRecordID>

<Channel>Application</Channel>

<Computer></Computer>

<Security />

</System>

<EventData>

<Data>iw3sp.exe</Data>

<Data>0.0.0.0</Data>

<Data>47044075</Data>

<Data>iw3sp.exe</Data>

<Data>0.0.0.0</Data>

<Data>47044075</Data>

<Data>c0000005</Data>

<Data>002033fd</Data>

<Data>1608</Data>

<Data>01c864fa4ad73b9a</Data>

</EventData>

</Event>

 

Natürlich immer wieder mit der Meldung "Der Anzeigetreiber atimdag reagiert nicht mehr blablabla..."

 

Ich konnte wenigstens wieder den aktuellen Catalyst installieren so dass vista wieder meine HD3870 erkennt! Das Treiberproblem ist gelöst, die Ursache der Abstürze besteht weiterhin...so ein mist...

 

peace

MurphY

Share this post


Link to post
Share on other sites

Hmmm, die Fehlermeldung bei CoD4 erinnert mich an eine Realtek Soundkarte, die hat die gleiche Meldung ausgespuckt .....

 

Ich habe zumindest bei mir kein Problem mit CoD (weder mit der alten X1600 XT noch mit der jetzigen 8600 GT - auch wenn letztere nicht von ATI ist) und Vista ....

 

ATI hat doch auch so ein Aufräumutil in deren Downloadbereich, das würde ich zumindest 3rd Party Cleanern vorziehen, die kennen ihren Krempel einfach besser als andere.

 

Grüsse

 

Gulp

Share this post


Link to post
Share on other sites

also kurzer zwischenbericht vom wochenende:

 

die grafikkprobleme unterm spielen sind weg. fragt mich nicht warum aber das hat irgendwie mit meinem 22" monitor zu tun. sobald ich die graka über HDMI an meinen LCD-TV anschließ hab ich keine grafikfehler mehr.

 

die abstürze kommen weiterhin nach 10-30 minuten. ich werd heut abend mal crysis ausprobieren dort hab ich nämlich ne andere fehlermeldung und werd sie hier posten!

 

das mit dem omega treiber liest sich auch gut das werd ich auch probieren und hier das ergebnis posten..

 

aber schonmal danke für eure hilfe...

 

peace

MurphY

Share this post


Link to post
Share on other sites

so leutz das problem wird wieder aktuell:

 

ich habe jetzt nach mittlerweile 2-monatigen recherche herausgefunden dass vista den treiber killt und wiederherstellt sobald die framerate unter 20 fps sinkt. vista denkt wohl der graka treiber hätte sich dann aufgehängt und killt den prozess. dass da jedes game bei diesem vorgang abstürzt ist wohl nicht weiter zu erwähnen.

 

das erklärt auch warum weniger grafikbelastende games wie C&C3 einwandfrei laufen. wenn ich bei crysis die details runterdrehe läuft es auch wesentlich länger oder zumindest bis ich durch eine rauchgranate durchlaufe.

 

microsoft hat einen eintrag dazu:

 

Timeout Detection and Recovery of GPUs through WDDM

 

kann mir einer erklären wie ich diese funktion der autom. wiederherstellung deaktiviere?? wäre für jeden rat äußerst dankbar!!

 

peace

MurphY

Share this post


Link to post
Share on other sites

Steht doch in dem Link:

 

The TDR-related registry keys are located under HKLM\System\CurrentControlSet\Control\GraphicsDrivers.

 

• TdrLevel: REG_DWORD. The initial level of recovery. The possible values are:

 

• TdrLevelOff (0). – Detection disabled.

 

 

Grüsse

 

Gulp

Share this post


Link to post
Share on other sites

hab ich probiert!

 

wenn ich dem registry pfad folge der in dem Link angegeben ist sind dort diese Tdr Eintrage nicht zu finden. Erstelle ich einen Key als REG_DWORD TdrLevelOff mit dem Wert 0 ändert sich trotzdem nichts...

 

deswegen hab ich gefragt ;)

peace

Share this post


Link to post
Share on other sites

Hab ich mir fast schon gedacht.

 

Ich vermute doch stark, dass die Schlüssel auch nur funktionieren, wenn hier zB spezielle Treiber mit dem Windows Driver Kit erstellt und verwendet werden.

 

Ich glaube kaum, dass die im Link genannten Schlüssel überhaupt bei "normalen" Treibern relevant sind.

 

Grüsse

 

Gulp

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...