Jump to content
Sign in to follow this  
astrologe3

Netzwerkdrucker + der an einen Systemanruf übergebene Datenbereich ist zu klein

Recommended Posts

Hallo,

 

Ich bin überzeugt, dass ich alles richtig konfiguriert habe, da es in einer Kombination XP-Notebook 1024 MB RAM / Celeron 1,6 GHz + freigeg. Netzwerkdrucker (ohne Kennwort) läuft. Jedoch mit selbem Drucker + anderem XP-Notebook 512 MB RAM / Penti 4 2,8 GHz (identisch konfiguriert) nicht *keuch. (Ihr lest richtig) . Der an einen Systemaufruf übergebene Datenbereich ist zu klein + dieser HP LJ4Plus-Drucker mit 18 MB RAM läuft hier nicht !

 

In beiden Fällen 32 Bit-Mobile CPU's. Drucker hängt an Win98SE - PC. Beide

Notebooks haben XP Home mit SP2. Auch vertauschte WLAN-Adapterkarten (WEP-Netzwerkschlüssel der Fritz Box eingetragen) helfen nicht weiter. Beide XP-Notebooks können jeweils direkt über USB-Parallel - Adapter-Verbindung

auf dem HP4LJet ausdrucken (Kabel muss dann halt zuvor umgestöpselt werden)

 

Ein Unterschied: 1. Notebook mit 1024 RAM sieht Fritz WLAN Box 7050 , das 512 RAM Notebook nicht - trotz jeweils aktivierter UPnP - Funktion.

 

Ich kann diesen Unterschied nicht in einen Zusammenhang zur Fehlermeldung sehen. Beide Notebooks stehen 1 m von der WLAN Box entfernt. Beide greifen anstandslos auf freigegebene Verzeichnisse vom nur Drucker-PC zu.

 

Auch das Hinaufsetzen des Zeitlimits des Druckers über den Win98SE-PC um das 4 fache : Reg.karte "Details" ZEITLIMIT: nicht gewählt auf 180 und Übertragungswiederholung auf 250 brachte nichts. Freigabename des Druckers: LJ4P_NETZ1

 

Würde mich über Rückmeldung - ideal: Lösungsvorschlag - sehr freuen, um

Netzwerkdrucker über das 512 MB - XP-Notebook am Win98SE - Drucker-PC

(dort an LTP1 über ECP) endlich zum Laufen zu bringen.

 

Freundliche Grüße, Peter :confused:

Share this post


Link to post

Als erstes würde ich mal den Treiber in Betracht ziehen. Also diesen austauschen. Wenn es es ein HP 4L ist, dann solltest Du auch den HP4 aus Windows oder den HP universal driver verwenden können. Dann weitersehen.

Chris

Share this post


Link to post

Hallo chrini1,

 

erstmal Danke für Deine Antwort. Das Ausprobieren eines aktuellen HP-Treibers für meinen

Laserjet 4 Plus (ein Paralleldrucker) ergab nichts neues ...

 

Vielmehr ergab ein Anruf bei einem Bastelkollegen zwei neue Überlegungen:

 

1. Das Notebook 512 RAM hat eine parallele Schnittstelle , die ich auch im Direktanschluss

des Druckers (egal mit welcher BIOS-MOde - Einstellung) nicht zum Laufen brachte, daher

der Direktausdruck nur mit USB-Adapterkabel auf Parallel möglich.

2. Auf dem 512 RAM - Notebook war nur das SP1 vorinstalliert - auch da ging der Drucker

weder übers Netzwerk noch über parallel - , das SP2 habe ich im abge-

sicherten Modus (keine blockierenden + notebookspeziellen Treiber geladen) installiert.

 

Beides zusammen erweckt den Verdacht, dass dieser Drucker in der Registry einen

bestimmten Wert für den Parallel-Direktbetrieb und zusätzlich woanders zum erfolg-

reichen Ansprechen des sichtbaren + freigegebenen Netzwerkdruckers am Win98SE-PC

braucht. Doch welche Werte und wo eintragen ! (kann über Tuneup Utilities 2006 mit

Registrierungseditor suchen und rein) - Umgebungsvariable ? -

 

Der Drucker läuft über USB direkt + auch per Netz am anderen Notebook 1024 RAM, auf dem das SP2 vorinstalliert war und das keine parallele Schnittstelle hat , mit beiden Betriebsarten weiterhin reibungslos.

 

Anm.: Auch der Austausch / Neuinstallation der WLAN-Adapterkarten (von 510 und 610 jew. Fa. D-Link) brachte nichts.

 

*grübel + keuch

 

LG, Peter

Share this post


Link to post

Hallo Peter und herzlich Willkommen im Board.

 

Als erstes mal, HP Laserjet benutzen meist den PCL5 und PCL6 Treiber von HP.

Warum hast Du das SP2 im abgesicherten Modus Installiert?

Siehst Du denn auf deinem Problem NB den drucker?

 

Stoni

Share this post


Link to post

Hallo Stoni,

 

HP-LJ4P - Drucker arbeitet mit PCL5, daher diesen Treiber erfolglos versucht. SP2 habe ich im abgesicherten Modus drüberinstalliert, um Konflikten mit speziellen Notebook-Treibern

aus dem Weg zu gehen. Der HP läuft übers andere Notebook mit dem angebotenen

XP-Treiber sowohl lokal (USB / Para-Adap), als auch übers Netz (WLAN).

Auf Problem NB sehe ich sowohl alle Arbeitsgruppen-PC und auch den Drucker am Win98SE-PC.

Da ein Mausklick zum Öffnen (/ ... / Eigenschaften/Reg.karte "Allg." - Testseite) das

XP-Dienstprog. abstürzen ließ (explorer.exe) , habe ich dann den Netzwerkdrucker

erstmals am Problem-NB per Druckerinstallations-Assist. einzurichten

(was ja am anderen NB sofort ging) versucht , dabei kam es zu dieser Fehlermeldung:

der an einen Systemanruf übergebene Datenbereich ist zu klein --- dann friert auch XP

schnell ein. Drucker bleibt auch nach Löschung als Netzwerkdrucker sichtbar.

 

Nochmal SP2 im Normal-XP-Modus installieren (zuvor deinstallieren, falls möglich ?)

 

Grüsse, Peter

Share this post


Link to post

Hi, installiere auf dem funktionierenden Notebook mal irgendeinen Drucker an LPT1, gib den frei und versuche den auf dem "defekten" Notebook zu verbinden+Testseite. Kommen da auch Fehlermeldungen?

 

Gruß Pusi

Share this post


Link to post

Hallo Peter,

 

So wie es aussieht, hast Du weniger ein Problem mit dem Drucker sondern mit deinem OS.

Explorer.exe und Co.

Steht denn was in der Ereignisanzeige dazu?

Deinstalliere SP2 nochmal und dann im normalen Modus installieren.

 

Stoni

Share this post


Link to post

Hallo Pusi, Hallo Stoni,

 

habe zuerst den Drucker am OK-Notebook freigegeben. Am Problem-NB zwar gesehen, aber keinen Zugang bekommen.

 

Danach Drucker parallel am Problem-NB angeschlossen. Ging, jedoch kam Meldung beim Versuch die Testseite zu drucken, dass kein Papier im Drucker sei.

 

Darauhin Deinstalltion SP2 am Problem-NB, Neustart, Neuinstallation SP2 im Normalmodus,

jedoch weiterhin die Fehlermeldung mit dem Systemsaufruf (...), sobald der

Drucker als Netzwerkdrucker am Problem-NB miitels des Druckerinstallationsassist. markiert

bzw. ausgewählt wird.

 

Nur noch kpl. Neuinstallation von XP(incl. SP1) und danach gleich SP2 möglich ?

 

Gruesse, Peter

Share this post


Link to post

Hallo Peter,

 

es ist schon möglich , daß Du dir bei der Installation im abgesicherten Modus dein OS etwas dureinander gebracht hast.

Die sauberste Lösung ist natürlich eine Neuinstallation. Danach direkt das SP2 drauf.

Hast Du mal UPNp abgeschaltet und probiert?

 

Stoni

Share this post


Link to post

Hallo Stoni,

 

erst mal Danke für Deine Denkanstösse, wie natürlich auch den anderen zuvor.

 

Nachdem ein Drüberbügeln des XP+Sp1 auf dem Problem-NB nichts half und nach Installation des SP2 sogar der WLAN-Button für den WLAN-Chip deaktiviert blieb, entschloss

ich mich zum Hardcore und versetzte dieses Medion 40100, das ich gebraucht erwarb, in den Auslieferungszuzustand mit jeder Menge Hotfixes, die die Tage zuvor nicht, in der Sofewareliste auftauchten. Au Backe, man gönnt sich ja sonst nichts. Aber nicht zur Strafe,

nur zur Übung ;-) . Als alle Treiber korrekt eingebunden waren (der WLAN-Button funktionierte auch ein / aus, mehr nicht), installierte ich das SP2 und danach die zusätzliche

WLAN-Adapterkarte. Hotfixes stehen immer noch in Softwareliste ...

 

( Das Hinaufsetzen des Zeitlimits des Druckers über den Win98SE-PC um das 4 fache : Reg.karte "Details" ZEITLIMIT: nicht gewählt auf 180 und Übertragungswiederholung auf 250 behielt ich ebenso bei, wie auch den Freigabenamen )

 

Danach gerade Antivir + Adobe Reader installiert und dann gleich Registry greinigt + defragmentiert (meine Güte: soviel Müll nach sowenig Installationen) und dann Platte defragmentiert. Dann WLAN-Adapterkarte eingerichtet

... WLAN-Box wurde ebenso gesehen / erkannt wie der Win98PC + freigeg. Drucker.

Dann diese Karte raus und dann dasselbe mit eingeschaltetem WLAN-Button für den WLAN-PRISM-Chip .

Nachdem bei beiden "WLAN-Geräten" unabhängig voneinander der Testseiten-Ausdruck lief hab ich den Drucker dann über den USB-Parallel-Adapter auch noch erfolgreich lokal installiert, da weiterhin parallel - trotz ECP , wie beim Win98SE-PC - nichts zu machen ist. Wahrscheinlich hat parallele Schnittstelle 'nen Lötstellen-Schlag (Druckermenü flackerte). ... Und alles während das andere NB ausgeschaltet war.

 

Irgendwie war wohl die Installation des NB zuvor nicht sauber gemacht geworden.

 

Ist schon ne Weile her, dass ich meinen MCP auf NT machte, aber bisschen was wusste

ich doch noch ;-)

 

Ihr habt was gut ... z.B. Peter Kuschminder: Astrologie, Klassische Astrologie | Astrologische Hilfe zur Selbsthilfe und mehr

 

Nochmals Danke !

 

Grüsse, Peter

Share this post


Link to post

Hallo Peter,

Danke für die Rückmeldung. Schön das es wieder läuft.

Aber stell mal bei dem 98 noch EPP+ECP ein.

 

Stoni

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...