Jump to content
Sign in to follow this  
Andy74

Richtlinie wird nicht übernommen.

Recommended Posts

Ich habe hier ein sehr merkwürdiges Problem auf Windows XP Clients.

 

Ich habe hier eine selbst gebaute Gruppenrichtlinie, welche die Proxyeinstellungen und die Startseite im Internetexplorer ändert. Klappt auch wunderbar. Beim allerersten Anmelden am System werden die Einstellungen korrekt übernommen.

"HKCU \Software \ Microsoft \ Windows \ CurentVersion \ Internet Settings" und dort der Wert für "AutoConfigURL"

 

Wenn nun ein Anwender den Wert ändert, sollte der Wert über die Gruppenrichtlinie doch eigentlich wieder angepasst werden.

Genau das funktioniert nicht.

 

Die Richtlinie an den Clients wird irgendwie nicht übernommen.

Wenn ich mir die Richtlinien auf den Clients mit RSOP.MSC anzeigen lasse, werden die Einstellungen korrekt angezeigt. In der Registry sind sie jedoch nicht eingetragen.

 

Wenn ich mir die Gruppenrichtlinienergebnisse in der Gruppenrichtlinienverwaltung anzeigen lasse, werden die Werte auch korrekt angezeigt.

 

Auch nach einigen Reboots wird die Richtlinie nicht übernommen.

Mach ich dann GPUPDATE /FORCE auf einem Client, ist die Richtlinie sofort verfügbar und korrekt übernommen.

 

 

Das Ganze ist wie oben zu sehen ist, eine Benutzerrichtlinie.

Der Loopbackverarbeitungsmodus steht aber aus "Ersetzen", weshalb die Richtlinie also am Computer hängt. Sollte aber eigentlich egal sein, weil bei der erstanmeldung klappt es ja.

 

 

DNS und Namensauflösung passt auch.

 

 

Wo liegt das Problem ?

Share this post


Link to post

Eben nochmal weiter getestet.

 

Gleicher Effekt auch bei einer Standardrichtlinie (Bildschrimschoner).

In der Ereignisanzeige sind keine Fehler

Share this post


Link to post
.....Ich habe hier eine selbst gebaute Gruppenrichtlinie, welche die Proxyeinstellungen und die Startseite im Internetexplorer ändert.
Warum wird nicht die Richtlinie für IE-Wartung verwendet?

Share this post


Link to post

Moin,

 

wo fang ich denn an?

Also,

 

1.

Warum wird nicht die Richtlinie für IE-Wartung verwendet?

2. Das hier -> GPMC hast du installiert (server 2003 vorrausgesetzt) oder? Wenn nicht -> Schande :D

3. Schau dich hier -> www.gruppenrichtlinien. mal um.

4. Beachte vor allem die Richtlinie "Computerkonfiguration/Administrative Vorlagen/System/Gruppenrichtlinien"

5. Alternativ kann man "GPUPDATE /FORCE" auch per Logon-Skript einbinden ;)

 

MfG,

 

Neomis

Share this post


Link to post
Warum wird nicht die Richtlinie für IE-Wartung verwendet?

 

Gute Frage, ist aber für das Problem eigentlich egal, weil das Problem ja auch beim Bildschirmschoner vorliegt .... und das ist eine normale Standardrichtlinie

Share this post


Link to post
Moin,

 

wo fang ich denn an?

Also,

 

1.

2. Das hier -> GPMC hast du installiert (server 2003 vorrausgesetzt) oder? Wenn nicht -> Schande :D

3. Schau dich hier -> www.gruppenrichtlinien. mal um.

4. Beachte vor allem die Richtlinie "Computerkonfiguration/Administrative Vorlagen/System/Gruppenrichtlinien"

5. Alternativ kann man "GPUPDATE /FORCE" auch per Logon-Skript einbinden ;)

 

MfG,

 

Neomis

 

Zu 1.)

siehe oben

 

Zu 2.)

Ja, klar. Bringt mich bei dem Problem aber erstmal nicht weiter

 

zu 3.)

Werde ich mal testen

 

Zu 4.)

Dachte ich auch schon daran, behebt aber das Problem eigentlich nicht, sondern umgeht es nur ;)

Share this post


Link to post
Gute Frage, ist aber für das Problem eigentlich egal, weil das Problem ja auch beim Bildschirmschoner vorliegt .... und das ist eine normale Standardrichtlinie

 

Dein eigentliches Problem hat auch nix mit der IE-Wartungsrichtlinie zu tun, sondern mehr mir dem GP-Übernahme/Aktualisierungsintervall (wie ich oben schon geschrieben hab).

Es war lediglich 'n versteckter Hinweis nach dem Motto: Warum kompliziert, wenn's auch einfach geht^^

Share this post


Link to post
....Mach ich dann GPUPDATE /FORCE auf einem Client, ist die Richtlinie sofort verfügbar und korrekt übernommen......?
Nun, handelt es sich um XPs?

 

Ist die Richtlinie ".... immer auf das Netzwerk warten." aktiviert und wirksam?

Share this post


Link to post

Hallo Andy74,

 

wie lange wartest Du mit dem Neustart und damit auf das Aktualiesieren/Wiederanwenden der Richtlinie?

 

Gruß Robert

Share this post


Link to post
Dein eigentliches Problem hat auch nix mit der IE-Wartungsrichtlinie zu tun, sondern mehr mir dem GP-Übernahme/Aktualisierungsintervall (wie ich oben schon geschrieben hab).

Es war lediglich 'n versteckter Hinweis nach dem Motto: Warum kompliziert, wenn's auch einfach geht^^

 

Ja, klar mit GPUPDATE im Logonscript wäre das ganze Problem sehr schnell gelöst.

Aber wie gesagt, das Problem ist damit ja nicht gelöst sondern nur umgangen ;)

 

 

Nun, handelt es sich um XPs?

 

Ist die Richtlinie ".... immer auf das Netzwerk warten." aktiviert und wirksam?

 

Ja, alles WinXP SP2.

Diese Richtlinie war noch nicht aktiv. Habe ich aber auf einem Client heute morgen von Hand aktiviert. Hat aber auch nichts gebracht.

 

 

Hallo Andy74,

wie lange wartest Du mit dem Neustart und damit auf das Aktualiesieren/Wiederanwenden der Richtlinie?

 

Gruß Robert

 

Ehrlich gesagt gar nicht. Ich starte den Rechner, schaue ob die Einstellung da ist, wenn nicht starte ich ihn sofort neu.

Aber die Richtlinien müssten doch beim Rechnerneustart übernommen werden, oder ?

Unabhängig davon wie lange der Rechner an ist. Oder hab ich da einen Denkfehler ?

Share this post


Link to post

Die Loopback-Verarbeitung ist m.E. das Problem. Wenn der Rechhner startet und die Computer-Richtlinie anwendet, gibt es noch keinen Current User (niemand angemeldet) -> Wert kann nicht in Registry geschrieben werden. Wenn Du mit angemeldetem Benutzer (Current User vorhanden) die GPOs refreshst, wird die Richtlinie korrekt übernommen.

Share this post


Link to post

Also doch per Logon-Script :p :D

 

Edit: oder du setzt den Aktivierungsintervall auf ein minimum...(ohne Gewähr)

Share this post


Link to post
Die Loopback-Verarbeitung ist m.E. das Problem. Wenn der Rechhner startet und die Computer-Richtlinie anwendet, gibt es noch keinen Current User (niemand angemeldet) -> Wert kann nicht in Registry geschrieben werden. Wenn Du mit angemeldetem Benutzer (Current User vorhanden) die GPOs refreshst, wird die Richtlinie korrekt übernommen.

 

 

Die Loopback-Modus legt nur fest, von wo der Benutzer- und der Computerteil der Richtlinie geholt werden soll.

Bei ERSETZEN wird der Benutzerteil also aus der OU geholt, in der sich das Computerkonto befindet.

 

 

Letztendlich hat das aktivieren der Richtlinie "Gruppenrichtlinienobjekte auch ohne Änderungen bearbeiten" für die Lösung gesorgt.

 

Trotzdem Danke allen :thumb1:

Share this post


Link to post
Die Loopback-Modus legt nur fest, von wo der Benutzer- und der Computerteil der Richtlinie geholt werden soll.

Ups, hab da was durcheinandergeworfen und das erste Posting falsch interpretiert (schneller getippt als gedacht ;) ). Danke für die Korrektur.

Share this post


Link to post
Die Loopback-Modus legt nur fest, von wo der Benutzer- und der Computerteil der Richtlinie geholt werden soll.

Bei ERSETZEN wird der Benutzerteil also aus der OU geholt, in der sich das Computerkonto befindet.

Nur ergänzend :): Das stimmt aber auch nicht so ganz, es werden die Benutzerkonfigurationseinstellungen angewendet, in dessen Reichweite sich das Computerkonto befindet, auf dem die Loopbackeinstellung angewendet wird, also für die Benutzer, die sich an diesem Rechner anmelden. Solch ein GPO kann in die OU gelinkt werden, in der sich das Computerkonto befindet, es wirken aber auch Benutzerrichtlinien, die z.B. in die Domäne oder Standort (also oberhalb der OU des Computers) gelinkt wurden ...

http://www.mcseboard.de/windows-forum-ms-backoffice-31/loopbackmodus-102768.html#post631731

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...