Jump to content
Sign in to follow this  
sabine79

Probleme mit Domäne

Recommended Posts

Hallo Zusammen,

 

Leider sind die einzigen 2 DC's ausgefallen u. ich muste ein DisasterRecovery durchführen.

 

Server1:

dcdiag:

Starting test: Advertising

Fatal Error:DsGetDcName (Server1) call failed, error 1355

The Locator could not find the server.

......................... Server1 failed test Advertising

Starting test: frsevent

There are warning or error events within the last 24 hours after the

SYSVOL has been shared. Failing SYSVOL replication problems may cause

Group Policy problems.

......................... Server1 failed test frsevent

Warning: DcGetDcName(GC_SERVER_REQUIRED) call failed, error 1355

A Global Catalog Server could not be located - All GC's are down.

Warning: DcGetDcName(TIME_SERVER) call failed, error 1355

A Time Server could not be located.

The server holding the PDC role is down.

Warning: DcGetDcName(GOOD_TIME_SERVER_PREFERRED) call failed, error 1355

A Good Time Server could not be located.

Warning: DcGetDcName(KDC_REQUIRED) call failed, error 1355

A KDC could not be located - All the KDCs are down.

netdiag:

Domain membership test . . . . . . : Failed

[WARNING] Ths system volume has not been completely replicated to the local machine. This machine is not working properly as a DC.

DC discovery test. . . . . . . . . : Failed

[FATAL] Cannot find DC in domain 'Domäne'. [ERROR_NO_SUCH_DOMAIN]

DC list test . . . . . . . . . . . : Failed

'Domäne': Cannot find DC to get DC list from [test skipped].

LDAP test. . . . . . . . . . . . . : Failed

Cannot find DC to run LDAP tests on. The error occurred was: Die angegebene Domäne ist nicht vorhanden, oder es konnte keine Verbindung hergestellt werden.

[WARNING] Cannot find DC in domain 'Domäne'. [ERROR_NO_SUCH_DOMAIN]

 

Server2:

dcdiag:

Starting test: Advertising

Fatal Error:DsGetDcName (Server2) call failed, error 1355

The Locator could not find the server.

......................... Server2 failed test Advertising

Starting test: frsevent

There are warning or error events within the last 24 hours after the

SYSVOL has been shared. Failing SYSVOL replication problems may cause

Group Policy problems.

Starting test: FsmoCheck

Warning: DcGetDcName(GC_SERVER_REQUIRED) call failed, error 1355

A Global Catalog Server could not be located - All GC's are down.

Warning: DcGetDcName(PDC_REQUIRED) call failed, error 1355

A Primary Domain Controller could not be located.

The server holding the PDC role is down.

Warning: DcGetDcName(TIME_SERVER) call failed, error 1355

A Time Server could not be located.

The server holding the PDC role is down.

Warning: DcGetDcName(GOOD_TIME_SERVER_PREFERRED) call failed, error 1355

A Good Time Server could not be located.

Warning: DcGetDcName(KDC_REQUIRED) call failed, error 1355

A KDC could not be located - All the KDCs are down.

netdiag:

DC discovery test. . . . . . . . . : Failed

[FATAL] Cannot find DC in domain 'Domäne. [ERROR_NO_SUCH_DOMAIN]

DC list test . . . . . . . . . . . : Failed

'Domäne': Cannot find DC to get DC list from [test skipped].

Trust relationship test. . . . . . : Failed

'Domäne': Cannot find DC to get DC list from [test skipped].

[FATAL] Secure channel to domain 'Domäne' is broken. [ERROR_NO_LOGON_SERVERS]

LDAP test. . . . . . . . . . . . . : Failed

Cannot find DC to run LDAP tests on. The error occurred was: Die angegebene Domäne ist nicht vorhanden, oder es konnte keine Verbindung hergestellt werden.

[WARNING] Cannot find DC in domain 'Domäne'. [ERROR_NO_SUCH_DOMAIN]

 

Kann mir jemand weiterhelfen?

 

Gruß, Bine

Share this post


Link to post

Hallo,

 

sorry, aber das würde jeden Rahmen einer Online-Hilfe sprengen.

Da stimmt bei beiden DCs nicht viel.

Ich würde dir empfehlen, einen externen Dienstleister zur Seite zu holen.

Share this post


Link to post

mahlzeit,

 

Infoßs wärn noch gut!

 

"Leider sind die einzigen 2 DC's ausgefallen u. ich muste ein DisasterRecovery durchführen"

 

Und das eventlog ist nach dem DisasterRecovery? oder wie oder was:confused:

 

Erzähl uns doch mal bitte was du da so alles hast...clients,server und vorallem wie bzw. wovon haste das ADS versucht wiederherzustellen..

Share this post


Link to post

Hallo Bine,

offensichtlich hast du beim Disasterrecovery, evtl. auch schon lange davor, mehr oder weniger alles falsch gemacht. Was??? Wenn du uns deine Schritte nicht sagen willst, woher sollen wir es wissen???

 

Aber zu deiner Frage: Ich glaube nicht, dass irgendjemand diese beiden DCs in diesem Zustand wieder auf die Fuesse stellen kann

 

cu

blub

Share this post


Link to post

Hallo Zusammen,

 

es gibt nur 2 DC's in der Domäne und es handelt sich um Windows2003 SP1 Server. Auf den Servern läuft auch noch ein ADintegrierter DNS-Server.

Ich musste wegen Hardwareausfällen die beiden DC's wiederherstellen.

Laut den gesicherten Eventlogs hatten die Server vor dem Hardwareausfall kein Problem.

Die Sicherungen der DC's wurden mit Hilfe von Arcserve durchgeführt.

Die beiden DC's habe ich mit Hilfe der ASR-Diskette und Arcserve wiederhergestellt.

 

Ich habe mir den DNS-Server angesehen. Hier sind alle notwendigen Einträge vorhanden.

Das AD läst sich über "AD User und Computer" nur anzeigen wenn ich statt des Domännames einen der beiden DC's angebe.

 

Laut replmon findet eine Replikation der beiden DC's statt.

 

Ich kann mich ohne Probleme am DC mit dem Adminstrator der Domäne anmelden.

 

Ich habe versucht am Server2 wieder den SecureChannel herstellen (leider ohne erfolg):

KDC-Dienst auf dem Server2 beendet und auf manuell gesetzt

klist purge auf dem Server1 ausgeführt

auf dem Server2 mit netdom das Passwort zurückgesetzt

Server2 gebootet

KDC-Dienst wieder gestartet und auf automatisch gesetzt

 

Gruß, Bine

Share this post


Link to post

Dein größtes (wenn auch evtl nicht einziges) Problem scheint DNS zu sein. Hat nur ein Server DNS? Zeigen ansonsten beide Server auf einen DNS-Server? Was passiert bei nslookup "domänenname"?

Share this post


Link to post

Hi Biene,

Ist doch schonmal was.

Ich wuerde nochmal beginnen und nur einen DC vom Backupmedium wiederherstellen. Wenn der wieder komplett sauber dreht (fsmorollen, dcdiag, eventlogs etc.) , dann die Objekte des 2.-ten DC aus der Domanendatenbank mit "metadatacleanup" (such bei Bedarf hier im Forum nach dem entsprechenden MS-Artikel) entfernen. Anschliessend den 2.-ten Rechner neu aufsetzen und mit dcpromo neu aufnehmen. So funktioniert der Restore jedenfalls.

 

Der Restore mehr als eines DCs in einer Domaene ist schwierig, weil eben nicht die DCs im Ursprungszustand wiederhergestellt werden, sondern sich intern (z.B. GUIDs, Passwoerter) an einigen Stellen etwas veraendert.

 

cu

blub

Share this post


Link to post

Halo Zusammen,

 

@woiza

Jeder DC ist auch ein ad-integrierter DNS-Server (es gibt nur eine Forwardzone)

Ausgabe mit nslookup:

Server: Unknown

Adresses:192.168.1.4

Name: Domäne

Adresses: 192.168.1.4, 192.168.1.14

 

@IThome:

Ich habe das Log angepasst, da ich die Orginaldaten nicht weitergeben darf.

 

 

ich habe endeckt, dass die Syvol und netlogon-Freigabe bei beiden DC's nicht vorhanden war. Mit Hilfe des KB-Artikels 316790 (The Sysvol and Netlogon Shares Are Missing After You Restore a Domain Controller from Backup) konnte ich diese wieder anlegen.

Anschließend habe ich am DC1 seine eigene IP-Adresse als bevorzugten DNS-Server eingetragen.

Ich habe mir jeden Eintrag im DNS-Server nochmals angesehen -> es war ein Eintrag zuviel, diesen habe ich gelöscht (es hatte sich auch die 2.Netzwerkkarte vom DC im DNS registriert)

Jetzt kann ich die "AD User und Computer-Console" öffnen und bekomme die Domäne angezeigt.

Repliaktion mit replmon funktionierte ohne Probleme.

bei netdiag und dcdiag werden keine Fehler angezeigt

 

wenn ich mit dem Tool "nltest" arbeite bekomme ich trotzdem noch die Meldung: error_no_such_domain.

Ist das ein Problem?

Share this post


Link to post

noch eine ergänzung:

 

server1:

nltest /query

erfolgsmeldung

nltest /sc_query:domäne

1355 0x54b error_no_such domain

 

Server2:

nltest /query

1311 error_no_logon_servers

nltest /sc_query:domäne

erfolgsmeldung

 

Es läst sich ohne Probleme ein User im AD anlegen. In den eventlogs ist auch kein Fehler zu erkennen.

Share this post


Link to post

hast du in den directoryservice-eventlogs die Meldung 13516 und zeigt "repadmin /showreps" bzw. "repadmin Replsummary" auf beiden DCs keine Fehler an? Dann und nur dann kannst du davon sprechen, dass deine Filereplikation und deine Domaenenreplikation wirklich funktionieren

 

cu

blub

Share this post


Link to post

Hallo Zusammen,

 

es sind keine Fehlermeldungen in den Eventlogsvorhanden. Laut "repadmin" gibt es keine Replikationsprobleme.

Seit heute taucht der Fehler "no such domain" nicht mehr auf.

 

Danke für eure Hilfe.

 

Gruß, Bine

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...