Jump to content
Sign in to follow this  
Loop

Gruppenrichtlinie mit Computer-Startscript - was ist hier falsch?

Recommended Posts

Hallo Board,

 

folgende Ausgangssituation:

 

Ich habe einer OU ein GPO zugewiesen, das Computereinstellungen enthält (Berechtigungsänderungen für das Dateisystem sowie Kopier- und Registriervorgänge). Ziel des Ganzen ist es (wurde hier auch schon mehrfach besprochen, um diese Problematik geht es in diesem Fall aber nicht speziell), Schriften automatisch zu installieren.

 

Das GPO wird korrekt zugewiesen, GPRESULT zeigt mir die erfolgte Anwendung, die Dateisystemberechtigungen werden erfolgreich übernommen. ABER: Unter Startscripts in derselben GPO habe ich ein Script mit dem Namen copy_fonts.bat angelegt, das folgendenden Inhalt hat:

 

XCOPY \\SERVERNAME\FRUTIGER\*.* %SYSTEMROOT%\FONTS /yes

 

%systemroot%\system32\REG ADD "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Fonts" /v "Frutiger LT 45 Light (PostScript)" /t reg_sz /d LTE50327.pfm /f

%systemroot%\system32\REG ADD "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Fonts" /v "Frutiger LT 45 Light Italic (PostScript)" /t reg_sz /d lte50328.pfm /f

 

.....

 

Leider wird das Script nicht im Ansatz ausgeführt, weder die Schriften werden kopiert noch die REGs gesetzt. Ist das ein Berechtigungsproblem? Das Script wird doch VOR dem Logon als SYSTEM ausgeführt. Hat dieser User dazu keine Berechtigung? Wenn "nein", kann man das Script unter anderem Account laufen lassen?

 

Danke und viele Grüße

Loop

Share this post


Link to post
Share on other sites

Hat der Computer bzw. die Computer Leseberechtigung auf die Freigabe "FRUTIGER" und auf die Dateien in dem Verzeichnis?

Funktioniert das Skript denn unter einem Benutzer? Evtl. einfach mal ein

echo Dateien kopiert>C:\copy-log.txt

in die Datei einfügen, damit man überprüfen kann, ob das Skript überhaupt aufgerufen wird.

Share this post


Link to post
Share on other sites

Danke für den Tipp, das hat nun funktioniert, das Script wird ausgefüht. Leider habe ich jetzt aber den klassischen Fehler (der hier auch schon öfter besprochen wurde), dass die Schriften zwar in \FONTS angezeigt werden, nicht aber z.B. in Office... da muss ich jetzt mal suchen.

 

Danke!

Loop

Share this post


Link to post
Share on other sites

Versuche unter

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

 

Den Font mit dem richtigen Namen hinzuzufügen. Alterativ genügt es, in der Systemsteuerung "Schriftarten" aufzurufen.

 

-Zahni

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...