Jump to content

Citrix Programm läßt sich über ICA oder RDP nicht starten


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Forum,

 

wir haben auf unserer Citrix Farm eine neue Anwendung installiert. Diese läuft bis auf 2 Server ohne Probleme.

Auf diesen Servern läßt sich die Anwendung nicht über die Remotedesktopverbindung oder über den ICA Client starten. Es gibt keine Fehlermeldungen und auch keine Einträge im Eventlog. Im Taskmanager kann man beobachten das die Anwendung kurz startet und dann sofort wieder verschwindet.

Rufe ich die Anwendung lokal auf den Servern auf funktioniert sie ohne Probleme.

 

Jemand eine Idee woran dies liegen könnte?

 

Danke

Link to comment

Nein, ich meinte welcher Berechtigungslevel eingestellt ist.

Bei Full Security bedeutet das, dass ein höherer Sicherheitslevel vorhanden ist. Dann können teilweise Programme nicht mehr richtig laufen.

Wenn Du das Programm lokal startest, machst Du das mit Adminrechten? Wenn ja, versuch das Programm mit normalen Benutzerrechten lokal zu starten.

 

Eventuell könnte es auch sein, dass der Pfad dieser Programme auf den falschen Ort zeigen.

 

Gruss

Ritchie

Link to comment
Nein, ich meinte welcher Berechtigungslevel eingestellt ist.

Bei Full Security bedeutet das, dass ein höherer Sicherheitslevel vorhanden ist. Dann können teilweise Programme nicht mehr richtig laufen.

Wenn Du das Programm lokal startest, machst Du das mit Adminrechten? Wenn ja, versuch das Programm mit normalen Benutzerrechten lokal zu starten.

 

Eventuell könnte es auch sein, dass der Pfad dieser Programme auf den falschen Ort zeigen.

 

Gruss

Ritchie

Lokal geht das Programm mit Adminrechten und mit ganz normalen Benutzerrechten. Der Pfad ist auch identisch.

Die Berechtigungen auf Pfade und ini´s sind auch identisch

Link to comment

Langsam gehen mir die Ideen aus.

 

Ich kenne das Problem schon auch. z.B. bei Lotus Notes. Aber da fehlt dann meistens die Notes.ini die beim Benutzer in seinem Homedirectory fehlt.

 

Ich nehme mal an, dass alle Benutzer dieses Programm auf den beiden Servern nicht starten können, aber auf den anderen schon. Oder?

 

Wird das Programm durch eine Published Application gestartet oder ist das Programm-Icon im All User Profil abgelegt?

Vielleicht fehlt beim Published Application irgendein Parameter bei diesen zwei Servern :confused:

 

Ansonsten könnten auf Fileebene die Berechtigungen nicht gleich sein.

 

By the way: Welches MS Betriebssystem und Citrix Version setzt Ihr ein?

 

Gruss

Erich

Link to comment
Darf man auch erfahren, um welche Anwendung es sich handelt?

Vielleicht ist diese schlicht und ergreifend nicht Terminal Server fähig.

 

Hast Du schonmal den Support der Anwendung kontaktiert?

Das wäre für mich jedenfalls der allererste Schritt.

 

 

Moin,

 

ist SAP 6.40. Habe es gestern Abend nochmal komplett neu installiert, nach Anleitung Citrix Knowledge Base. Es geht ja nur auf 2 Servern nciht, auf 7 anderen mit der gleichen Installation geht es.

 

Gruss

Link to comment
Was sagen Filemon, Regmon und Eventlog?

 

Die Anwendung lässt sich auch als Admin nicht via ICA oder RDP starten?

 

Ein Lizenzproblem kann man wohl ausschließen, dass sich das Problem ja offensichtlich nur auf eine Anwendung konzentriert.

 

Eventlog schreibt keinerlei Einträge. Filemon steigt aus sobald ich SAP öffne aber auch nur bei einer RDP Verbindung.Im Eventlog wurde Filemon mit der Speicherverletzung eingetragen "Der Vorgang"read" konnte nicht auf dem Speicher durchgeführt werden."

 

Auf den anderen Server aber nicht.

Als Admin läßt sie sich via ICA oder RDP auch nicht starten.

Es geht nur SAP alles andere läuft ohne Probleme. Wobei ich nicht glaube das der Fehler an SAP hängt, da die anderen Server gehen.

Link to comment

Wenn Du Dich als Admin mit mstsc /console via RDP auf einen der betreffenden Server verbindest wie schaut es dann aus?

 

Ist jedenfalls ein interessantes, wenn auch besch.... Problem! Es ist schwer noch irgendwo einen Ansatz zu finden, da Du so ziemlich alles ausprobiert hast. Ein Telefonat mit dem ein oder anderen SAP Guru könnte aber vielleicht trotzdem nicht schaden. Ich denke eher, dass es an SAP als an den TS liegt. Wie Du schon richtig geschrieben hast, auf den anderen Servern läuft es...

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...